Медленная прорисовка окон.

Walker

New member
Сообщения
4
#1
Здравствуйте. Установили астру Смоленск 1.6 на рабочую станцию и на сервер. На рабочей станции все работает отлично, а на сервере при открытии любого окна происходит медленная прорисовка, "тиринг". Видяха встроенная - aspeed.
На вики Астра видел две записи. Использовал (статья про использование modesetting при aspeed и статья про настройки файлов theme), ситуация только немного улучшилась, но тиринг все равно остался. Думал проц в энергосбережении, но нет, все нормально (xeon e5 - 2620). Может кто сталкивался, может еще что можно сотворить? Или это все, "алес", так и придется мучаться?
 

ZUZ

New member
Сообщения
5
#2
Здравствуйте. Установили астру Смоленск 1.6 на рабочую станцию и на сервер. На рабочей станции все работает отлично, а на сервере при открытии любого окна происходит медленная прорисовка, "тиринг". Видяха встроенная - aspeed.
На вики Астра видел две записи. Использовал (статья про использование modesetting при aspeed и статья про настройки файлов theme), ситуация только немного улучшилась, но тиринг все равно остался. Думал проц в энергосбережении, но нет, все нормально (xeon e5 - 2620). Может кто сталкивался, может еще что можно сотворить? Или это все, "алес", так и придется мучаться?
У меня сейчас похожая ситуация.
Просто нереальный тиринг.
Думал выключена вертикальная синхронизация.
Но нет, она включена. Но, походу, видеокарта/её драйвер неправильно выставляют частоту обновления дисплея (вместо 60 ставит 27 или 48) и по этому такой дикий тиринг (то есть не один/два разрыв при перемещении окна, а до 20).
У меня железо:
AMD FirePro V4800 и 28" UHD монитор Samsung U28E590D (подключена через DP, вроде как работает FreeSync, но это не точно).
Запустил glxgears и он выдал, что развёртка всего 27 кадров (при разрешении 2560х1440)
После смены разрешения на 1920х1080 выдало уже 48 кадров. Тиринга при перемещении окон стало поменьше, но всё равно в районе десяти разрывов).

PS Если запустить с выключенной привязкой в герцовке, то выдаёт в районе 1470 кадров (строчкой vblank_mode=0 glxgears).
 

Walker

New member
Сообщения
4
#3
Спасибо. В понедельник попробую, отпишусь. Уменьшение разрешения (с 1920х1080) пробовал, не спасает.
 

Walker

New member
Сообщения
4
#4
У меня сейчас похожая ситуация.
Просто нереальный тиринг.
Думал выключена вертикальная синхронизация.
Но нет, она включена. Но, походу, видеокарта/её драйвер неправильно выставляют частоту обновления дисплея (вместо 60 ставит 27 или 48) и по этому такой дикий тиринг (то есть не один/два разрыв при перемещении окна, а до 20).
У меня железо:
AMD FirePro V4800 и 28" UHD монитор Samsung U28E590D (подключена через DP, вроде как работает FreeSync, но это не точно).
Запустил glxgears и он выдал, что развёртка всего 27 кадров (при разрешении 2560х1440)
После смены разрешения на 1920х1080 выдало уже 48 кадров. Тиринга при перемещении окон стало поменьше, но всё равно в районе десяти разрывов).

PS Если запустить с выключенной привязкой в герцовке, то выдаёт в районе 1470 кадров (строчкой vblank_mode=0 glxgears).
К сожалению, при vblank_mode=0 glxgears, стало только хуже. Разрешение экрана пробовал ранее, ничего не меняется, все как прорисовывалось медленно так и продолжает. Удалось только уменьшить этот процесс, а избавиться пока никак не удается. Придется по ходу работы искать решение.
 

ZUZ

New member
Сообщения
5
#5
К сожалению, при vblank_mode=0 glxgears, стало только хуже. Разрешение экрана пробовал ранее, ничего не меняется, все как прорисовывалось медленно так и продолжает. Удалось только уменьшить этот процесс, а избавиться пока никак не удается. Придется по ходу работы искать решение.
Эмммм.
Команда glxgears вызывает простенький рендер, который позволяет определить текущую частоту вывода изображения на экран. А команда vblank_mode=0 glxgears для вызываемого рендерера отключает ограничение на количесвто кадров и мы видим максималную производительность видеокарты (вдруг с драувеарми что-то не то и она дико тормозит) и получаем обычно результат в тысячах кадров. Никакие настройки при этом не изменяются !
 

ZUZ

New member
Сообщения
5
#7
на 1.5 на серверах была такая проблема, решалась вот так
Эмм. Не совсем понятно.
Совет имеет отношение ко всем видеокартам (в случае отсутствия установленного припроетарного драйвера) или только для определенных (Матрокс?).
И да, файла xorg.conf уже давно нигде не видел. А создавать не хотелось бы. Не хочется привязывать настройки линукса к железу. Может я его на внешнем ssd таскаю с собой?
 

Walker

New member
Сообщения
4
#8
на 1.5 на серверах была такая проблема, решалась вот так
После установки драйверов матрокса флай отказывается запускаться, горит черный экран с мигающим курсором и все - уже пробовал. Файла xorg.conf нету. Есть другие файлы в которых, как я понял, можно прописывать эти параметры. В общем все так же. Товарищ из группы в вк предложил проверить на работоспособность Орла. Тоже самое. Извиняюсь, что долго не писал, других забот еще хватает.
 

OIvanov

New member
Сообщения
33
#9
После установки драйверов матрокса флай отказывается запускаться, горит черный экран с мигающим курсором и все - уже пробовал. Файла xorg.conf нету. Есть другие файлы в которых, как я понял, можно прописывать эти параметры. В общем все так же. Товарищ из группы в вк предложил проверить на работоспособность Орла. Тоже самое. Извиняюсь, что долго не писал, других забот еще хватает.
А пробовалось ли на мониторе с более высоким разрешением экрана?