Драйверы принтеров Canon UFRII

Pavel77

New member
Сообщения
12
#1
Добрый день.

При установке драйверов 3.60 с сайта canon.ru (они одинаковые для всех лазерных кэнонов, например отсюда https://www.canon.ru/support/produc...d=tcm:203-1506758&os=Linux (64-bit)&language=), после запуска install.sh возникает ошибка установки пакета libgcrypt20-dev:i386, можете это починить, выложив подходящие версии либ в репозиторий астры? просто от дэбиана 9 пакет не ставится тоже, ругается на конфликты.
Хотя после этой ошибки принтер возможно установить через ручной запуск появившейся в меню утилиты Кэнонов.
 

OIvanov

New member
Сообщения
45
#2
Добрый день.

При установке драйверов 3.60 с сайта canon.ru (они одинаковые для всех лазерных кэнонов, например отсюда https://www.canon.ru/support/products/imagerunner/imagerunner-advance-c3320.aspx?type=drivers&driverdetailid=tcm:203-1506758&os=Linux (64-bit)&language=), после запуска install.sh возникает ошибка установки пакета libgcrypt20-dev:i386, можете это починить, выложив подходящие версии либ в репозиторий астры? просто от дэбиана 9 пакет не ставится тоже, ругается на конфликты.
Хотя после этой ошибки принтер возможно установить через ручной запуск появившейся в меню утилиты Кэнонов.
Вероятно, ругается на архитектуру. Или у Вас 32-х битный процессор?
 

Pavel77

New member
Сообщения
12
#3
Вероятно, ругается на архитектуру. Или у Вас 32-х битный процессор?
На убунте x64 все отлично проставилось, скрипт install.sh установил всё корректно сам. Здесь же ругается на конфликт с версиями, попробуйте запустите, оно ничего не ломает

Вообще хорошо бы было просто включить в дистрибутив этот пакет дров на кэноны, как это сделано с HP
 

tim2

New member
Сообщения
6
#4
попробуйте как написано здесь -https://wiki.astralinux.ru/pages/viewpage.action?pageId=3278114
 

Pavel77

New member
Сообщения
12
#5
попробуйте как написано здесь -https://wiki.astralinux.ru/pages/viewpage.action?pageId=3278114
ухты, все уже описано в вики. Пробую на свежеустановленной Астре CE 2.12.8 и те же ошибки. В итоге даже с ошибкой и на этом компе установилась утилита добавления принтеров Кэнон и кучка соответствующих PPD.

user@astra6:~$ cat /etc/astra_version
CE 2.12.8 (orel)

sudo su
apt update
apt-get install ia32-libs

cd linux-UFRII-drv-v360-uken
./install.sh

Код:
Do you want to continue with installation? (y/n)y

#----------------------------------------------------#
# Install Start
#----------------------------------------------------#
Machine Type = amd64
Package Type = deb
Package list =
    ./64-bit_Driver/Debian/cndrvcups-common_4.00-1_amd64.deb
    ./64-bit_Driver/Debian/cndrvcups-ufr2-uk_3.60-1_amd64.deb
    ./64-bit_Driver/Debian/cndrvcups-utility_1.10-1_amd64.deb

#----------------------------------------------------#
# apt-get update
#----------------------------------------------------#
Сущ:1 https://download.astralinux.ru/astra/current/orel/repository orel InRelease
Чтение списков пакетов… Готово


#----------------------------------------------------#
# apt-get install
#----------------------------------------------------#
Чтение списков пакетов… Готово
Построение дерева зависимостей     
Чтение информации о состоянии… Готово
Уже установлен пакет libglade2-0 самой новой версии (1:2.6.4-2).
обновлено 0, установлено 0 новых пакетов, для удаления отмечено 0 пакетов, и 0 пакетов не обновлено.

#----------------------------------------------------#
# Install Package Check
#----------------------------------------------------#
OK: libglade2-0

#----------------------------------------------------#
# apt-get install
#----------------------------------------------------#
Чтение списков пакетов… Готово
Построение дерева зависимостей     
Чтение информации о состоянии… Готово
E: Не удалось найти пакет libstdc++6:i386
E: Не удалось найти пакет с помощью regex «libstdc++6»

#----------------------------------------------------#
# Install Package Check
#----------------------------------------------------#
NG: libstdc++6:i386

#----------------------------------------------------#
# apt-get install
#----------------------------------------------------#
Чтение списков пакетов… Готово
Построение дерева зависимостей     
Чтение информации о состоянии… Готово
Заметьте, вместо «libxml2:i386» выбирается «ia32-libs»
Уже установлен пакет ia32-libs самой новой версии (20180423.1).
обновлено 0, установлено 0 новых пакетов, для удаления отмечено 0 пакетов, и 0 пакетов не обновлено.

#----------------------------------------------------#
# Install Package Check
#----------------------------------------------------#
NG: libxml2:i386

#----------------------------------------------------#
# apt-get install
#----------------------------------------------------#
Чтение списков пакетов… Готово
Построение дерева зависимостей     
Чтение информации о состоянии… Готово
Заметьте, вместо «libjpeg62:i386» выбирается «ia32-libs»
Уже установлен пакет ia32-libs самой новой версии (20180423.1).
обновлено 0, установлено 0 новых пакетов, для удаления отмечено 0 пакетов, и 0 пакетов не обновлено.

#----------------------------------------------------#
# Install Package Check
#----------------------------------------------------#
NG: libjpeg62:i386

#----------------------------------------------------#
# apt-get install
#----------------------------------------------------#
Чтение списков пакетов… Готово
Построение дерева зависимостей     
Чтение информации о состоянии… Готово
E: Не удалось найти пакет libbeecrypt7:i386

#----------------------------------------------------#
# Install Package Check
#----------------------------------------------------#
Replace: libbeecrypt7:i386 -> libgcrypt20:i386

#----------------------------------------------------#
# apt-get update
#----------------------------------------------------#
Сущ:1 https://download.astralinux.ru/astra/current/orel/repository orel InRelease
Чтение списков пакетов… Готово


#----------------------------------------------------#
# apt-get install
#----------------------------------------------------#
Чтение списков пакетов… Готово
Построение дерева зависимостей     
Чтение информации о состоянии… Готово
Заметьте, вместо «libgcrypt20:i386» выбирается «ia32-libs»
Уже установлен пакет ia32-libs самой новой версии (20180423.1).
обновлено 0, установлено 0 новых пакетов, для удаления отмечено 0 пакетов, и 0 пакетов не обновлено.

#----------------------------------------------------#
# Install Package Check
#----------------------------------------------------#
NG: libgcrypt20:i386

#----------------------------------------------------#
# apt-get install
#----------------------------------------------------#
Чтение списков пакетов… Готово
Построение дерева зависимостей     
Чтение информации о состоянии… Готово
E: Не удалось найти пакет libbeecrypt-dev:i386

#----------------------------------------------------#
# Install Package Check
#----------------------------------------------------#
Replace: libbeecrypt-dev:i386 -> libgcrypt20-dev:i386

#----------------------------------------------------#
# apt-get update
#----------------------------------------------------#
Сущ:1 https://download.astralinux.ru/astra/current/orel/repository orel InRelease
Чтение списков пакетов… Готово


#----------------------------------------------------#
# apt-get install
#----------------------------------------------------#
Чтение списков пакетов… Готово
Построение дерева зависимостей     
Чтение информации о состоянии… Готово
E: Не удалось найти пакет libgcrypt20-dev:i386

#----------------------------------------------------#
# Install Package Check
#----------------------------------------------------#
NG: libgcrypt20-dev:i386

Some system libraries could not be installed.
Refer to the Readme file for more information.
Do you want to continue with installation? (y/n)
 
Последнее редактирование: