php Смоленск 1.6

g1m

New member
Сообщения
6
#1
Доброго времени суток.

Подскажите, не устанавливается php

Код:
aptitude install php
Warning: Invalid locale (please review locale settings, this might lead to problems later):
  locale::facet::_S_create_c_locale name not valid
The following NEW packages will be installed:
  libapache2-mod-php7.0{a} php php-common{a} php7.0{a} php7.0-cli{a} php7.0-common{a} php7.0-json{a} php7.0-opcache{a} php7.0-readline{a}
0 packages upgraded, 9 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B/3223 kB of archives. After unpacking 13.7 MB will be used.
Do you want to continue? [Y/n/?]
Get: 1 file:/media/repo smolensk/main amd64 php-common all 1:49 [14.1 kB]
Get: 2 file:/media/repo smolensk/main amd64 php7.0-common amd64 7.0.27-0+deb9u1 [536 kB]
Get: 3 file:/media/repo smolensk/main amd64 php7.0-json amd64 7.0.27-0+deb9u1 [17.2 kB]
Get: 4 file:/media/repo smolensk/main amd64 php7.0-opcache amd64 7.0.27-0+deb9u1 [77.9 kB]
Get: 5 file:/media/repo smolensk/main amd64 php7.0-readline amd64 7.0.27-0+deb9u1 [12.4 kB]
Get: 6 file:/media/repo smolensk/main amd64 php7.0-cli amd64 7.0.27-0+deb9u1 [1284 kB]
Get: 7 file:/media/repo smolensk/main amd64 libapache2-mod-php7.0 amd64 7.0.27-0+deb9u1 [1224 kB]
Get: 8 file:/media/repo smolensk/main amd64 php7.0 all 7.0.27-0+deb9u1 [52.9 kB]
Get: 9 file:/media/repo smolensk/main amd64 php all 1:7.0+49 [5034 B]
100% [Working]perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
        LANGUAGE = (unset),
        LC_ALL = (unset),
        LC_CTYPE = "en_US.UTF-8",
        LANG = "ru_RU.UTF-8"
    are supported and installed on your system.
perl: warning: Falling back to a fallback locale ("ru_RU.UTF-8").
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: ?????????? ?????????? LC_ALL ? ?????? ?? ?????????.: ??? ?????? ????? ??? ????????
(Reading database ... 125687 files and directories currently installed.)
Preparing to unpack .../0-php-common_49_all.deb ...
Unpacking php-common (1:49) ...
dpkg: error processing archive /tmp/apt-dpkg-install-0IDm3m/0-php-common_49_all.deb (--unpack):
 error creating directory './var/lib/php': Operation not permitted
Preparing to unpack .../1-php7.0-common_7.0.27-0+deb9u1_amd64.deb ...
Unpacking php7.0-common (7.0.27-0+deb9u1) ...
Preparing to unpack .../2-php7.0-json_7.0.27-0+deb9u1_amd64.deb ...
Unpacking php7.0-json (7.0.27-0+deb9u1) ...
Preparing to unpack .../3-php7.0-opcache_7.0.27-0+deb9u1_amd64.deb ...
Unpacking php7.0-opcache (7.0.27-0+deb9u1) ...
Preparing to unpack .../4-php7.0-readline_7.0.27-0+deb9u1_amd64.deb ...
Unpacking php7.0-readline (7.0.27-0+deb9u1) ...
Preparing to unpack .../5-php7.0-cli_7.0.27-0+deb9u1_amd64.deb ...
Unpacking php7.0-cli (7.0.27-0+deb9u1) ...
Preparing to unpack .../6-libapache2-mod-php7.0_7.0.27-0+deb9u1_amd64.deb ...
Unpacking libapache2-mod-php7.0 (7.0.27-0+deb9u1) ...
Selecting previously unselected package php7.0.
Preparing to unpack .../7-php7.0_7.0.27-0+deb9u1_all.deb ...
Unpacking php7.0 (7.0.27-0+deb9u1) ...
Selecting previously unselected package php.
Preparing to unpack .../8-php_7.0+49_all.deb ...
Unpacking php (1:7.0+49) ...
Errors were encountered while processing:
 /tmp/apt-dpkg-install-0IDm3m/0-php-common_49_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
dpkg: dependency problems prevent configuration of php7.0-readline:
 php7.0-readline depends on php-common (>= 1:35); however:
  Package php-common is not installed.

dpkg: error processing package php7.0-readline (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of php7.0-opcache:
 php7.0-opcache depends on php-common (>= 1:35); however:
  Package php-common is not installed.

dpkg: error processing package php7.0-opcache (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libapache2-mod-php7.0:
 libapache2-mod-php7.0 depends on php7.0-opcache; however:
  Package php7.0-opcache is not configured yet.

dpkg: error processing package libapache2-mod-php7.0 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of php7.0-cli:
 php7.0-cli depends on php7.0-opcache; however:
  Package php7.0-opcache is not configured yet.
 php7.0-cli depends on php7.0-readline; however:
  Package php7.0-readline is not configured yet.

dpkg: error processing package php7.0-cli (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of php7.0-json:
 php7.0-json depends on php-common (>= 1:35); however:
  Package php-common is not installed.

dpkg: error processing package php7.0-json (--configure):
 dependency problems - leaving unconfigured
Processing triggers for man-db (2.7.6.1-2) ...
dpkg: dependency problems prevent configuration of php7.0-common:
 php7.0-common depends on php-common (>= 1:35); however:
  Package php-common is not installed.

dpkg: error processing package php7.0-common (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of php7.0:
 php7.0 depends on libapache2-mod-php7.0 | php7.0-fpm | php7.0-cgi; however:
  Package libapache2-mod-php7.0 is not configured yet.
  Package php7.0-fpm is not installed.
  Package php7.0-cgi is not installed.
 php7.0 depends on php7.0-common; however:
  Package php7.0-common is not configured yet.

dpkg: error processing package php7.0 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of php:
 php depends on php7.0; however:
  Package php7.0 is not configured yet.

dpkg: error processing package php (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 php7.0-readline
 php7.0-opcache
 libapache2-mod-php7.0
 php7.0-cli
 php7.0-json
 php7.0-common
 php7.0
 php
                                        
Current status: 4 (+4) broken.
 

g1m

New member
Сообщения
6
#2
Разобрался. Может кто подскажет, как удалить вопрос
 

g1m

New member
Сообщения
6
#4
Я начинающий пользователь астры. Ошибка в том, что root по ssh, это не совсем root =))) У него нет прав на установку

Код:
dpkg: error processing archive /tmp/apt-dpkg-install-0IDm3m/0-php-common_49_all.deb (--unpack):
 error creating directory './var/lib/php': Operation not permitted
вот по этому куску вывода я это понял =))) Продолжаем читать доки =))))
 

SkvITy

New member
Сообщения
68
#5
Не... Селинух по заказу АНБ, значит низя.
а руту дать 63 целостность -
после установки разблокировать рута. перейти в него, потом
pdpl-user -i 63 root
вроде так. Ну и перезайти после этого.
Мне помогло