Какое ядро загружать после обновления № 02032018SE15?

Сообщения
23
#1
Всем привет. Астралинукс SE Смоленск 1.5, обновление № 02032018SE15.
Читаем:

+++++++++++++++++++++++++++++++++++++++++++++++++
Кумулятивное обновление (содержит в себе обновления №27102017SE15,№29032017SE15, №16092016SE15) для нейтрализации угроз эксплуатации уязвимостей операционной системы специального назначения "Astra Linux Special Edition" РУСБ.10015-01 (версия 1.5). Для минимизации рисков эксплуатации уязвимостей микропроцессоров Meltdown (CVE-2017-5754) и Spectre v2 (CVE-2017-5715) в состав данного обновления включено ядро linux 4.2.0-24.

В связи с серьезными изменениями в части своего интерфейса это ядро устанавливается дополнительно к linux 4.2.0-23 и не загружается по умолчанию. Стороннее программное обеспечение, содержащее в своем составе модули ядра, скомпилированные для ядра 4.2.0-23, может работать некорректно и потребовать перекомпиляции.
+++++++++++++++++++++++++++++++++++++++++++++++++

Из чего я делаю вывод, что ядро 4.2.0-24, которое появляется в меню grub-а после обновления (а оно появляется), вобще говоря, загружать обязательно только в том случае, если у тебя Meltdown (CVE-2017-5754) и Spectre v2 (CVE-2017-5715). Прав ли я, и если да, то как определить, такие ли у меня микропроцессоры? Спасибо.
 

Fd1501h

Moderator
Сообщения
505
#2
Всем привет. Астралинукс SE Смоленск 1.5, обновление № 02032018SE15.
Читаем:

+++++++++++++++++++++++++++++++++++++++++++++++++
Кумулятивное обновление (содержит в себе обновления №27102017SE15,№29032017SE15, №16092016SE15) для нейтрализации угроз эксплуатации уязвимостей операционной системы специального назначения "Astra Linux Special Edition" РУСБ.10015-01 (версия 1.5). Для минимизации рисков эксплуатации уязвимостей микропроцессоров Meltdown (CVE-2017-5754) и Spectre v2 (CVE-2017-5715) в состав данного обновления включено ядро linux 4.2.0-24.

В связи с серьезными изменениями в части своего интерфейса это ядро устанавливается дополнительно к linux 4.2.0-23 и не загружается по умолчанию. Стороннее программное обеспечение, содержащее в своем составе модули ядра, скомпилированные для ядра 4.2.0-23, может работать некорректно и потребовать перекомпиляции.
+++++++++++++++++++++++++++++++++++++++++++++++++

Из чего я делаю вывод, что ядро 4.2.0-24, которое появляется в меню grub-а после обновления (а оно появляется), вобще говоря, загружать обязательно только в том случае, если у тебя Meltdown (CVE-2017-5754) и Spectre v2 (CVE-2017-5715). Прав ли я, и если да, то как определить, такие ли у меня микропроцессоры? Спасибо.
Уязвимость Meltdown и Spectre есть почти во всех процессорах.
Meltdown
Spectre

Узнать какой у вас процессор можно командой:
Код:
cat /proc/cpuinfo
 
Сообщения
23
#3
А как узнать, установлено я то или иное обновление или нет? Интересует команда, выводящая список установленных обновлений ну или файл какой-нибудь, в который записаны номера установленных обновлений.
 

Fd1501h

Moderator
Сообщения
505
#4
А как узнать, установлено я то или иное обновление или нет? Интересует команда, выводящая список установленных обновлений ну или файл какой-нибудь, в который записаны номера установленных обновлений.
Если вас интересует только закрытие Meltdown и Spectre то:
Код:
cat /proc/cpuinfo | grep bugs
Вывод должен содержать: cpu_meltdown spectre_v1 spectre_v2

Вывести все установленные пакеты:
Код:
dpkg --list
 
Сообщения
23
#5
Интересуют все установленные обновления. Ну то есть такой примерно список
31082018SE15, 27082018SE15, 02032018SE15, 27102017SE15, 01062017SE15, 29032017SE15, 16092016SE15
Надеюсь, я не прошу ничего лишнего.
 

Fd1501h

Moderator
Сообщения
505
#6
Все обновления кумулятивные, то есть последнее обновление содержит в себе все предыдущие.
Любое обновление это просто набор пакетов.
 
Сообщения
23
#7
Все обновления кумулятивные, то есть последнее обновление содержит в себе все предыдущие.
Это не совсем так. Так, обновление 31082018SE15 не содержит в себе обновления 01062017SE15

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

Хорошо, чтобы увидеть, что обновления 27082018SE15, 02032018SE15, 27102017SE15, 29032017SE15, 16092016SE15 установлены, достаточно проконтролировать установлено ли одно обновление, а именно 31082018SE15.

А как проверить, установлено ли ОДНО обновление 31082018SE15? Если бы речь шла о пакете, то я знаю, как проверить установлен он или нет. А про обновление- не знаю.