Смоленск 1.4 Сервер очередей в Астре 1.4 SE

kostia

New member
Сообщения
134
#1
Есть ли в составе Астры 1.4 SE какой либо сервер очередей типа RabbitMQ? Тот же вопрос насчет Memcached ?
А в Astre 1.5 SE ?
 

kostia

New member
Сообщения
134
#3
Хмм.. список пакетов это конечно хорошо, но не совсем то что хотелось. Переформулирую. Кто нибудь на Astra 1.4 SE использовал сервер очередей и БД в памяти? И если да, то какие?
 

kostia

New member
Сообщения
134
#5
Вот для 1.4 кролика то и нет похоже. Хотелось точно убедиться ну или вдруг есть какая-то альтернатива.
 

cogniter

Moderator
Team Astra Linux
Сообщения
127
#6
не понимаю, как это нет? в 1.4 он есть на devel диске, также есть поправленный пакет в репозитории Lab50.

в 1.5 RabbitMQ и Memcached есть на основном диске
 

kostia

New member
Сообщения
134
#8
Упсс, а есть ли библиотеки в дистрибутиве Астры 1.4 SE для подключения к RabbitMQ хоть для какого нибудь языка программирования? Pyhton, perl, C++ ?
 

cogniter

Moderator
Team Astra Linux
Сообщения
127
#11
ну, я в целом не вижу проблем с их подключением к RabbitMQ
 

kostia

New member
Сообщения
134
#12
Да проблем то может и нет, вопрос в том есть ли они в составе дистрибутива? Дистрибутива или диска разработчика Astra Linux 1.4 SE?
 

cogniter

Moderator
Team Astra Linux
Сообщения
127
#13
Да проблем то может и нет, вопрос в том есть ли они в составе дистрибутива? Дистрибутива или диска разработчика Astra Linux 1.4 SE?
а если нет, вы их не можете использовать? это же по сути средства разработки, они не реализуют функционал по защите от НСД
 

kostia

New member
Сообщения
134
#14
Увы увы, заказчику важен откуда взят каждый используемый файл. Если в систему что то ставиться, то это должно быть официально куплено и поставлено на объект. И так уже предвижу проблемы с установкой RabbitMQ с диска разработчика, ибо в руководстве по Астре написано, что на сервере не должно быть средств разработки.
 

cogniter

Moderator
Team Astra Linux
Сообщения
127
#15
Увы увы, заказчику важен откуда взят каждый используемый файл. Если в систему что то ставиться, то это должно быть официально куплено и поставлено на объект. И так уже предвижу проблемы с установкой RabbitMQ с диска разработчика, ибо в руководстве по Астре написано, что на сервере не должно быть средств разработки.
Возможно, что обновление до 1.5 решит вашу проблему с нахождением указанных сервисов на основном диске, но вопрос использования сторонних библиотек и средств разработки так и останется.

Обычно он разрешается при аттестации объекта, а не при сертификации операционной системы.