Astralinux 1.6 и KLMS

Operkolt73

New member
Сообщения
1
#1
Доброго времени суток, нужна помощь!
Установлена Astra Linux 1.6 бюллетень 12. Версия Exim 4.86, версия apache 2,4. Устанавливаю предварительно библиотеки : ia32-libs, lib32ncurses5, lib32z1, lib-apache2-mod-authnz-Pam, далее устанавливаю klnagent_10.1.1-45_i386, проверяю подключение к ksc, пишет все ок, далее устанавливаю klmsui 8.0.3-30, пакет локализации KLMS-l10n-ru_8.0.3-30 и сам klms_8.0.3-30_i386, установка проходит без ошибок, проблем нет
Далее настраиваю KLMS /opt/Kaspersky/klms/bin/klms-setup.pl, со всем соглашаюсь MTA exim, тип конфигурации dlfunc, все ок, включаю модули apache: auth_nzpam, alias, authz_core,env,headers,rewrite,ssl,include,expires,dir. Перезапускаю apache.
Далее настраиваю пользовательский интерфейс: /opt/kaspersky/klmsui/bin/klmsui-setup.pl со всем соглашаюсь,папки etc/apache2/conf.d и etc/unit.d/apache2, UI host 127.0.0.1:2711 порт 9045, создаю новый сертификат, далее настраиваю авторизацию через Pam в файле /etc/apache2/conf.d/klmsui.conf:
AuthPAM_Enablen on
AuthType Basic
AuthName “Pam authentication for klms”
Require valid-user
Далее добавляю в файл etc/pam.d/apache2 строчку: account required pam_tally.so
Далее в файле etc/apache2/apache2.conf добавляю строчку: Astramode off
Далее устанавливаю пароль на администратора веб интерфейса, добавляю файл ключа лицензии.
Перезапускаю все необходимые службы Проблема в следующем: на адрес вебинтерфейса указанный при настройке klsmui не заходит как будто бы его вообще не существует, в статусе klms следующие ошибки: licence is invalid reason-“invalid blacklist” несмотря на то что лицензионный ключ рабочий и проверенный на других серверах компании , в статусе klmsdb пишет: error database audit database already exist, базы соответственно тоже не обновляются, подскажите пожалуйста куда копать
 
Последнее редактирование: