Установка Яндекс браузера(Неактуально)

Hobo

New member
Сообщения
7
#1
Приветствую!

Прошу помочь с установкой браузера от Яндекс..

Установил на ноут версию Астры 2.12.45 и пытаюсь установить одноимённый браузер(нужен импорт закладок), но что-то не очень получается... Как понял из гугла, нативно поддерживается только в версии ОС 1.7, а для остальных нужно танцы с бубнами исполнять, собственно нашел на этом форуме инструкцию, но валюсь на 3м пункте:
Код:
#1.Скачиваем Яндекс браузер  deb пакетом
# https://browser.yandex.ru/?banerid=0500000000
#В терминале вводим
sudo su

#2.Устанавливаем Яндекс браузер.
sudo dpkg -i yandex-*.deb

#3.Выполняем обновление кодеков
sudo /opt/yandex/browser/update-ffmpeg

#4.Переходим в каталог yandex
sudo echo "deb [trusted=true] https://mirror.yandex.ru/debian/ buster main contrib non-free" | sudo tee -a /etc/apt/sources.list

#5.Выполняем команду
sudo apt-get -t buster install libc6
Код:
root@notacer:/home/vander/Загрузки# sudo dpkg -i Yandex.deb
Выбор ранее не выбранного пакета yandex-browser-stable.
(Чтение базы данных … на данный момент установлено 169003 файла и каталога.)
Подготовка к распаковке Yandex.deb …
Распаковывается yandex-browser-stable (23.3.1.912-1) …
dpkg: зависимости пакетов не позволяют настроить пакет yandex-browser-stable:
yandex-browser-stable зависит от jq, однако:
  Пакет jq не установлен.
yandex-browser-stable зависит от libu2f-udev, однако:
  Пакет libu2f-udev не установлен.

dpkg: ошибка при обработке пакета yandex-browser-stable (--install):
проблемы зависимостей — оставляем не настроенным
Обрабатываются триггеры для desktop-file-utils (0.26-1astra1) …
Обрабатываются триггеры для mime-support (3.60) …
Обрабатываются триггеры для man-db (2.7.6.1-2) …
Обрабатываются триггеры для menu (2.1.47-astra1) …
При обработке следующих пакетов произошли ошибки:
yandex-browser-stable
root@notacer:/home/vander/Загрузки# sudo /opt/yandex/browser/update-ffmpeg
FFMPEG codecs installation failed: can not download https://browser-resources.s3.yandex.net/linux/codecs.json
Вижу, что установились не все зависимости после установки deb пакета, также эти зависимости не устанавливаются, если попытаться установить через графический интерфейс менеджера пакетов. Прошу помочь разобраться знающих людей, что не так делаю и где копать?
 

Hobo

New member
Сообщения
7
#4
Там он довольно старенький. У меня уже 23.1.2.1033. Или вы его можете обновить после установки?
Ну, для обновления надо какой-нибудь дополнительный репозиторий подключать, а мне оно пока не надо) Ноут вообще маме планирую отдать)) Но хочу кое что потестить, дабы понять надо оно(Астра) мне другом ноуте или нет. А в целом Астра очень хорошо себя показала на старом железе, пока самый шустрый дистрибутив из опробованных(не считая чистого Арча, но он не юзер френдли для не посвященных) именно на мега древнем и изначально очень слабом железе и уже планирую еще на 2 старых гроба его воткнуть, на которых сейчас винда со скрипом пашет, пущай дети осваивают :D
 

countmein

New member
Сообщения
327
#5
Ну, для обновления надо какой-нибудь дополнительный репозиторий подключать
Если пакет скачать с самого Яндекса, то при установке он подключает свой репозиторий и впоследствии с него обновляется. Здесь, видимо, не так. Наверно, если обновить, то с кодеками проблема выйдет. Те, что стандартный пакет устанавливает, требуют более новую libc6, чем в Астре стоит.