Установка QT

lo-st

New member
Сообщения
28
#1
как установить qt creator c библиотеками qt
Во время установки с помощью файла qt-unified-linux-x64-3.0.5-online.run появляется ошибка:

Warning: Network error: [ QNetworkReply::NetworkError(SslHandshakeFailedError) ] "
Failed to connect to server. Check your network connection and try again."
 

Fd1501h

Moderator
Сообщения
671
#2
как установить qt creator c библиотеками qt
Во время установки с помощью файла qt-unified-linux-x64-3.0.5-online.run появляется ошибка:

Warning: Network error: [ QNetworkReply::NetworkError(SslHandshakeFailedError) ] "
Failed to connect to server. Check your network connection and try again."
sudo apt-get install qtcreator
 

Yuriy46

New member
Сообщения
2
#3
тоже самое, нужно установить другую версию Qt,
инсталляторы Qt в SE 1.6 (smolensk) не работают, в CE 2.12.7 (orel) всё нормально.
подскажите, что может быть?
 

AndreyK

New member
Сообщения
15
#6
Поставил qt5-default, поставил qtcreator (с диска devel, не из сторонних репо)

При запуске выдает

andreyk@astra-se:~$ qtcreator
QFactoryLoader::QFactoryLoader() checking directory path "/usr/bin/platforms" ...
qt.qpa.plugin: Could not find the Qt platform plugin "xcb" in ""
This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix this problem.

Аварийный останов

Каталога /usr/bin/platforms в системе нет

andreyk@astra-se:~$ sudo cat /sys/digsig/elf_mode && cat /etc/astra_version && uname -a
1
SE 1.6 (smolensk)
Linux astra-se 4.15.3-1-generic #astra13 SMP Wed Jul 25 16:37:04 UTC 2018 x86_64 GNU/Linux
 

AndreyK

New member
Сообщения
15
#7
Поддержка предложила следующую процедуру:

После установки ОС, необходимо:
Вставить диск со средствами разработки
Выполнить команды:
sudo apt-cdrom add
sudo apt update
sudo apt install qt5-default
sudo apt install qtcreator
Потребуется заменить диск на установочный, после этого снова на диск со средствами разработки.

оставлю на память
 

Montfer

New member
Сообщения
891
#8
Поддержка предложила следующую процедуру:

После установки ОС, необходимо:
Вставить диск со средствами разработки
Выполнить команды:
sudo apt-cdrom add
sudo apt update
sudo apt install qt5-default
sudo apt install qtcreator
Потребуется заменить диск на установочный, после этого снова на диск со средствами разработки.

оставлю на память
Помогло?
 

AndreyK

New member
Сообщения
15
#9
Конкретно эту процедуру не проверял.

До ответа поддержки я попытался установить qtcreator на чистую ОС.

Конкретно:
sudo apt install qt5-default
sudo apt install qtcreator

Процесс завершился с кучей ошибок на зависимости, однако после я выполнил apt --fix-broken install
и qtcreator удалось запустить.

Поддержка уверяет что процедура выше на тестовом стенде отработала без ошибок.
Будет время - проверю.
 

Aleksey1508

New member
Сообщения
3
#11
Не подскажите как установить qt creator 5 на astra linux special edition Смоленск 1.5 ?
Это бесплатно, или нужен диск "Инструменты разработчика" ?
Или легче установить на astra linux common edition Орел 2.12 ?
 

AndreyK

New member
Сообщения
15
#12
sudo apt install qt5-default
sudo apt install qtcreator

Если ставите Qt на систему SE с обновлениями, то нужно скачать и диск обновлений разработки. На SE имеет смысл собирать то, то будет работать в последствии на SE, но разрабытавать по моему мнению нужно на Орле или на другой системе (я использую Ubuntu). Надо учитывать, что в Qt, который сходит в состав SE, нет некоторых расширений, например QChart, видимо дело в лицензионной политике Qt

Если ставить на Орле, то имхо проще скачать стандартный Qt с qt.io, но надо обратить внимание на то, с какой лицензией поставляются те или иные компоненты Qt, хотя если разрабатываете для внутреннего использования, то можно использовать все.

Про бесплатно или платно ничего не скажу.