Не запускается ald-client

tux

New member
Сообщения
9
#1
Поднял домен на SE 1.6.
Пытаюсь ввести компьютер в созданный домен, но выходит ошибка:

Создание ключей для принципала 'host/astra-cli@IACUR.LOCAL' в файле ключей '/etc/krb5.keytab'...
-- ОШИБКА:
Ошибка MIT Kerberos V5: Ошибка получения ключей принципала Kerberos 'host/astra-cli@IACUR.LOCAL'. в ALDKadm5Connection.cpp:1581(KeytabAddPrincipal)
:> Principal does not exist
--

Не удалось запустить клиент ALD.
...

В чем может быть проблема?
 

ingener

New member
Сообщения
163
#2
нужно проверить, запущен ли сервис aldd - sudo /etc/init.d/aldd status, если не запущен - запустить. после этого попробовать подключиться к домену
 

KSV

New member
Сообщения
7
#3
Столкнулся с такой же проблемой. Смоленск 1.6 и клиенты и сервер. Тоже самое при попытке ввести в созданный домен.
Предложенный выше вариант не спасает. Может сталкивался ещё кто с этим? Побеждали?
 

ingener

New member
Сообщения
163
#4
все проблемы с вводом в домен у меня были связаны с алгоритмами шифрования файла krb5.conf. нужно сверить используемые протоколы и проверить использование устаревших протоколов
 

IvanS

New member
Сообщения
2
#5
Проверь /etc/hosts, не забыл прописать полное и короткое имя для клиента? Пример: 192.168.0.2 client1.domenname.local client1
 

KSV

New member
Сообщения
7
#6
Проверь /etc/hosts, не забыл прописать полное и короткое имя для клиента? Пример: 192.168.0.2 client1.domenname.local client1
Именно. Прошу прощения, не отписался после решения проблемы.
В hosts были ЗАГЛАВНЫЕ буквы и отсутствовало короткое имя, только полное.
После исправления двух этих ошибок всё запустилось.