Браузер Google Chrome

ArtGal27

New member
Сообщения
27
#1
Добрый день!

Не удаётся установить браузер Google Chrome на новом компьютере.
Установлена ОС orel-2.12.45.5-23.07.2022_07.53.iso.
Ядро AstraLinuxCE GNU/Linux, with Linux 5.15.0-33-hardened.

Загружаю с https://www.google.com/intl/ru_ru/chrome/
файл google-chrome-stable_current_amd64.deb (версия 109.0.5414.119-1).
Пытаюсь установить ...
В результате получаю:
Ошибка: не удалось удовлетворить зависимости
...
Не установлены
libcurl4
libgtk-4-1
libu2f-udef
Посмотреть вложение Chrome_230202_175054.jpg
Давлю "Проверить в сторонних репозитариях" - результата нет.

Где можно взять пакеты libcurl4, libgtk-4-1, libu2f-udef ?

P.S. Декабрьская версия google-chrome-stable_108.0.5359.124-1_amd64.deb встала без проблем, но не обновляется. Репозитарий добавлен
Посмотреть вложение Обновление_230201_162412.jpg
 

ArtGal27

New member
Сообщения
27
#4
Как это сделать?
Более двух десятков под виндой сказываются ... в 67 лет трудно переходить на Linux c win.
Что прописать в /etc/apt/sources.list ?
Там сейчас:
deb https://download.astralinux.ru/astra/stable/orel/repository/ orel main contrib non-free
deb https://dl.astralinux.ru/astra/stable/2.12_x86-64/repository/ orel main contrib non-free
# deb http://mirror.yandex.ru/astra/stable/orel/repository/ orel main contrib non-free
 

Montfer

New member
Сообщения
2 358
#5
Как это сделать?
Более двух десятков под виндой сказываются ... в 67 лет трудно переходить на Linux c win.
Что прописать в /etc/apt/sources.list ?
Там сейчас:
deb https://download.astralinux.ru/astra/stable/orel/repository/ orel main contrib non-free
deb https://dl.astralinux.ru/astra/stable/2.12_x86-64/repository/ orel main contrib non-free
# deb http://mirror.yandex.ru/astra/stable/orel/repository/ orel main contrib non-free
первое - установи debian-archive-keyring
потом добавь
deb http://ftp.ru.debian.org/debian stretch main contrib non-free
потом
sudo apt update
если список пакетов получен без ошибок, тогда пробуй ставить браузер.
может потребоваться выполнить
sudo apt -f install

и ни в коем случае не делай upgrade или dist-upgrade с подключенной репой дебиана
 

ArtGal27

New member
Сообщения
27
#6
Сделал.
Пишет:
Чтение списков пакетов… Готово
Построение дерева зависимостей
Чтение информации о состоянии… Готово
Может быть обновлён 1 пакет. Запустите «apt list --upgradable» для показа.

sudo apt update
Пытаюсь ставить браузер.
Опять
Не установлены
libcurl4
libgtk-4-1
libu2f-udef

sudo apt -f install
Не помогло.

Делаю:
apt list --upgradable
Получил:
Вывод списка… Готово
google-chrome-stable/stable 109.0.5414.119-1 amd64 [может быть обновлён с: 108.0.5359.124-1]
N: Есть 1 дополнительная версия. Используйте «-a» для просмотра

Это то что нужно.
Как его установить?
 

ArtGal27

New member
Сообщения
27
#7
...~$ sudo apt update
Сущ:1 https://dl.astralinux.ru/astra/stable/2.12_x86-64/repository orel InRelease
Сущ:2 https://download.astralinux.ru/astra/stable/orel/repository orel InRelease
Сущ:3 https://dl.google.com/linux/chrome/deb stable InRelease
Чтение списков пакетов… Готово
Построение дерева зависимостей
Чтение информации о состоянии… Готово
Может быть обновлён 1 пакет. Запустите «apt list --upgradable» для показа.
...~$ apt list --upgradable
Вывод списка… Готово
google-chrome-stable/stable 109.0.5414.119-1 amd64 [может быть обновлён с: 108.0.5359.124-1]
N: Есть 1 дополнительная версия. Используйте «-a» для просмотра

Что нужно сделать?
 

ArtGal27

New member
Сообщения
27
#10
Ивините.
deb http://ftp.ru.debian.org/debian
Добавил.
В 7 сообщение в спешке не то скопировал.
С репой дебиана
появляется сообщение
google-chrome-stable/stable 109.0.5414.119-1 amd64 [может быть обновлён с: 108.0.5359.124-1]
а без репы дебинана тако сообщения нет.
 

Montfer

New member
Сообщения
2 358
#11
тогда попробуй установить зависимости
sudo apt install libcurl4 libgtk-4-1 libu2f-udef
если скажет, что таких пакетов нет, то либо подключать репозиторий дебиана 10 (но тут может опять по зависимостям не пойти), либо отказываться от браузера
 

ArtGal27

New member
Сообщения
27
#12
/etc/apt/sources.list
deb https://download.astralinux.ru/astra/stable/orel/repository/ orel main contrib non-free
deb https://dl.astralinux.ru/astra/stable/2.12_x86-64/repository/ orel main contrib non-free
# deb http://mirror.yandex.ru/astra/stable/orel/repository/ orel main contrib non-free
deb http://ftp.ru.debian.org/debian stretch main contrib non-free
/*------
~$ sudo apt update
Игн:1 http://ftp.ru.debian.org/debian stretch InRelease
Пол:2 http://ftp.ru.debian.org/debian stretch Release [118 kB]
Сущ:3 https://dl.astralinux.ru/astra/stable/2.12_x86-64/repository orel InRelease
Сущ:4 https://download.astralinux.ru/astra/stable/orel/repository orel InRelease
Пол:5 http://ftp.ru.debian.org/debian stretch Release.gpg [3 177 B]
Сущ:6 https://dl.google.com/linux/chrome/deb stable InRelease
Пол:7 http://ftp.ru.debian.org/debian stretch/main i386 Packages [7 059 kB]
Пол:8 http://ftp.ru.debian.org/debian stretch/main amd64 Packages [7 080 kB]
Пол:9 http://ftp.ru.debian.org/debian stretch/main Translation-en [5 377 kB]
Пол:10 http://ftp.ru.debian.org/debian stretch/main Translation-ru [487 kB]
Пол:11 http://ftp.ru.debian.org/debian stretch/contrib amd64 Packages [50,7 kB]
Пол:12 http://ftp.ru.debian.org/debian stretch/contrib i386 Packages [47,7 kB]
Пол:13 http://ftp.ru.debian.org/debian stretch/contrib Translation-en [45,8 kB]
Пол:14 http://ftp.ru.debian.org/debian stretch/non-free amd64 Packages [78,3 kB]
Пол:15 http://ftp.ru.debian.org/debian stretch/non-free i386 Packages [69,4 kB]
Пол:16 http://ftp.ru.debian.org/debian stretch/non-free Translation-en [80,2 kB]
Получено 20,5 MБ за 6с (3 321 kБ/c)
Чтение списков пакетов… Готово
Построение дерева зависимостей
Чтение информации о состоянии… Готово
Может быть обновлён 1 пакет. Запустите «apt list --upgradable» для показа.
/*--------
apt list --upgradable
Вывод списка… Готово
google-chrome-stable/stable 109.0.5414.119-1 amd64 [может быть обновлён с: 108.0.5359.124-1]
N: Есть 1 дополнительная версия. Используйте «-a» для просмотра
/*----------
~$ sudo apt install libcurl4 libgtk-4-1 libu2f-udef
Чтение списков пакетов… Готово
Построение дерева зависимостей
Чтение информации о состоянии… Готово
Пакет libcurl4 недоступен, но упомянут в списке зависимостей другого пакета.
Это может означать, что пакет отсутствует, устарел, или доступен из источников, не упомянутых в sources.list

Пакет libgtk-4-1 недоступен, но упомянут в списке зависимостей другого пакета.
Это может означать, что пакет отсутствует, устарел, или доступен из источников, не упомянутых в sources.list

E: Для пакета «libcurl4» не найден кандидат на установку
E: Для пакета «libgtk-4-1» не найден кандидат на установку
E: Не удалось найти пакет libu2f-udef
/*---------------

Не получилось.
 

ArtGal27

New member
Сообщения
27
#13
Может быть из-за ядра 5.15.0.-33-hardened.
Завтра поробую с ядром 5.15.0.-33-generic.
 

Montfer

New member
Сообщения
2 358
#14
значит, хром убрал поддержку дебиана 9. тогда на свой страх и риск подключать репу дебиана 10, либо уходить на чистый хромиум.
 

ArtGal27

New member
Сообщения
27
#16
значит, хром убрал поддержку дебиана 9. тогда на свой страх и риск подключать репу дебиана 10, либо уходить на чистый хромиум.
Вы правы!
Дебиан 9 - Окончание срока длительной поддержки 30 июня 2022 года :( Это плохо.
Попробую поэкспериментировать с Debian 10 на старом ноутбуке HP ProBook 4720s 2010 года.
 

ArtGal27

New member
Сообщения
27
#17
Аналогично
https://habr.com/ru/post/715522/
Посмотреть вложение 1675848886802.png

Посмотреть вложение 1675848966756.png
Цитата: "Попытки «прикрутить» репозитории Debian или Ubuntu ничего не дали, поэтому вздыхаем и остаёмся с прежней версией, поскольку знаний, чтобы победить эту проблему, пока ещё не хватает. Боль."