в каком репозитории лежат build-essential ?

Сообщения
21
#1
Хост-система : Астра Линукс SE 4.7
Я создаю образ pbuilder и получаю следующий лог

Код:
...

I: Checking component main on https://dl.astralinux.ru/astra/stable/4.7_arm/repository-main...

I: Checking component contrib on https://dl.astralinux.ru/astra/stable/4.7_arm/repository-main...
I: Checking component non-free on https://dl.astralinux.ru/astra/stable/4.7_arm/repository-main...
E: Couldn't find these debs: build-essential
E: debootstrap failed
E: Tail of debootstrap.log:
...
а почему? какой репозиторий мне подключить нужно?
 
Сообщения
21
#3
подключай repository-base, если там не будет, то repository-extended
да подключен он и экстендед тоже. Вопрос №2 в чем разница между тем что делает debootstrap и тем что делает pbuilder? Дебутстрап вроде срабатывает
 
Сообщения
2 069
#10
вроде бы нужно, но кому это надо? плюс много однотипных вопросов, а значит, народ не особо любит искать по форуму
 
Сообщения
21
#11
вроде бы нужно, но кому это надо? плюс много однотипных вопросов, а значит, народ не особо любит искать по форуму
В топик могу добавить еще вывод комманды pbuilder вне Python script окружения

Код:
user@comp:~/PROSTOR/pkg-csp$ sudo pbuilder create --configfile /tmp/lastrc --buildplace /var/cache/pbuilder/alse47-arm64/alse47-arm64.cow --mirror https://dl.astralinux.ru/astra/stable/4.7_arm/repository-main --distribution 4.7_arm --no-targz --extrapackages 'cowdancer pbuilder fakeroot quilt python devscripts eatmydata procps locales  cowdancer'
[sudo] password for user:
W: /root/.pbuilderrc does not exist
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
        LANGUAGE = (unset),
        LC_ALL = (unset),
        LC_ADDRESS = "en_US.UTF-8",
        LC_NAME = "en_US.UTF-8",
        LC_MONETARY = "en_US.UTF-8",
        LC_PAPER = "en_US.UTF-8",
        LC_IDENTIFICATION = "en_US.UTF-8",
        LC_TELEPHONE = "en_US.UTF-8",
        LC_MEASUREMENT = "en_US.UTF-8",
        LC_TIME = "en_US.UTF-8",
        LC_NUMERIC = "en_US.UTF-8",
        LANG = "ru_RU.UTF-8"
    are supported and installed on your system.
perl: warning: Falling back to a fallback locale ("ru_RU.UTF-8").
E: Directory /var/cache/pbuilder/alse47-arm64/alse47-arm64.cow does not exist
/tmp/lastrc = https://gist.github.com/iva-nova-e-katerina/46b9e5ae4cbb55a3ec45d5327e22c0b3

То есть у меня есть некий набор пайтон скриптов создающих окружение для pbuilder и запуск этих скриптов даёт ошибку описанную в начале треда. Я вытащила в чистом виде комманду pbuilder без окружения и запустила, получился лог как в этом посте. В чем проблема, не знает ли кто-нибудь?