Не могу установить на astra linux 1.7 lotus notes 9

Сообщения
3
#1
Добрый день!

Требуется установить lotus notes 9, но проблема в том что он имеет архитектуру i386.
Состав дистрибутива:

md5sum ./*
01fc15896c726b4cffdd96a8c3359ca3 ./ibm-activities-9.0.1.i586.deb
9f023bc9415c08895dc9f2217b711311 ./ibm-feedreader-9.0.1.i586.deb
b552af68b9ba2a5477c3644f43c88e41 ./ibm-notes-9.0.1.i586.deb
b92dba9a316057618d0fe572e4bb8f7c ./ibm-opensocial-9.0.1.i586.deb
34be9e8dacc15b16996019715f17edea ./ibm-sametime-9.0.1.i586.deb
2b270afba3e3be732a4b3083895310fc ./license.tar
500033ac20758bf83493e2eb5593091b ./smartupgrade.sh

1. Подключить архитектуру i386 через dpkg --add-architecture i386 не получилось:

N: Пропускается получение настроенного файла «main/binary-i386/Packages», так как репозиторий «http://download.astralinux.ru/astra/frozen/1.7_x86-64/1.7.1/repository-base 1.7_x86-64 InRelease» не поддерживает архитектуру «i386»
N: Пропускается получение настроенного файла «non-free/binary-i386/Packages», так как репозиторий «http://download.astralinux.ru/astra/frozen/1.7_x86-64/1.7.1/repository-base 1.7_x86-64 InRelease» не поддерживает архитектуру «i386»
N: Пропускается получение настроенного файла «contrib/binary-i386/Packages», так как репозиторий «http://download.astralinux.ru/astra/frozen/1.7_x86-64/1.7.1/repository-base 1.7_x86-64 InRelease» не поддерживает архитектуру «i386»
N: Пропускается получение настроенного файла «main/binary-i386/Packages», так как репозиторий «http://download.astralinux.ru/astra/frozen/1.7_x86-64/1.7.1/repository-extended 1.7_x86-64 InRelease» не поддерживает архитектуру «i386»
N: Пропускается получение настроенного файла «contrib/binary-i386/Packages», так как репозиторий «http://download.astralinux.ru/astra/frozen/1.7_x86-64/1.7.1/repository-extended 1.7_x86-64 InRelease» не поддерживает архитектуру «i386»
N: Пропускается получение настроенного файла «non-free/binary-i386/Packages», так как репозиторий «http://download.astralinux.ru/astra/frozen/1.7_x86-64/1.7.1/repository-extended 1.7_x86-64 InRelease» не поддерживает архитектуру «i386»

2. Попробовал решить через рекомендации описанные в
https://wiki.astralinux.ru/pages/viewpage.action?pageId=14024724

sudo apt install ia32-libs

но этих библиотек не достаточно, требуются еще:

apt install -f ../ibm-notes-9.0.1.i586.deb
Чтение списков пакетов… Готово
Построение дерева зависимостей
Чтение информации о состоянии… Готово
Заметьте, вместо «../ibm-notes-9.0.1.i586.deb» выбирается «ibm-notes:i386»
Некоторые пакеты не могут быть установлены. Возможно, то, что вы просите,
неосуществимо, или же вы используете нестабильную версию дистрибутива, где
запрошенные вами пакеты ещё не созданы или были удалены из Incoming.
Следующая информация, возможно, вам поможет:

Следующие пакеты имеют неудовлетворённые зависимости:
ibm-notes:i386 : Предзависит: libbonoboui2-0:i386 но он не будет установлен
Предзависит: libcupsys2:i386 но он не может быть установлен
Предзависит: libgconf2-4:i386 но он не будет установлен
Предзависит: libgtk2.0-0:i386 но он не будет установлен
Предзависит: libgnome2-0:i386 но он не будет установлен
Предзависит: libgnomecanvas2-0:i386 но он не будет установлен
Предзависит: libgnome-desktop-2:i386 но он не может быть установлен или
libgnome-desktop-2-7:i386 но он не может быть установлен или
libgnome-desktop-2-11:i386 но он не может быть установлен или
libgnome-desktop-2-17:i386 но он не может быть установлен или
libgnome-desktop-3-2:i386 но он не может быть установлен
Предзависит: libgnomeui-0:i386 но он не будет установлен
Предзависит: libice6:i386 но он не будет установлен
Предзависит: libpng12-0:i386 но он не может быть установлен
Предзависит: libsm6:i386 но он не будет установлен
Предзависит: libxcursor1:i386 но он не будет установлен
Предзависит: libxi6:i386 но он не будет установлен
Предзависит: libxp6:i386 но он не может быть установлен
Предзависит: libxt6:i386 но он не будет установлен
Предзависит: libxtst6:i386 но он не будет установлен
Рекомендует: ttf-xfree86-nonfree:i386 но он не может быть установлен
E: Невозможно исправить ошибки: у вас зафиксированы сломанные пакеты.


Подскажите, можно ли поставить lotus 9 на astra linux 1.7?
 
Сообщения
3
#2
3. Пробовал подключить debian 10 репо main и security для решения зависимостей чтобы подтянуть недостающие пакеты, получаю следующее:


# aptitude install libbonoboui2-0:i386
Следующие НОВЫЕ пакеты будут установлены:
gconf-service{a} gconf2{a} gconf2-common{a} gnome-mime-data{a} krb5-locales{a} libatk1.0-0{a} libavahi-client3:i386{a} libavahi-common-data:i386{a} libavahi-common3:i386{a} libavahi-glib1:i386{a} libbonoboui2-0:i386 libbonoboui2-common{a}
libcairo2:i386{a} libcanberra0:i386{a} libcups2:i386{ab} libdatrie1:i386{a} libdbus-1-3:i386{a} libdbus-glib-1-2:i386{a} libfontconfig1:i386{a} libfreetype6:i386{a} libfribidi0:i386{a} libgail-common{a} libgail-common:i386{a} libgail18{a}
libgail18:i386{a} libgconf-2-4{a} libgconf-2-4:i386{a} libgdk-pixbuf2.0-0:i386{ab} libgdk-pixbuf2.0-bin{a} libglade2-0:i386{a} libgnome-2-0:i386{a} libgnome2-common{a} libgnomecanvas2-0:i386{a} libgnomecanvas2-common{a} libgnomevfs2-0:i386{a}
libgnomevfs2-common{a} libgnomevfs2-extra:i386{a} libgraphite2-3:i386{a} libgssapi-krb5-2:i386{ab} libgtk2.0-0{a} libgtk2.0-0:i386{a} libgtk2.0-bin{a} libharfbuzz0b:i386{a} libice6:i386{ab} libjbig0:i386{a} libjpeg62-turbo:i386{a}
libk5crypto3:i386{ab} libkeyutils1:i386{a} libkrb5-3:i386{ab} libkrb5support0:i386{ab} libogg0:i386{a} libpango-1.0-0:i386{a} libpangocairo-1.0-0:i386{a} libpangoft2-1.0-0:i386{a} libpixman-1-0:i386{a} libpng16-16:i386{a} libpopt0:i386{a}
libsm6:i386{a} libtdb1:i386{ab} libthai0:i386{a} libtiff5:i386{a} libvorbis0a:i386{a} libvorbisfile3:i386{a} libwebp6:i386{a} libxcomposite1:i386{ab} libxcursor1:i386{ab} libxi6:i386{ab} libxinerama1:i386{a} libxrandr2:i386{a}
libxrender1:i386{a}
Следующие пакеты будут обновлены:
libavahi-client3 libavahi-common-data libavahi-common3 libcairo2 libdbus-1-3 libfreetype6 libfribidi0 libjbig0 libogg0 libtiff5 libwebp6
11 пакетов обновлено, 70 установлено новых, 331 пакетов отмечено для удаления, и 442 пакетов не обновлено.
Необходимо получить 20,7 MБ архивов. После распаковки освободится 894 MБ.
Следующие пакеты имеют неудовлетворённые зависимости:
libkrb5-3 : Ломает: libkrb5-3:i386 (!= 1.17-3.astra1) но устанавливается 1.17-3+deb10u4
libkrb5-3:i386 : Ломает: libkrb5-3 (!= 1.17-3+deb10u4) но установлен 1.17-3.astra1
libgssapi-krb5-2 : Ломает: libgssapi-krb5-2:i386 (!= 1.17-3.astra1) но устанавливается 1.17-3+deb10u4
libgssapi-krb5-2:i386 : Ломает: libgssapi-krb5-2 (!= 1.17-3+deb10u4) но установлен 1.17-3.astra1
dbus-x11 : Зависит: libdbus-1-3 (= 1.12.20-2+astra.se7+ci4) но устанавливается 1.12.24-0+deb10u1
libcups2 : Ломает: libcups2:i386 (!= 2.3.3-3astra.se18) но устанавливается 2.2.10-6+deb10u6
libcups2:i386 : Ломает: libcups2 (!= 2.2.10-6+deb10u6) но установлен 2.3.3-3astra.se18
libgdk-pixbuf2.0-0 : Зависит: libgdk-pixbuf-xlib-2.0-0 (>= 2.40.2-2) но его установка не запланирована
Ломает: libgdk-pixbuf2.0-0:i386 (!= 2.40.2-2) но устанавливается 2.38.1+dfsg-1
libgdk-pixbuf2.0-0:i386 : Зависит: libgdk-pixbuf2.0-common:i386 (= 2.38.1+dfsg-1)который является виртуальным пакетом, предоставляется:
- libgdk-pixbuf2.0-common (2.42.2+dfsg-1), но установлен 2.42.2+dfsg-1
- libgdk-pixbuf2.0-common (2.36.5-2+deb9u2), но установлен 2.42.2+dfsg-1
- libgdk-pixbuf2.0-common (2.38.1+dfsg-1), но установлен 2.42.2+dfsg-1

Ломает: libgdk-pixbuf2.0-0 (!= 2.38.1+dfsg-1) но установлен 2.40.2-2
dbus : Зависит: libdbus-1-3 (= 1.12.20-2+astra.se7+ci4) но устанавливается 1.12.24-0+deb10u1
libxcursor1 : Ломает: libxcursor1:i386 (!= 1:1.2.0-2astra1) но устанавливается 1:1.1.15-2
libxcursor1:i386 : Ломает: libxcursor1 (!= 1:1.1.15-2) но установлен 1:1.2.0-2astra1
libk5crypto3 : Ломает: libk5crypto3:i386 (!= 1.17-3.astra1) но устанавливается 1.17-3+deb10u4
libk5crypto3:i386 : Ломает: libk5crypto3 (!= 1.17-3+deb10u4) но установлен 1.17-3.astra1
libxcomposite1 : Ломает: libxcomposite1:i386 (!= 1:0.4.5-1) но устанавливается 1:0.4.4-2
libxcomposite1:i386 : Ломает: libxcomposite1 (!= 1:0.4.4-2) но установлен 1:0.4.5-1
libxi6 : Ломает: libxi6:i386 (!= 2:1.7.10-1) но устанавливается 2:1.7.9-1
libxi6:i386 : Ломает: libxi6 (!= 2:1.7.9-1) но установлен 2:1.7.10-1
libkrb5support0 : Ломает: libkrb5support0:i386 (!= 1.17-3.astra1) но устанавливается 1.17-3+deb10u4
libkrb5support0:i386 : Ломает: libkrb5support0 (!= 1.17-3+deb10u4) но установлен 1.17-3.astra1
libtdb1 : Ломает: libtdb1:i386 (!= 1.4.3-1astra.se1) но устанавливается 1.3.16-2+b1
libtdb1:i386 : Ломает: libtdb1 (!= 1.3.16-2+b1) но установлен 1.4.3-1astra.se1
libice6 : Ломает: libice6:i386 (!= 2:1.0.9-2astra.se2) но устанавливается 2:1.0.9-2
libice6:i386 : Ломает: libice6 (!= 2:1.0.9-2) но установлен 2:1.0.9-2astra.se2
libgdk-pixbuf-2.0-0 : Ломает: libgdk-pixbuf2.0-0:i386 (< 2.40.0+dfsg-6~) но устанавливается 2.38.1+dfsg-1
открыто: 7792; закрыто: 33717; отброшено: 373; конфликтует: 519