1.7.2. libvirt+uefi

SkvITy

New member
Сообщения
76
#1
1.7.2
Создаю гостя uefi, при старте
Unable to complete install: ''utf-8' codec can't decode byte 0xe0 in position 12: invalid continuation byte'
Код:
Unable to complete install: ''utf-8' codec can't decode byte 0xe0 in position 12: invalid continuation byte'

Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/asyncjob.py", line 75, in cb_wrapper
    callback(asyncjob, *args, **kwargs)
  File "/usr/share/virt-manager/virtManager/createvm.py", line 2089, in _do_async_install
    guest.installer_instance.start_install(guest, meter=meter)
  File "/usr/share/virt-manager/virtinst/install/installer.py", line 544, in start_install
    doboot, transient)
  File "/usr/share/virt-manager/virtinst/install/installer.py", line 491, in _create_guest
    domain = self.conn.createXML(install_xml or final_xml, 0)
  File "/usr/lib/python3/dist-packages/libvirt.py", line 3732, in createXML
    if ret is None:raise libvirtError('virDomainCreateXML() failed', conn=self)
  File "/usr/lib/python3/dist-packages/libvirt.py", line 37, in __init__
    err = libvirtmod.virGetLastError()
UnicodeDecodeError: 'utf-8' codec can't decode byte 0xe0 in position 12: invalid continuation byte
Если bios - все нормально.
 

zettzett

New member
Сообщения
3
#2
Аналогичная проблема. На уже созданной uefi машине ошибка такая:
Код:
Ошибка запуска : 'utf-8' codec can't decode byte 0x8a in position 13: invalid start byte

Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/asyncjob.py", line 75, in cb_wrapper
    callback(asyncjob, *args, **kwargs)
  File "/usr/share/virt-manager/virtManager/asyncjob.py", line 111, in tmpcb
    callback(*args, **kwargs)
  File "/usr/share/virt-manager/virtManager/object/libvirtobject.py", line 68, in newfn
    ret = fn(self, *args, **kwargs)
  File "/usr/share/virt-manager/virtManager/object/domain.py", line 1329, in startup
    self._backend.create()
  File "/usr/lib/python3/dist-packages/libvirt.py", line 1080, in create
    if ret == -1: raise libvirtError ('virDomainCreate() failed', dom=self)
  File "/usr/lib/python3/dist-packages/libvirt.py", line 37, in __init__
    err = libvirtmod.virGetLastError()
UnicodeDecodeError: 'utf-8' codec can't decode byte 0x8a in position 13: invalid start byte
Bash:
$ sudo virsh list --all
 ID   Имя     Состояние
-------------------------
 -    win10   выключен

$ sudo virsh start win10
ошибка: Failed to start domain 'win10'
ошибка: cannot stat @�\w: Нет такого файла или каталога
 
Последнее редактирование:

zettzett

New member
Сообщения
3
#4
Это после обновления до 1.7.2?
До 1.7.2 обновлен был давно. Во вторник проверил репы, появились пакеты обновленного libvirt, python, remmina. После установки свежих пакетов проблема и появилась, проявляется только при попытках прикрутить ovmf к qemu-kvm.
 

zettzett

New member
Сообщения
3
#6
Снес новые пакеты libvirt и установил их с диска, все работает штатно, нет только возможности редактировать xml в virt-manager.
 

SkvITy

New member
Сообщения
76
#7
В Бресте наверно так же будет, хотя он вроде не совместим с 172
 

Rossem

New member
Сообщения
3
#10
Такая же проблема.
Что то ТП кому то ответила кроме как откатывать версию модулей?