ALSE. После обновления с 1.7.0 до 1.7.2 перестаёт устанавливаться kubernetes.

MinistrBob

New member
Сообщения
11
#1
Если не обновлять ОС, оставаться на 1.7.0. тогда kubernetes устанавливается как из ванильного репо так из репо Астры.
Но если обновить ОС (sudo apt upgrade) до 1.7.2.5 ( у меня так) то при попытке установить kubelet получаю ошибку зависимостей пакетов.

Bash:
$ sudo apt install kubernetes-node
Чтение списков пакетов… Готово
Построение дерева зависимостей
Чтение информации о состоянии… Готово
Некоторые пакеты не могут быть установлены. Возможно, то, что вы просите,
неосуществимо, или же вы используете нестабильную версию дистрибутива, где
запрошенные вами пакеты ещё не созданы или были удалены из Incoming.
Следующая информация, возможно, вам поможет:

Следующие пакеты имеют неудовлетворённые зависимости:
 kubernetes-node : Зависит: ebtables но он не будет установлен
E: Невозможно исправить ошибки: у вас зафиксированы сломанные пакеты.
Если попытаться установить ebtables то он удаляет iptables при своей установке и тогда установка kubernetes-node ругается на зависимость от iptables. При установке iptables удаляется ebtables. И так получается замкнутый круг.

Как обходной манёвр (workaround) помогает установить более старую версию netbase (внезапно).
Bash:
sudo apt-get install -y netbase=5.6 --allow-downgrades
sudo apt-mark hold netbase
Вместе с netbase устанавливаются более старые версии пакетов iptables и т.п. Поэтому такой вариант не самый красивый.

Это похоже на баг обновления ОС. Как можно решить данную проблему? Может я неправильно ставлю kubernetes на Astra Linux? но я не нашёл в документации даже упоминания как это правильно делать.
 

MinistrBob

New member
Сообщения
11
#2
Как workarround можно понизить версии некоторых пакетов

Bash:
sudo apt-get install -y netbase=5.6 iptables=1.8.2-4 libiptc0=1.8.2-4 libxtables12=1.8.2-4 --allow-downgrades
sudo apt-mark hold netbase iptables libiptc0 libxtables12
sudo apt-mark showhold
sudo apt-cache policy netbase iptables libiptc0 libxtables12

sudo apt update
apt list --upgradable
sudo apt upgrade

-- Теперь устанавливается.
sudo apt install kubernetes-node
Но это не ответ на вопрос я считаю. Было бы хорошо как-то эту информацию до разработчиков донести. Только как это сделать?
 

MinistrBob

New member
Сообщения
11
#4
обновление только через apt dist-upgrade
В этой доке сказано что начиная с 1.6.7 рекомендуется использовать либо fly-astra-update либо astra-update.
Установка оперативных обновлений с использованием astra-update (fly-astra-update)

astra-update не получилось воспользоваться, т.к. заругался что раздел boot маленький, поэтому пришлось apt upgrade делать.
 

Montfer

New member
Сообщения
2 093
#5
В этой доке сказано что начиная с 1.6.7 рекомендуется использовать либо fly-astra-update либо astra-update.
Установка оперативных обновлений с использованием astra-update (fly-astra-update)

astra-update не получилось воспользоваться, т.к. заругался что раздел boot маленький, поэтому пришлось apt upgrade делать.
дело не в разнице между astra-upgrade и apt dist-upgrade, а в ранице между APT UPGRADE и APT DIST-UPGRADE
 
Последнее редактирование:

MinistrBob

New member
Сообщения
11
#6
дело не в разнице между astra-upgrade и apt dist-upgrade, а в ранице между APT UPGRADE и APT DIST-UPGRADE
Да я понял. А в чём эта разница? Можно где-то почитать об этом? Не думаю что dist-upgrade как-то по другому зависимости пакетов разруливает. Скорее он делает какие-то добавочные действия характерные для Астры, например, какие-то настройки parsec.
 

MinistrBob

New member
Сообщения
11
#7
Я позже провёл пару экспериментов = попробовал провести установку куба из репо Астры 1) в docker контейнере астры (который slim) 2) на другой виртуалке, там правда была ОС 1.7.1.8 с GUI но думаю в данной ситуации это не важно.
В обоих случаях куб установился.
Поэтому я пересоздал те виртуалки где установка наткнулась на ошибку и повторил установку куба - только я сначала поставил куб и только потом обновил ОС (на всякий случай) - так сработало без проблем.
И грубо говоря, ХЗ почему возникла проблема с зависимостями, т.к. перед установкой куба ничего на ОС особо не ставилось только пакеты: apt-transport-https,ca-certificates,curl,vim,nano,mc,bash-completion,wget,lvm2.

Кстати, проблема была только с пакетом kubernetes-node (это один из 4х пакетов куба в репо Астры).