Инструкция по настройке и работе с Крипто-Про для государственных порталов

Montfer

New member
Сообщения
807
#21
Astra Special Edition 1.6
Проблема в установке криптопро браузер плагина
в документации на wiki написано что нужно поставить пакет alien: sudo apt install alien

Этого пакета в рипозитории нет, выполнение команды выдает сообщение:

Чтение списков пакетов… Готово
Построение дерева зависимостей
Чтение информации о состоянии… Готово
Пакет alien недоступен, но упомянут в списке зависимостей другого пакета.
Это может означать, что пакет отсутствует, устарел, или доступен из источников, не упомянутых в sources.list


E: Для пакета «alien» не найден кандидат на установку
root@astra-se:/home/user1/Загрузки# sudo apt install alien
Чтение списков пакетов… Готово
Построение дерева зависимостей
Чтение информации о состоянии… Готово
Пакет alien недоступен, но упомянут в списке зависимостей другого пакета.
Это может означать, что пакет отсутствует, устарел, или доступен из источников, не упомянутых в sources.list


Как быть в данной ситуации?
Диск разработчика добавьте в соурс.лист командой
sudo apt-cdrom add
 

user7f

New member
Сообщения
15
#22
Диск разработчика добавьте в соурс.лист командой
sudo apt-cdrom add
монтирую установочный диск с комплекта поставки
uname -a
Linux astra-se 4.15.3-1-generic #astra13 SMP Wed Jul 25 16:37:04 UTC 2018 x86_64 GNU/Linux
пакета alien в репозитории установочного комплекта Special Edition нет

Я понимаю так, что инструкции по установке КриптоПро ЭЦП Browser plugin писали на wiki по редакции Astra Common Edition, в сертифицированной версии этот метод не работает.

Как же тогда пользователям Astra Special Edition установить КриптоПро ЭЦП Browser plug-in
 

Montfer

New member
Сообщения
807
#23
монтирую установочный диск с комплекта поставки
uname -a
Linux astra-se 4.15.3-1-generic #astra13 SMP Wed Jul 25 16:37:04 UTC 2018 x86_64 GNU/Linux
пакета alien в репозитории установочного комплекта Special Edition нет

Я понимаю так, что инструкции по установке КриптоПро ЭЦП Browser plugin писали на wiki по редакции Astra Common Edition, в сертифицированной версии этот метод не работает.

Как же тогда пользователям Astra Special Edition установить КриптоПро ЭЦП Browser plug-in
установочный диск и диск разработчика - это два разных диска
http://astra-store.ru/catalog/software/software-special/astralinuxse-100150115-606/
 
Сообщения
16
#27
apt install alien libpcsclite1 pcscd libccid zip unzip
bash: apt: команда не найдена

в чем прикол?

root@AstraLi:/home/messir/Загрузки# dpkg -i pcsc-tools_1.4.27-1_amd64.deb
Выбор ранее не выбранного пакета pcsc-tools.
(Чтение базы данных … на данный момент установлено 106892 файла и каталога.)
Распаковывается пакет pcsc-tools (из файла pcsc-tools_1.4.27-1_amd64.deb) …
dpkg: зависимости пакетов не позволяют настроить пакет pcsc-tools:
pcsc-tools зависит от libpcsc-perl, однако:
Пакет libpcsc-perl не установлен.
pcsc-tools зависит от libgtk2-perl, однако:
Пакет libgtk2-perl не установлен.
----
root@AstraLi:/etc/apt# apt-get install libpcsc-perl
Чтение списков пакетов… Готово
Построение дерева зависимостей
Чтение информации о состоянии… Готово
E: Не удалось найти пакет libpcsc-perl
----

Пробую добавить репозиторий орла:
deb https://download.astralinux.ru/astra/current/orel/repository orel contrib main non-free

apt-get update

***
: Не удалось получить https://download.astralinux.ru/astr...tory/dists/orel/contrib/binary-amd64/Packages Problem with the SSL CA cert (path? access rights?)

W: Не удалось получить https://download.astralinux.ru/astra/current/orel/repository/dists/orel/main/binary-amd64/Packages Problem with the SSL CA cert (path? access rights?)

W: Не удалось получить https://download.astralinux.ru/astr...ory/dists/orel/non-free/binary-amd64/Packages Problem with the SSL CA cert (path? access rights?)

E: Некоторые индексные файлы не скачались. Они были проигнорированы или вместо них были использованы старые версии.

WTF??? Из коробки тут вообще что-нибудь работает? Если нужно докупить диск, чтоб ЭЦП заработали, почему об этом заранее не предупреждается?
Есть место, где адекватно и по работающим шагам описано, как запустить рутокен на астре?
 

Montfer

New member
Сообщения
807
#28
apt install alien libpcsclite1 pcscd libccid zip unzip
bash: apt: команда не найдена

в чем прикол?

root@AstraLi:/home/messir/Загрузки# dpkg -i pcsc-tools_1.4.27-1_amd64.deb
Выбор ранее не выбранного пакета pcsc-tools.
(Чтение базы данных … на данный момент установлено 106892 файла и каталога.)
Распаковывается пакет pcsc-tools (из файла pcsc-tools_1.4.27-1_amd64.deb) …
dpkg: зависимости пакетов не позволяют настроить пакет pcsc-tools:
pcsc-tools зависит от libpcsc-perl, однако:
Пакет libpcsc-perl не установлен.
pcsc-tools зависит от libgtk2-perl, однако:
Пакет libgtk2-perl не установлен.
----
root@AstraLi:/etc/apt# apt-get install libpcsc-perl
Чтение списков пакетов… Готово
Построение дерева зависимостей
Чтение информации о состоянии… Готово
E: Не удалось найти пакет libpcsc-perl
----

Пробую добавить репозиторий орла:
deb https://download.astralinux.ru/astra/current/orel/repository orel contrib main non-free

apt-get update

***
: Не удалось получить https://download.astralinux.ru/astr...tory/dists/orel/contrib/binary-amd64/Packages Problem with the SSL CA cert (path? access rights?)

W: Не удалось получить https://download.astralinux.ru/astra/current/orel/repository/dists/orel/main/binary-amd64/Packages Problem with the SSL CA cert (path? access rights?)

W: Не удалось получить https://download.astralinux.ru/astr...ory/dists/orel/non-free/binary-amd64/Packages Problem with the SSL CA cert (path? access rights?)

E: Некоторые индексные файлы не скачались. Они были проигнорированы или вместо них были использованы старые версии.

WTF??? Из коробки тут вообще что-нибудь работает? Если нужно докупить диск, чтоб ЭЦП заработали, почему об этом заранее не предупреждается?
Есть место, где адекватно и по работающим шагам описано, как запустить рутокен на астре?
apt install ....
Команда не найдена - чаще всего пишет, т.к. нет прав root. Добавьте команду sudo в начало.
 

cogniter

Moderator
Team Astra Linux
Сообщения
507
#29
монтирую установочный диск с комплекта поставки
uname -a
Linux astra-se 4.15.3-1-generic #astra13 SMP Wed Jul 25 16:37:04 UTC 2018 x86_64 GNU/Linux
пакета alien в репозитории установочного комплекта Special Edition нет

Я понимаю так, что инструкции по установке КриптоПро ЭЦП Browser plugin писали на wiki по редакции Astra Common Edition, в сертифицированной версии этот метод не работает.

Как же тогда пользователям Astra Special Edition установить КриптоПро ЭЦП Browser plug-in
выложили deb пакеты в инструкции
 
Сообщения
16
#33
Возможно глупость скажу, т.к. сам не особо шарю. Всегда писал команду apt-get
Конкретно в вашем случае поможет или нет - не знаю
Тоже через apt-get остальное установил. Странно то, что в "официальной" инструкции используются команды из коробки не работающие.
 

CrashBldash

New member
Сообщения
251
#36
Камрады, как я понимаю яндекс браузере на линукс нет поддержки гостшифрования. Написал в яндекс, они подтвердили. Огромного желания прикрутить его как я понял у них нет, но они обещали подумать над этим. Убедительная просьба всем неравнодушным написать в яндекс о необходимости поддержки в яндекс браузере под линукс шифрования по гост.
 

Griffith

New member
Сообщения
10
#37
Делал по вашей инструкции, все завелось. ГосУслуги работают во всех браузерах.А вот Закупки гов ру и прочие торговые площадки работают только в браузере Chromium) поначалу столкнулся на сайте zakupki.gov.ru при входе, что у меня не удается выбрать сертификат .. но оказалось, что просто выделение не отображается. Т.е. нужно выбрать конкретный сертификат щелчком(он не выделится) и потом нажать кнопку "войти".
 

Ton

New member
Сообщения
6
#39
Здравствуйте.
С плагином 3.0.3 не появлялось окно с выбором сертификата.
Установил плагин 3.0.0 окно выбора сертификата появилось. (обрадовался :) )
После выборы нужно сертификата и ввода пароля окно закрывается, вход в личный кабинет не происходит. :(
Удалось побороть? Такая же проблема. Пускает только под одним старым сертификатом с ГОСТ2001. Совпадение?