Epson m200

evdev

New member
Сообщения
4
#1
Как установить драйвер на Epson m200?
На wiki ссылка не работает на epson-inkjet-escpr-1.6.2_signed.deb
На сайте Epson все драйвера требуют
In order to install these drivers, you need to install LSB package (version 3.2 or later) beforehand.

apt-get install lsb
Чтение списков пакетов… Готово
Построение дерева зависимостей
Чтение информации о состоянии… Готово
Заметьте, вместо «lsb» выбирается «lsb-compat»
Уже установлен пакет lsb-compat самой новой версии (9.20161125).

Что делать?
 

Fd1501h

Moderator
Сообщения
404
#2
Как установить драйвер на Epson m200?
На wiki ссылка не работает на epson-inkjet-escpr-1.6.2_signed.deb
На сайте Epson все драйвера требуют
In order to install these drivers, you need to install LSB package (version 3.2 or later) beforehand.

apt-get install lsb
Чтение списков пакетов… Готово
Построение дерева зависимостей
Чтение информации о состоянии… Готово
Заметьте, вместо «lsb» выбирается «lsb-compat»
Уже установлен пакет lsb-compat самой новой версии (9.20161125).

Что делать?
Какая у вас версия Астры?
 

evdev

New member
Сообщения
4
#3

Fd1501h

Moderator
Сообщения
404
#4
cat /etc/*-release
DISTRIB_ID="AstraLinux"
DISTRIB_DESCRIPTION="Astra Linux 2.12 (Orel)"
DISTRIB_RELEASE=2.12
DISTRIB_CODENAME=orel
PRETTY_NAME="Astra Linux (Orel 2.12)"
NAME="Astra Linux (Orel)"
ID=astra
ID_LIKE=debian
ANSI_COLOR="1;31"
HOME_URL="http://www.astra-linux.com/"
SUPPORT_URL="http://www.astra-linux.com/support"
VARIANT_ID=orel
VARIANT=Orel
VERSION_ID=2.12
1.) Обновите систему, так как уже Орёл 2.12.4
2.) пакет lsb у вас установлен, пакеты с оф.сайта устанавливаются корректно
 

evdev

New member
Сообщения
4
#5
1.) Обновите систему, так как уже Орёл 2.12.4
2.) пакет lsb у вас установлен, пакеты с оф.сайта устанавливаются корректно
1)
auser@vc-astra:~/Загрузки$ cat /etc/*-release
DISTRIB_ID="AstraLinuxCE"
DISTRIB_DESCRIPTION="Astra Linux CE 2.12.4 (Orel)"
DISTRIB_RELEASE=2.12.4
DISTRIB_CODENAME=orel
PRETTY_NAME="Astra Linux (Orel 2.12.4)"
NAME="Astra Linux (Orel)"
ID=astra
ID_LIKE=debian
ANSI_COLOR="1;31"
HOME_URL="http://astralinux.ru"
SUPPORT_URL="http://astralinux.ru/support"
VARIANT_ID=orel
VARIANT=Orel
VERSION_ID=2.12.4
2) auser@vc-astra:~/Загрузки$ sudo dpkg -i epson-inkjet-printer-escpr_1.6.31-1lsb3.2_i386.deb
(Чтение базы данных … на данный момент установлено 139237 файлов и каталогов.)
Подготовка к распаковке epson-inkjet-printer-escpr_1.6.31-1lsb3.2_i386.deb …
Распаковывается epson-inkjet-printer-escpr:i386 (1.6.31-1lsb3.2) на замену (1.6.31-1lsb3.2) …
dpkg: зависимости пакетов не позволяют настроить пакет epson-inkjet-printer-escpr:i386:
epson-inkjet-printer-escpr:i386 зависит от lsb (>= 3.2).

dpkg: ошибка при обработке пакета epson-inkjet-printer-escpr:i386 (--install):
проблемы зависимостей — оставляем не настроенным
При обработке следующих пакетов произошли ошибки:
epson-inkjet-printer-escpr:i386
 

Fd1501h

Moderator
Сообщения
404
#6
1)
auser@vc-astra:~/Загрузки$ cat /etc/*-release
DISTRIB_ID="AstraLinuxCE"
DISTRIB_DESCRIPTION="Astra Linux CE 2.12.4 (Orel)"
DISTRIB_RELEASE=2.12.4
DISTRIB_CODENAME=orel
PRETTY_NAME="Astra Linux (Orel 2.12.4)"
NAME="Astra Linux (Orel)"
ID=astra
ID_LIKE=debian
ANSI_COLOR="1;31"
HOME_URL="http://astralinux.ru"
SUPPORT_URL="http://astralinux.ru/support"
VARIANT_ID=orel
VARIANT=Orel
VERSION_ID=2.12.4
2) auser@vc-astra:~/Загрузки$ sudo dpkg -i epson-inkjet-printer-escpr_1.6.31-1lsb3.2_i386.deb
(Чтение базы данных … на данный момент установлено 139237 файлов и каталогов.)
Подготовка к распаковке epson-inkjet-printer-escpr_1.6.31-1lsb3.2_i386.deb …
Распаковывается epson-inkjet-printer-escpr:i386 (1.6.31-1lsb3.2) на замену (1.6.31-1lsb3.2) …
dpkg: зависимости пакетов не позволяют настроить пакет epson-inkjet-printer-escpr:i386:
epson-inkjet-printer-escpr:i386 зависит от lsb (>= 3.2).

dpkg: ошибка при обработке пакета epson-inkjet-printer-escpr:i386 (--install):
проблемы зависимостей — оставляем не настроенным
При обработке следующих пакетов произошли ошибки:
epson-inkjet-printer-escpr:i386
Так вы пакет для i386 (это 32-х битная архитектура) ставите! Вам нужен пакет для x86-64 (amd64), Астра только 64 битная
 

Fd1501h

Moderator
Сообщения
404
#7
1)
auser@vc-astra:~/Загрузки$ cat /etc/*-release
DISTRIB_ID="AstraLinuxCE"
DISTRIB_DESCRIPTION="Astra Linux CE 2.12.4 (Orel)"
DISTRIB_RELEASE=2.12.4
DISTRIB_CODENAME=orel
PRETTY_NAME="Astra Linux (Orel 2.12.4)"
NAME="Astra Linux (Orel)"
ID=astra
ID_LIKE=debian
ANSI_COLOR="1;31"
HOME_URL="http://astralinux.ru"
SUPPORT_URL="http://astralinux.ru/support"
VARIANT_ID=orel
VARIANT=Orel
VERSION_ID=2.12.4
2) auser@vc-astra:~/Загрузки$ sudo dpkg -i epson-inkjet-printer-escpr_1.6.31-1lsb3.2_i386.deb
(Чтение базы данных … на данный момент установлено 139237 файлов и каталогов.)
Подготовка к распаковке epson-inkjet-printer-escpr_1.6.31-1lsb3.2_i386.deb …
Распаковывается epson-inkjet-printer-escpr:i386 (1.6.31-1lsb3.2) на замену (1.6.31-1lsb3.2) …
dpkg: зависимости пакетов не позволяют настроить пакет epson-inkjet-printer-escpr:i386:
epson-inkjet-printer-escpr:i386 зависит от lsb (>= 3.2).

dpkg: ошибка при обработке пакета epson-inkjet-printer-escpr:i386 (--install):
проблемы зависимостей — оставляем не настроенным
При обработке следующих пакетов произошли ошибки:
epson-inkjet-printer-escpr:i386
А вообще пакет epson-inkjet-printer-escpr есть в репозитории Орла.
Вам достаточно выполнить: sudo apt-get install epson-inkjet-printer-escpr
 

evdev

New member
Сообщения
4
#8
А вообще пакет epson-inkjet-printer-escpr есть в репозитории Орла.
Вам достаточно выполнить: sudo apt-get install epson-inkjet-printer-escpr

auser@vc-astra:~/Загрузки$ sudo apt-get install epson-inkjet-printer-escpr
Чтение списков пакетов… Готово
Построение дерева зависимостей
Чтение информации о состоянии… Готово
Пакет epson-inkjet-printer-escpr:i386 недоступен, но упомянут в списке зависимостей другого пакета.
Это может означать, что пакет отсутствует, устарел, или доступен из источников, не упомянутых в sources.list

E: Для пакета «epson-inkjet-printer-escpr:i386» не найден кандидат на установку



Так вы пакет для i386 (это 32-х битная архитектура) ставите! Вам нужен пакет для x86-64 (amd64), Астра только 64 битная
ДА!.... просмотрел!
скачал epson-inkjet-printer-escpr_1.6.31-1lsb3.2_amd64.deb
Все работает!