Компиляция samba

skilful

New member
Сообщения
3
#1
Здравствуйте.

Хочу собрать пакет samba сам.

Качаю:
https://download.samba.org/pub/samba/stable/samba-4.16.4.tar.gz

Инструкция тут:
https://wiki.samba.org/index.php/Build_Samba_from_Source


Даю команду:
./configure и вылетает ошибка:

Код:
Waf: The wscript in '/home/sa/___MAKE_LIBS___/samba-4.16.4' is unreadable
Traceback (most recent call last):
  File "/home/sa/___MAKE_LIBS___/samba-4.16.4/third_party/waf/waflib/Scripting.py", line 141, in waf_entry_point
    set_main_module(wscript)
  File "/home/sa/___MAKE_LIBS___/samba-4.16.4/third_party/waf/waflib/Scripting.py", line 191, in set_main_module
    Context.g_module = Context.load_module(file_path)
  File "/home/sa/___MAKE_LIBS___/samba-4.16.4/third_party/waf/waflib/Context.py", line 682, in load_module
    exec(compile(code, path, 'exec'), module.__dict__)
  File "/home/sa/___MAKE_LIBS___/samba-4.16.4/wscript", line 12, in <module>
    import wafsamba, samba_dist, samba_git, samba_version, samba_utils
  File "./buildtools/wafsamba/wafsamba.py", line 15, in <module>
    from samba_autoconf import *
  File "./buildtools/wafsamba/samba_autoconf.py", line 353
    f'static int test_array[1 - 2 * !((({v})-1) {op} 0)];',
                                                         ^

На сайте пишут, что нужно поставить следующие пакеты:

Код:
apt-get install acl attr autoconf bind9utils bison build-essential \
  debhelper dnsutils docbook-xml docbook-xsl flex gdb libjansson-dev krb5-user \
  libacl1-dev libaio-dev libarchive-dev libattr1-dev libblkid-dev libbsd-dev \
  libcap-dev libcups2-dev libgnutls28-dev libgpgme-dev libjson-perl \
  libldap2-dev libncurses5-dev libpam0g-dev libparse-yapp-perl \
  libpopt-dev libreadline-dev nettle-dev perl perl-modules pkg-config \
  python-all-dev python-crypto python-dbg python-dev python-dnspython \
  python3-dnspython python-gpgme python3-gpgme python-markdown python3-markdown \
  python3-dev xsltproc zlib1g-dev liblmdb-dev lmdb-utils
Однако они не все в репозитариях Астры есть.
Что мне делать - может подскажете?

Скачать готовую самбу не надо предлагать ))

Спасибо
 

Montfer

New member
Сообщения
1 888
#2
если нет в репе астры, то подключить репу дебиана 9 и попытаться установить оттуда
 

skilful

New member
Сообщения
3
#3
Этот вариант правильный? Не будет потом с ума сходить система?