Не устанавливается g++

sergunok

New member
Сообщения
7
#1
Использую CE orel-2.12.45.5-23.07.2022_07.53

Пытаюсь установить g++:
sudo apt install g++

Чтение списков пакетов…
Построение дерева зависимостей…
Чтение информации о состоянии…
Некоторые пакеты невозможно установить. Возможно, вы просите невозможного,
или же используете нестабильную версию дистрибутива, где запрошенные вами
пакеты ещё не созданы или были удалены из Incoming.
Следующая информация, возможно, поможет вам:

Пакеты, имеющие неудовлетворённые зависимости:
g++ : Зависит: g++-6 (>= 6.3.0-9~) но он не будет установлен
E: Невозможно исправить ошибки, у вас отложены (held) битые пакеты.

В чем может быть проблема?
 

DEVOPS

New member
Сообщения
38
#2
Использую CE orel-2.12.45.5-23.07.2022_07.53

Пытаюсь установить g++:
sudo apt install g++

Чтение списков пакетов…
Построение дерева зависимостей…
Чтение информации о состоянии…
Некоторые пакеты невозможно установить. Возможно, вы просите невозможного,
или же используете нестабильную версию дистрибутива, где запрошенные вами
пакеты ещё не созданы или были удалены из Incoming.
Следующая информация, возможно, поможет вам:

Пакеты, имеющие неудовлетворённые зависимости:
g++ : Зависит: g++-6 (>= 6.3.0-9~) но он не будет установлен
E: Невозможно исправить ошибки, у вас отложены (held) битые пакеты.

В чем может быть проблема?
Пробуйте g++
 

oko

New member
Сообщения
1 052
#3
to sergunok
Когда-то давно ставил С/С++ на Орла из родного репозитория. Так что если ничего не поменяли, то sudo apt install gcc g++ make решит проблему...
Это при условии, что репы сконфигурированы корректно и в системе не проводилось лишних манипуляций по обновлению сразу из репы астры и сразу нескольких версий дебиан (как тут часто любят, ага)...
 

sergunok

New member
Сообщения
7
#5
to sergunok
Когда-то давно ставил С/С++ на Орла из родного репозитория. Так что если ничего не поменяли, то sudo apt install gcc g++ make решит проблему...
Это при условии, что репы сконфигурированы корректно и в системе не проводилось лишних манипуляций по обновлению сразу из репы астры и сразу нескольких версий дебиан (как тут часто любят, ага)...
В том-то и дело, что я не трогал настройки репозиториев.
Сделал sudo apt update

Потом:

sudo apt install g++

И вот такая-вот ошибка:
Чтение списков пакетов…
Построение дерева зависимостей…
Чтение информации о состоянии…
Некоторые пакеты невозможно установить. Возможно, вы просите невозможного,
или же используете нестабильную версию дистрибутива, где запрошенные вами
пакеты ещё не созданы или были удалены из Incoming.
Следующая информация, возможно, поможет вам:

Пакеты, имеющие неудовлетворённые зависимости:
g++ : Зависит: g++-6 (>= 6.3.0-9~) но он не будет установлен
E: Невозможно исправить ошибки, у вас отложены (held) битые пакеты.

Может быть дело в CE? Нужен SE?
 

sergunok

New member
Сообщения
7
#8
Может это все связано с: https://forum.astralinux.ru/threads/4038/ ?

Повторю, ничего с ОС не делал, репозитории пакетов не перенастраивал.
Поставил CE вчера. При установке не ставил никакие доп. пакеты -расчекал все в инсталляторе. Потом доставил лишь docker.io и deboostrap
 

countmein

New member
Сообщения
203
#10
При установке не ставил никакие доп. пакеты -расчекал все в инсталляторе.
Вот это и зря, наверно. Там же вроде были средства разработки. Я кроме тачскрина все галочки поставил, насколько помню. По крайней мере gcc работает, g++ уже установлен.
Код:
g++/stable,now 4:6.3.0-4 amd64 [установлен, автоматически]
g++-6/stable,now 6.3.0-18+deb9u1 amd64 [установлен, автоматически]
 

sergunok

New member
Сообщения
7
#11
измени orel на 2.12_x86-64 в адресе репозитория. имя дистра оставь orel
Помогло. Спасибо!!!

А почему это действие потребовалось? Почему не подошел репо по умолчанию?

Саму операционку ставил из https://dl.astralinux.ru/astra/stable/2.12_x86-64/iso/orel-2.12.45.5-23.07.2022_07.53.iso
То, что я поставил, это вообще CE? :)
 

Montfer

New member
Сообщения
1 888
#12
Помогло. Спасибо!!!

А почему это действие потребовалось? Почему не подошел репо по умолчанию?

Саму операционку ставил из https://dl.astralinux.ru/astra/stable/2.12_x86-64/iso/orel-2.12.45.5-23.07.2022_07.53.iso
То, что я поставил, это вообще CE? :)
обе репы для СЕ. та, что orel - старая, 2.12_x86-64 - новая. в старой пакеты не обновили
 

sergunok

New member
Сообщения
7
#13
обе репы для СЕ. та, что orel - старая, 2.12_x86-64 - новая. в старой пакеты не обновили
Спасибо еще раз!
А не просветишь:
1. Подразумевает ли какой-то вариант AL бесплатное использование в коммерческих проектах? (CE?)
2. Какие астры покупать для
- хостинга Веб-сервера
- работы СУБД postgresql
Спец.защита данных не нужна
3. 2.12 старее чем 1.6, 1.7?
4. Можно ли лицензию купить не на организацию-конечного пользователя, а на организацию-разработчика ПО?
 

Montfer

New member
Сообщения
1 888
#14
Спасибо еще раз!
А не просветишь:
1. Подразумевает ли какой-то вариант AL бесплатное использование в коммерческих проектах? (CE?)
2. Какие астры покупать для
- хостинга Веб-сервера
- работы СУБД postgresql
Спец.защита данных не нужна
3. 2.12 старее чем 1.6, 1.7?
4. Можно ли лицензию купить не на организацию-конечного пользователя, а на организацию-разработчика ПО?
бесплатна СЕ только для домашнего некоммерческого использования. СЕ больше не купить, только SE. 2.12 и 1.6 основаны на дебиане 9, 1.7 - на дебиане 10. По остальным вопросам лучше писать в какой нибудь отдел продаж рбт, адресы есть на официальном сайте
 

Карл

New member
Сообщения
132
#15
поясните, т.е. поставил пакет nginx или postgres и теперь это "сервер" ?
где граница "сервера" и "раб станции" ?
 

Montfer

New member
Сообщения
1 888
#16
это из разряда холивар. однозначного ответа нет. как назовёшь, так и будет
 

Montfer

New member
Сообщения
1 888
#18
не холивара ради, но цена дороже на "сервер" )
я придерживаюсь точки зрения, что сервер - это железка с достаточной производительностью с установленными серверными прогами. многие со мной не согласятся. но пофиг
 

Карл

New member
Сообщения
132
#19
я придерживаюсь точки зрения, что сервер - это железка с достаточной производительностью с установленными серверными прогами. многие со мной не согласятся. но пофиг
можно согласиться, но хорошо бы нам пояснили спецы из саппорта или кто покупал астру - что сии понятия значат