как поставить php выше 7.0?

fredorick

New member
Сообщения
2
#1
добрый день, ставлю на астра линукс glpi на apache2, но начиная с версии 10.0.0 glpi требует php от 7.4 версии, менять /etc/apt/sources.list.d/php.list на https://packages.sury.org/php/ пробовал, тоже не находит. пакеты с дебиана тоже пробовал, выводит при попытки поставить apt-get install php7.4 кучу конфликтов с предыдуще версией php, так же стирал полностью apache и php, и пробовал ставить - все так же.

может кто подскажет как поставить php7.4?
 

gfh1gfh1

New member
Сообщения
23
#2
добрый день, ставлю на астра линукс glpi на apache2, но начиная с версии 10.0.0 glpi требует php от 7.4 версии, менять /etc/apt/sources.list.d/php.list на https://packages.sury.org/php/ пробовал, тоже не находит. пакеты с дебиана тоже пробовал, выводит при попытки поставить apt-get install php7.4 кучу конфликтов с предыдуще версией php, так же стирал полностью apache и php, и пробовал ставить - все так же.

может кто подскажет как поставить php7.4?
К вам вопрос параллельно: а есть ли клиент glpi под AstraLinux? Их пакет в deb формате на AstraLinux 1.7.1 не ставится из-за зависимостей.
 

gfh1gfh1

New member
Сообщения
23
#4
glpi разворачивается на вебсервере, причем тут deb формат?
Я использую GLPI как систему инвентаризации, не как helpdesk. Раньше в версиях GLPI 0.9x это называлось FusionInventory, в 10-й версии эта система стала родной для GLPI.
https://glpi-agent.readthedocs.io/en/latest/
Для инвентаризации компьютеров, сетевых железок, принтеров и т.п..
 

AnteFil

New member
Сообщения
8
#5
Полноценно развернуть не получиться веб-сервер с актуальными обновлениями. Либо ставить ПО 2018 года или отказаться от использовании астры в качестве сервера. Я пытался около двух недель всё установить и настроить. К слову сказать у меня это получилось, но дальнейшая работа показала что отсутсвуют необходимые компоненты для работы и встал выбор или бороться бесконечно за каждый новый компонент, или выбрать другую ОС я выбрал второй вариант.