Поломал видео драйвера

whitediver

New member
Сообщения
5
#1
Здравствуйте товарищи.

Установил Астра Линукс Орёл
Код:
VERSION_ID=2.12.43
VERSION_CODENAME=orel
Поставил на него 1С сервер, всё взлетело, всё хорошо.
Но меня сильно парило разрешение 800х600 :)

Попытался обновить драйвера sudo apt -y install amdgpu-core (18.50.756341 для ubuntu 18.04)
как обычно что-то пошло не так :)
не нашёл кучу зависимостей, начал устанавливать зависимости по очереди, но не тут то было, все так и не смог, при этом установщик "зациклился" на некоторых пакетах и я теперь ничего не могу сделать, при попытке установить что-то ещё он всё время пытается завершить установку предыдущих пакетов.

Отсюда два вопроса:
Как вычистить весь установившийся и не установившийся мусор от amdgpu и как вернуть к жизни графическую часть.
На данный момент сессия не стартует, захожу через tty2 и лажу в консоле =)
 

whitediver

New member
Сообщения
5
#2
sudo apt-get install phppgadmin
Чтение списков пакетов… Готово
Построение дерева зависимостей
Чтение информации о состоянии… Готово
Возможно, для исправления этих ошибок вы захотите воспользоваться «apt-get -f install».
Пакеты, имеющие неудовлетворённые зависимости:
glamor-amdgpu : Зависит: amdgpu-core но он не будет установлен
gst-omx-amdgpu : Зависит: amdgpu-core но он не будет установлен
libdrm-amdgpu-common : Зависит: amdgpu-core но он не будет установлен
libdrm2-amdgpu : Зависит: amdgpu-core но он не будет установлен
libegl1-amdgpu-mesa : Зависит: amdgpu-core но он не будет установлен
libgbm1-amdgpu : Зависит: amdgpu-core но он не будет установлен
libglapi-amdgpu-mesa : Зависит: amdgpu-core но он не будет установлен
libllvm7.0-amdgpu : Зависит: amdgpu-core но он не будет установлен
libwayland-amdgpu-client0 : Зависит: amdgpu-core но он не будет установлен
libwayland-amdgpu-egl1 : Зависит: amdgpu-core но он не будет установлен
libwayland-amdgpu-server0 : Зависит: amdgpu-core но он не будет установлен
phppgadmin : Зависит: libapache2-mod-php или
php-cgi или
php
Зависит: php-pgsql
Зависит: libjs-jquery но он не будет установлен
Зависит: libphp-adodb но он не будет установлен
Рекомендует: apache2 (>= 2.4.20~) но он не будет установлен или
httpd
xserver-xorg-amdgpu-video-amdgpu : Зависит: amdgpu-core но он не будет установлен
E: Неудовлетворённые зависимости. Попытайтесь выполнить «apt --fix-broken install», не указывая имени пакета, (или найдите другое решение).
 

whitediver

New member
Сообщения
5
#3
sudo apt --fix-broken install
Чтение списков пакетов… Готово
Построение дерева зависимостей
Чтение информации о состоянии… Готово
Исправление зависимостей… Готово
Будут установлены следующие дополнительные пакеты:
amdgpu-core
НОВЫЕ пакеты, которые будут установлены:
amdgpu-core
обновлено 0, установлено 1 новых пакетов, для удаления отмечено 0 пакетов, и 7 пакетов не обновлено.
не установлено до конца или удалено 18 пакетов.
Необходимо скачать 0 B/2 356 B архивов.
После данной операции, объём занятого дискового пространства возрастёт на 12,3 kB.
Хотите продолжить? [Д/н] y
Пол:1 file:/var/opt/amdgpu-pro-local ./ amdgpu-core 18.50-756341 [2 356 B]
(Чтение базы данных … на данный момент установлено 198973 файла и каталога.)
Подготовка к распаковке …/amdgpu-core_18.50-756341_all.deb …
ERROR: This package can only be installed on Ubuntu 18.04.
dpkg: ошибка при обработке архива /var/opt/amdgpu-pro-local/./amdgpu-core_18.50-756341_all.deb (--unpack):
подпроцесс новый сценарий pre-installation возвратил код ошибки 1
При обработке следующих пакетов произошли ошибки:
/var/opt/amdgpu-pro-local/./amdgpu-core_18.50-756341_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
 

countmein

New member
Сообщения
88
#5
Не думаю. Просто никто не знает решения. Т.е. я знаю одно решение, но его уже поздно в данном случае применять: установить timeshift и настроить на ежедневный снимок системы. Тогда чуть что не так: ноу проблем, восстановите последний снимок и всё опять работает. Вот эта версия на Астре устанавливается без проблем: https://github.com/teejee2008/timeshift/releases/download/v20.11.1/timeshift_20.11.1_amd64.deb
 

whitediver

New member
Сообщения
5
#6
Не думаю. Просто никто не знает решения. Т.е. я знаю одно решение, но его уже поздно в данном случае применять: установить timeshift и настроить на ежедневный снимок системы. Тогда чуть что не так: ноу проблем, восстановите последний снимок и всё опять работает. Вот эта версия на Астре устанавливается без проблем: https://github.com/teejee2008/timeshift/releases/download/v20.11.1/timeshift_20.11.1_amd64.deb
Спасибо. А вы не знаете, можно ли сделать так, что бы пакет думал что его запускают под Ubuntu 18.04?

Можно где-то в конфигах системы это указать и где, если да?

UPD. В os-release прописал ubuntu 18.04, в результате amdgpu-core установилось и apt-get Проживал все остальные пакеты, кроме amdgpu-dkms

Ругается на: Error Bad return status for module build on kernel: 5.4.0-71-generic (amd64)

Через Putty сейчас попробую, напишу листинг целиком
 
Последнее редактирование:

kvv-vp

New member
Сообщения
62
#7
В os-release прописал ubuntu 18.04, в результате amdgpu-core установилось и apt-get Проживал все остальные пакеты, кроме amdgpu-dkms
"Если на клетке слона прочтешь надпись «буйвол», не верь глазам своим."

Источник: Статья Афоризмы Козьмы Пруткова с https://burido.ru/976-aforizmy-kozmy-prutkova на сайте Буридо