Cеть стартует через 30 секунд после запуска ОС/Обновление драйвера сетевого адаптера Intel Corporation I211

Art74

New member
Сообщения
121
#1
Приветствую.
Ethernet controller: Intel Corporation I211 Gigabit Network Connection (rev 03)
Проблема: сеть стартует через 30 секунд после запуска ОС Астра Орёл 2.12.44. С коммутатором сеть стартует сразу.
Если не ошибаюсь, проблема в драйвере.
Текущая версия драйвера:
sudo ethtool -i eth0
driver: igb
version: 5.10.0-1038.40-generic
firmware-version: 0. 6-2
expansion-rom-version:
bus-info: 0000:02:00.0
supports-statistics: yes
supports-test: yes
supports-eeprom-access: yes
supports-register-dump: yes
supports-priv-flags: yes
Скачал с оф.сайта интела драйвер igb-5.9.3, распаковал, попробовал сделать make install:
user@h061:~/Desktop/333/igb-5.9.3/src$ sudo make install
*** The target kernel has CONFIG_MODULE_SIG_ALL enabled, but
*** the signing key cannot be found. Module signing has been
*** disabled for this build.
make[1]: вход в каталог «/usr/src/linux-headers-5.10.0-1038.40-generic»
CC [M] /home/user/Desktops/Desktop1/333/igb-5.9.3/src/igb_main.o
In file included from /home/user/Desktops/Desktop1/333/igb-5.9.3/src/kcompat.h:74:0,
from /home/user/Desktops/Desktop1/333/igb-5.9.3/src/igb.h:32,
from /home/user/Desktops/Desktop1/333/igb-5.9.3/src/igb_main.c:30:
./include/generated/utsrelease.h:2:32: error: floating constant in preprocessor expression
#define UTS_UBUNTU_RELEASE_ABI 1038.40
^
/home/user/Desktops/Desktop1/333/igb-5.9.3/src/kcompat.h:827:5: note: in expansion of macro ‘UTS_UBUNTU_RELEASE_ABI’
#if UTS_UBUNTU_RELEASE_ABI > 65535
^~~~~~~~~~~~~~~~~~~~~~
./include/generated/utsrelease.h:2:32: error: floating constant in preprocessor expression
#define UTS_UBUNTU_RELEASE_ABI 1038.40
^
/home/user/Desktops/Desktop1/333/igb-5.9.3/src/kcompat.h:825:9: note: in expansion of macro ‘UTS_UBUNTU_RELEASE_ABI’
UTS_UBUNTU_RELEASE_ABI)
^~~~~~~~~~~~~~~~~~~~~~
/home/user/Desktops/Desktop1/333/igb-5.9.3/src/kcompat_defs.h:31:7: note: in expansion of macro ‘UBUNTU_VERSION_CODE’
#elif UBUNTU_VERSION_CODE
^~~~~~~~~~~~~~~~~~~
./include/generated/utsrelease.h:2:32: error: floating constant in preprocessor expression
#define UTS_UBUNTU_RELEASE_ABI 1038.40
^
/home/user/Desktops/Desktop1/333/igb-5.9.3/src/kcompat_ubuntu_defs.h:16:6: note: in expansion of macro ‘UTS_UBUNTU_RELEASE_ABI’
#if !UTS_UBUNTU_RELEASE_ABI
^~~~~~~~~~~~~~~~~~~~~~
In file included from /home/user/Desktops/Desktop1/333/igb-5.9.3/src/kcompat_defs.h:32:0,
from /home/user/Desktops/Desktop1/333/igb-5.9.3/src/kcompat.h:949,
from /home/user/Desktops/Desktop1/333/igb-5.9.3/src/igb.h:32,
from /home/user/Desktops/Desktop1/333/igb-5.9.3/src/igb_main.c:30:
/home/user/Desktops/Desktop1/333/igb-5.9.3/src/kcompat_ubuntu_defs.h:17:2: error: #error "UTS_UBUNTU_RELEASE_ABI is 0 or undefined"
#error "UTS_UBUNTU_RELEASE_ABI is 0 or undefined"
^~~~~
In file included from /home/user/Desktops/Desktop1/333/igb-5.9.3/src/kcompat.h:74:0,
from /home/user/Desktops/Desktop1/333/igb-5.9.3/src/igb.h:32,
from /home/user/Desktops/Desktop1/333/igb-5.9.3/src/igb_main.c:30:
./include/generated/utsrelease.h:2:32: error: floating constant in preprocessor expression
#define UTS_UBUNTU_RELEASE_ABI 1038.40
^
/home/user/Desktops/Desktop1/333/igb-5.9.3/src/kcompat.h:825:9: note: in expansion of macro ‘UTS_UBUNTU_RELEASE_ABI’
UTS_UBUNTU_RELEASE_ABI)
^~~~~~~~~~~~~~~~~~~~~~
/home/user/Desktops/Desktop1/333/igb-5.9.3/src/kcompat_ubuntu_defs.h:20:6: note: in expansion of macro ‘UBUNTU_VERSION_CODE’
#if !UBUNTU_VERSION_CODE
^~~~~~~~~~~~~~~~~~~
./include/generated/utsrelease.h:2:32: error: floating constant in preprocessor expression
#define UTS_UBUNTU_RELEASE_ABI 1038.40
^
/home/user/Desktops/Desktop1/333/igb-5.9.3/src/kcompat.h:825:9: note: in expansion of macro ‘UTS_UBUNTU_RELEASE_ABI’
UTS_UBUNTU_RELEASE_ABI)
^~~~~~~~~~~~~~~~~~~~~~
/home/user/Desktops/Desktop1/333/igb-5.9.3/src/kcompat_ubuntu_defs.h:29:6: note: in expansion of macro ‘UBUNTU_VERSION_CODE’
#if (UBUNTU_VERSION_CODE >= UBUNTU_VERSION(4,15,0,159) && \
^~~~~~~~~~~~~~~~~~~
./include/generated/utsrelease.h:2:32: error: floating constant in preprocessor expression
#define UTS_UBUNTU_RELEASE_ABI 1038.40
^
/home/user/Desktops/Desktop1/333/igb-5.9.3/src/kcompat.h:825:9: note: in expansion of macro ‘UTS_UBUNTU_RELEASE_ABI’
UTS_UBUNTU_RELEASE_ABI)
^~~~~~~~~~~~~~~~~~~~~~
/home/user/Desktops/Desktop1/333/igb-5.9.3/src/kcompat_ubuntu_defs.h:30:6: note: in expansion of macro ‘UBUNTU_VERSION_CODE’
UBUNTU_VERSION_CODE < UBUNTU_VERSION(4,15,0,999))
^~~~~~~~~~~~~~~~~~~
./include/generated/utsrelease.h:2:32: error: floating constant in preprocessor expression
#define UTS_UBUNTU_RELEASE_ABI 1038.40
^
/home/user/Desktops/Desktop1/333/igb-5.9.3/src/kcompat.h:825:9: note: in expansion of macro ‘UTS_UBUNTU_RELEASE_ABI’
UTS_UBUNTU_RELEASE_ABI)
^~~~~~~~~~~~~~~~~~~~~~
/home/user/Desktops/Desktop1/333/igb-5.9.3/src/kcompat.h:961:50: note: in expansion of macro ‘UBUNTU_VERSION_CODE’
#if (!RHEL_RELEASE_CODE && !SLE_VERSION_CODE && !UBUNTU_VERSION_CODE)
^~~~~~~~~~~~~~~~~~~
./include/generated/utsrelease.h:2:32: error: floating constant in preprocessor expression
#define UTS_UBUNTU_RELEASE_ABI 1038.40
^
/home/user/Desktops/Desktop1/333/igb-5.9.3/src/kcompat.h:825:9: note: in expansion of macro ‘UTS_UBUNTU_RELEASE_ABI’
UTS_UBUNTU_RELEASE_ABI)
^~~~~~~~~~~~~~~~~~~~~~
/home/user/Desktops/Desktop1/333/igb-5.9.3/src/kcompat.h:5077:6: note: in expansion of macro ‘UBUNTU_VERSION_CODE’
#if (UBUNTU_VERSION_CODE && UBUNTU_VERSION_CODE >= UBUNTU_VERSION(3,13,0,24))
^~~~~~~~~~~~~~~~~~~
./include/generated/utsrelease.h:2:32: error: floating constant in preprocessor expression
#define UTS_UBUNTU_RELEASE_ABI 1038.40
^
/home/user/Desktops/Desktop1/333/igb-5.9.3/src/kcompat.h:825:9: note: in expansion of macro ‘UTS_UBUNTU_RELEASE_ABI’
UTS_UBUNTU_RELEASE_ABI)
^~~~~~~~~~~~~~~~~~~~~~
/home/user/Desktops/Desktop1/333/igb-5.9.3/src/kcompat.h:5077:29: note: in expansion of macro ‘UBUNTU_VERSION_CODE’
#if (UBUNTU_VERSION_CODE && UBUNTU_VERSION_CODE >= UBUNTU_VERSION(3,13,0,24))
^~~~~~~~~~~~~~~~~~~
scripts/Makefile.build:287: ошибка выполнения рецепта для цели «/home/user/Desktops/Desktop1/333/igb-5.9.3/src/igb_main.o»
make[2]: *** [/home/user/Desktops/Desktop1/333/igb-5.9.3/src/igb_main.o] Ошибка 1
Makefile:1849: ошибка выполнения рецепта для цели «/home/user/Desktops/Desktop1/333/igb-5.9.3/src»
make[1]: *** [/home/user/Desktops/Desktop1/333/igb-5.9.3/src] Ошибка 2
make[1]: выход из каталога «/usr/src/linux-headers-5.10.0-1038.40-generic»
Makefile:87: ошибка выполнения рецепта для цели «default»
make: *** [default] Ошибка 2
 

oko

New member
Сообщения
964
#2
Смущает фраза про коммутатор - раскройте...
Вообще, траббла может быть не в драйвере. Если речь о том, что при подключении к коммутатору и после ребута ОС у вас сетевой интерфейс сразу начинает запрашивать адрес по DHCP или принимает назначенную статику и дальше отрабатывает, а при подключении проводным интерфейсом к вышестоящему роутеру или иному сетевому оборудованию в этом всем происходит задержка до 30 сек., то... связано этом может быть с физическим уровнем и его поддержкой как с вашей стороны, так и со стороны подключаемого железа: не сразу устанавливается нужная несущая, определяется тип соединения (в случае витой пары - классическая ситуация с "прямым" и "кросс" кабелем, которую современные коммутаторы легко решают на уровне своей прошивки, а старое железо может тратить лишнее время) и т.п...
Если же речь о том, что периодически сетевой сервис провисает на 30 секунд после рестарта ОС, то тут дело может быть и в задержке исполнения systemd-Unit (того же NetworkManager, networkd и т.п.)...
И да, старайтесь никогда в бинарных дистрибутивах не решать проблемы за счет сборки чего-то из исходников. Только если нет альтернативы в виде совместимого репозитория того же Debian (народ, помнится, на Debian 8 поднимал схожий igb из репозитория, значит в Debian 9 будет и подавно). Или, если собираете из сорцов, то хотя бы на вирт.машине, чтобы не мусорить в "боевой" системе...

ЗЫ И я бы поостерегся в текущих реалиях что-то качать с Intel напрямую. Так-то они блочат IP-адреса российской зоны, но могут в будущем и в исходники какую-нибудь дрянь заложить без проблем, ага...
 

Art74

New member
Сообщения
121
#3
Спасибо за ответ.
Если речь о том, что при подключении к коммутатору и после ребута ОС у вас сетевой интерфейс сразу начинает запрашивать адрес по DHCP или принимает назначенную статику и дальше отрабатывает, а при подключении проводным интерфейсом к вышестоящему роутеру или иному сетевому оборудованию в этом всем происходит задержка до 30 сек.
Именно так.

Проблемы с сетью исключаю. Подключал к этому патч-корду другие машины с другими ОС (windows, redos), проблем с сетью не увидел. Изначально на моноблоке была redos и сеть запускалась при старте системы сразу же. Установил Астру и вот такую проблему обнаружил. Поэтому и думаю на драйвер.

https://wiki.astralinux.ru/pages/vi...РУСБ.1001501(очередноеобновление1.3)-Inteligb
По этой ссылке есть драйверы Intel igb для Astra Linux Special Edition под мою модель сетевой (Написано: Подходит для Intel 82575-6, 82580, I350, I210, I211 ), но ссылка не рабочая. Да и ОС у меня Common.

ЗЫ Замерил секундомером. 20 сек задержка, если точнее) Длина кабеля где-то 30 м. На бОльших расстояниях может вообще не подключится, не проверял еще.
 

oko

New member
Сообщения
964
#4
Лучше от Смоленска не брать, несмотря на то, что это тоже AstraLinux. По множеству факторов, ага...
И да, от драйвера проблема падения сетевого соединения при увеличении длины кабеля зависит в оооочень малом проценте случаев...
Для начала на той же машине разверните LiveCD с Mint, Kali или еще чем-нибудь подобным и проверьте. Если ситуация не повторится, подключите репозиторий Debian 9 и попробуйте взять драйвер в виде готовых бинарных пакетов оттуда...
 

Art74

New member
Сообщения
121
#5
на РедОС сеть работает нормально, как уже говорил.
Репозиторий Debian подключу, а подскажите пожалуйста как драйвер установить из репозитория?
 

oko

New member
Сообщения
964
#6
Почитал по поводу этих сетевых карт. Народ для Debian 8 ссылался на конфликт с полным пакетом acpi-support и рекомендует заменить его на acpi-support-base, не меняя драйвер сетевой карты. Попробуйте...
Так то добавить репозиторий Debian 9 с зеркала того же Yandex в sources.list менеджера apt, а дальше обновляться с его учетом. На форуме уже много раз расписывалось, как это добавить и прописать...
 

Art74

New member
Сообщения
121
#7
Добавлять репозиторий Debian умею. С установкой драйверов из репозитория затрудняюсь.
 

oko

New member
Сообщения
964
#8
Тащем-то, да, драйвера отдельно вы в репах не найдете, ибо они ядерные. Вот набор прошивок для драйверов (в частности, пакет linux-firmware) - другое дело...
В вашем случае еще кое-что придумал: попробуйте заменить через rmmod и modprobe ваш собранный igb-модуль на e1000e. Он тоже поддерживает Intel I211. Либо попробуйте обновить ядро (лучше, конечно, из репозитория AstraLinux, если работаете на дефолтном сейчас)...
 

Art74

New member
Сообщения
121
#9
Думаю, попробую поглядеть какой драйвер на РедОсе. Может это прояснит ситуацию. Накачу Ред, отпишусь.
попробуйте заменить через rmmod и modprobe ваш собранный igb-модуль на e1000e.
как-то сложновато однако. Скачать с интела драйвер на e1000e и его попробовать поставить через make install?

uname -r
5.10.0-1038.40-generic
вроде же самое новое?
 
Последнее редактирование:

oko

New member
Сообщения
964
#10
Да, новее не найдете, во всяком случае для AstraLinux...
Модуль e1000e уже должен быть в наличии (sudo find /usr -name *e1000e* или где там в Орле модули лежат, в /usr/lib? в /lib отдельно?). Пробуйте так:
modinfo e1000e - если покажет выхлоп, значит, есть
lsmod | grep igb - если будет выхлоп, значит, используется igb-драйвер
sudo rmmod igb - отключаем модуль igb
sudo modprobe e1000e - подключаем модуль e1000e
lsmod | grep e1000e - если будет выхлоп, значит, используется e1000e-драйвер
Далее пробуем ваши операции с патч-кордами и коннектном напрямую. Если не сработает, то можно еще модуль e1000 попробовать...
 

oko

New member
Сообщения
964
#11
А вообще, надо было начать с анализа выхлопа dmesg...
Совсем я отвык от драйверных проблем...
 

Art74

New member
Сообщения
121
#12
e1000e и e1000 - сеть вообще не запустилась. Интерфейс не поднялся.
dmesg
в РедОС драйвер:
ethtool -i enp2s0
driver: igb
version: 5.4.0-k
firmware-version: 0. 6-2
expansion-rom-version:
bus-info: 0000:02:00.0
supports-statistics: yes
supports-test: yes
supports-eeprom-access: yes
supports-register-dump: yes
supports-priv-flags: yes
 
Последнее редактирование:

Art74

New member
Сообщения
121
#13
С интела скачал igb-5.4.6.
user@astra:~/Desktop/111/igb-5.4.6/src$ sudo make install
/bin/sh: cc: команда не найдена
/bin/sh: строка 0: [: -lt: ожидается унарный оператор
/bin/sh: строка 0: [: -lt: ожидается унарный оператор
make[1]: вход в каталог «/usr/src/linux-headers-5.10.0-1038.40-generic»
arch/x86/Makefile:147: CONFIG_X86_X32 enabled but no binutils support
make[1]: gcc: Команда не найдена
CC [M] /home/user/Desktops/Desktop1/111/igb-5.4.6/src/igb_main.o
/bin/sh: gcc: команда не найдена
scripts/Makefile.build:287: ошибка выполнения рецепта для цели «/home/user/Desktops/Desktop1/111/igb-5.4.6/src/igb_main.o»
make[2]: *** [/home/user/Desktops/Desktop1/111/igb-5.4.6/src/igb_main.o] Ошибка 127
Makefile:1849: ошибка выполнения рецепта для цели «/home/user/Desktops/Desktop1/111/igb-5.4.6/src»
make[1]: *** [/home/user/Desktops/Desktop1/111/igb-5.4.6/src] Ошибка 2
make[1]: выход из каталога «/usr/src/linux-headers-5.10.0-1038.40-generic»
Makefile:86: ошибка выполнения рецепта для цели «default»
make: *** [default] Ошибка 2
 

Art74

New member
Сообщения
121
#14
сделал еще так apt install gcc make
user@astra:~/Desktop/111/igb-5.4.6/src$ sudo make install
*** The target kernel has CONFIG_MODULE_SIG_ALL enabled, but
*** the signing key cannot be found. Module signing has been
*** disabled for this build.
make[1]: вход в каталог «/usr/src/linux-headers-5.10.0-1038.40-generic»
CC [M] /home/user/Desktops/Desktop1/111/igb-5.4.6/src/igb_main.o
In file included from /home/user/Desktops/Desktop1/111/igb-5.4.6/src/kcompat.h:69:0,
from /home/user/Desktops/Desktop1/111/igb-5.4.6/src/igb.h:32,
from /home/user/Desktops/Desktop1/111/igb-5.4.6/src/igb_main.c:30:
./include/generated/utsrelease.h:2:32: error: floating constant in preprocessor expression
#define UTS_UBUNTU_RELEASE_ABI 1038.40
^
/home/user/Desktops/Desktop1/111/igb-5.4.6/src/kcompat.h:817:5:
note: in expansion of macro ‘UTS_UBUNTU_RELEASE_ABI
#if UTS_UBUNTU_RELEASE_ABI > 255
^~~~~~~~~~~~~~~~~~~~~~
./include/generated/utsrelease.h:2:32:
error: floating constant in preprocessor expression
#define UTS_UBUNTU_RELEASE_ABI 1038.40
^
/home/user/Desktops/Desktop1/111/igb-5.4.6/src/kcompat.h:815:9:
note: in expansion of macro ‘UTS_UBUNTU_RELEASE_ABI
UTS_UBUNTU_RELEASE_ABI)
^~~~~~~~~~~~~~~~~~~~~~
/home/user/Desktops/Desktop1/111/igb-5.4.6/src/kcompat.h:952:50:
note: in expansion of macro ‘UBUNTU_VERSION_CODE
#if (!RHEL_RELEASE_CODE && !SLE_VERSION_CODE && !UBUNTU_VERSION_CODE)
^~~~~~~~~~~~~~~~~~~
./include/generated/utsrelease.h:2:32:
error: floating constant in preprocessor expression
#define UTS_UBUNTU_RELEASE_ABI 1038.40
^
/home/user/Desktops/Desktop1/111/igb-5.4.6/src/kcompat.h:815:9:
note: in expansion of macro ‘UTS_UBUNTU_RELEASE_ABI
UTS_UBUNTU_RELEASE_ABI)
^~~~~~~~~~~~~~~~~~~~~~
/home/user/Desktops/Desktop1/111/igb-5.4.6/src/kcompat.h:5030:6:
note: in expansion of macro ‘UBUNTU_VERSION_CODE
#if (UBUNTU_VERSION_CODE && UBUNTU_VERSION_CODE >= UBUNTU_VERSION(3,13,0,24))
^~~~~~~~~~~~~~~~~~~
./include/generated/utsrelease.h:2:32:
error: floating constant in preprocessor expression
#define UTS_UBUNTU_RELEASE_ABI 1038.40
^
/home/user/Desktops/Desktop1/111/igb-5.4.6/src/kcompat.h:815:9:
note: in expansion of macro ‘UTS_UBUNTU_RELEASE_ABI
UTS_UBUNTU_RELEASE_ABI)
^~~~~~~~~~~~~~~~~~~~~~
/home/user/Desktops/Desktop1/111/igb-5.4.6/src/kcompat.h:5030:29:
note: in expansion of macro ‘UBUNTU_VERSION_CODE
#if (UBUNTU_VERSION_CODE && UBUNTU_VERSION_CODE >= UBUNTU_VERSION(3,13,0,24))
^~~~~~~~~~~~~~~~~~~
/home/user/Desktops/Desktop1/111/igb-5.4.6/src/igb_main.c:
In function ‘igb_clean_tx_irq’:
/home/user/Desktops/Desktop1/111/igb-5.4.6/src/igb_main.c:7526:3: error: implicit declaration of function ‘read_barrier_depends’ [-Werror=implicit-function-declaration]
read_barrier_depends();
^~~~~~~~~~~~~~~~~~~~
cc1: some warnings being treated as errors
scripts/Makefile.build:287: ошибка выполнения рецепта для цели «/home/user/Desktops/Desktop1/111/igb-5.4.6/src/igb_main.o»
make[2]: *** [/home/user/Desktops/Desktop1/111/igb-5.4.6/src/igb_main.o] Ошибка 1
Makefile:1849: ошибка выполнения рецепта для цели «/home/user/Desktops/Desktop1/111/igb-5.4.6/src»
make[1]: *** [/home/user/Desktops/Desktop1/111/igb-5.4.6/src] Ошибка 2
make[1]: выход из каталога «/usr/src/linux-headers-5.10.0-1038.40-generic»
Makefile:86: ошибка выполнения рецепта для цели «default»
make: *** [default] Ошибка 2
 
Последнее редактирование:

Art74

New member
Сообщения
121
#15
Может какой-нибудь костыль подскажете. Например чтобы сперва сетка запускалась, а потом уже графика.
 

oko

New member
Сообщения
964
#16
Мде, с компилляцией будут проблемы...
У вас эта траббла только при старте ОС или при любом отключении/подключении патч-корда? Если при любом, то вначале сделайте sudo dmesg -C, затем отключите и подключите патч, затем sudo dmesg и весь выхлоп приложите сюда. Что-то мне подсказывает, что мы ищем проблему не там...
И, кстати, какой драйвер у вас сейчас-то используется?
 

Art74

New member
Сообщения
121
#17
Ну как-бы вот так. Вроде ничего подозрительного.
user@astra:~$ sudo dmesg -C
user@astra:~$
user@astra:~$ sudo dmesg
[ 196.186777] igb 0000:02:00.0 eth0: igb: eth0 NIC Link is Down
[ 232.037059] igb 0000:02:00.0 eth0: igb: eth0 NIC Link is Up 100 Mbps Full Duplex, Flow Control: RX/TX
[ 232.037134] igb 0000:02:00.0 eth0: Link Speed was downgraded by SmartSpeed
user@astra:~$
Да, при любом отключении/подключении патч-корда одинаковое поведение - задержки 20 сек. Даже когда патч выдернул, не сразу реагирует.
А драйвер всё тот-же который в самом первом моём сообщении (driver: igb). Ничего другого прикрутить не удалось.
Второй комп идентичный - установил Астру, картина та же. Думал может просто дефектный комп попался, а нет вся партия такая похоже.
 

oko

New member
Сообщения
964
#18
В BIOS/UEFI отключите все опции Intel, завязанные на вашу встроенную сетевую карту (SmartSpeed и аналогичное) и будет вам счастье. Говорил же, что проблема аппаратная (походу, аппаратная + UEFI). И, если прав, то драйвер как раз отрабатывает как положено - косячат дополнительные тулзы в составе UEFI...
 

Art74

New member
Сообщения
121
#20
Аппаратная система защиты Аккорд на компах. Может из-за неё?