Не работает запуск Libreoffice от обычного пользователя, а не из под sudo

barolina

New member
Сообщения
7
#1
LibreOffice 7.0.3.1 00(Build:1)

При запуске LibreOffice от обычного пользователя, получаем ошибку вида:

Код:
If it is already installed then try removing ~/.config/libreoffice/4/user/config/javasettings_Linux_*.xml
Warning: failed to read path from javaldx
qt.qpa.xcb: could not connect to display
qt.qpa.plugin: Could not load the Qt platform plugin "xcb" in "" even though it was found.
This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix this problem.

Available platform plugins are: eglfs, linuxfb, minimal, minimalegl, offscreen, vnc, wayland-egl, wayland, wayland-xcomposite-egl, wayland-xcomposite-glx, xcb.
Что можно с этим сделать?????????
 

barolina

New member
Сообщения
7
#6
так тоже делала

сейчас, вообще удалила полностью прям c purge
и получаю при запуске


```/usr/lib/libreoffice/program/oosplash: error while loading shared libraries: libuno_sal.so.3: cannot open shared object file: No such file or directory```
Доставила пакета, sudo apt install libuno* , эта проблема ушла

Но вернулась старая )
 

barolina

New member
Сообщения
7
#9
--headless видимо libreoffice 7.0 ни как не воспринимает, для обычного пользователя, а под sudo замечательно работает
 

kvv-vp

New member
Сообщения
62
#10
--headless видимо libreoffice 7.0 ни как не воспринимает, для обычного пользователя, а под sudo замечательно работает
Похоже какой то из плагинов не имеет прав на запуск под обычным пользователем. Ищите. Переустановите все пакеты jre, QT. Возможно поможет.