Смоленск 1.5 Проблема с VirtualBox

ozziue

New member
Сообщения
10
#1
Устанавливаю virtualbox, как сказано здесь https://wiki.astralinux.ru/pages/viewpage.action?pageId=3277139 , там есть переход на сам сайт бокса, где я устанавливаю его по инструкции для Debian дистрибутивов. Всё прекрасно ставится, версия 5.2.14, но вот во время установки вылезла такая ошибка
This system is currently not set up to build kernel modules.
Please install the gcc make perl packages from your distribution.

There were problems setting up VirtualBox. To re-start the set-up process, run
/sbin/vboxconfig
as root.
Запускал сам VirtualBox, создавал там машину с Windows XP SP3, но при запуске выдает следующую ошибку
Kernel driver not installed (rc=-1908)

The VirtualBox Linux kernel driver (vboxdrv) is either not loaded or there is a permission problem with /dev/vboxdrv. Please reinstall the kernel module by executing

'/sbin/vboxconfig'

as root.

where: suplibOsInit what: 3 VERR_VM_DRIVER_NOT_INSTALLED (-1908) - The support driver is not installed. On linux, open returned ENOENT.
Лазил по разным форумам, но решения проблемы так и не нашёл. Если у кого было также и кто смог это побороть, помогите, пожалуйста.
 

kostia

New member
Сообщения
170
#2
С диска разработчика нужно поставить необходимые пакеты.
 

ozziue

New member
Сообщения
10
#3
Какие именно пакеты? Выполнял команду apt-get install gcc make perl, но он мне выдаёт
Package make is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or is only available from another source

Package gcc is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or is only available from another source

E: Package 'gcc' has no installation candidate
E: Package 'make' has no installation candidate
 

ozziue

New member
Сообщения
10
#6
А можно обойтись без этого диска? В инете нет этих пакетов разве?
 

ozziue

New member
Сообщения
10
#8
А не подскажете, та ссылка на диск разработчика, это официальный сайт, или сторонний интернет магазин? Просто нужно, чтобы всё было официально, с реквизитами, актом приёма-передачи и т.п.
 

Fd1501h

Moderator
Сообщения
447
#10
А можно обойтись без этого диска? В инете нет этих пакетов разве?
Если у вас данный АРМ не аттестуется и нет требований по защите данных, то скачате iso Орла 1.11 (примонтируйте его как локальный репозиторий) и установите с него нужные пакеты.
 

ozziue

New member
Сообщения
10
#11
Если у вас данный АРМ не аттестуется и нет требований по защите данных, то скачате iso Орла 1.11 (примонтируйте его как локальный репозиторий) и установите с него нужные пакеты.
Скачал iso орла 1.11, пытаюсь установить пакеты, но говорит, что их не существует
 

ozziue

New member
Сообщения
10
#13
root@astra:/home/user# apt-get install gcc
Чтение списков пакетов… Готово
Построение дерева зависимостей
Чтение информации о состоянии… Готово
Некоторые пакеты невозможно установить. Возможно, вы просите невозможного,
или же используете нестабильную версию дистрибутива, где запрошенные вами
пакеты ещё не созданы или были удалены из Incoming.
Следующая информация, возможно, поможет вам:

Пакеты, имеющие неудовлетворённые зависимости:
gcc : Зависит: gcc-4.7 (>= 4.7.2-1~) но он не будет установлен
E: Невозможно исправить ошибки, у вас отложены (held) битые пакеты.
root@astra:/home/user# apt-get install gcc-4.7
Чтение списков пакетов… Готово
Построение дерева зависимостей
Чтение информации о состоянии… Готово
Некоторые пакеты невозможно установить. Возможно, вы просите невозможного,
или же используете нестабильную версию дистрибутива, где запрошенные вами
пакеты ещё не созданы или были удалены из Incoming.
Следующая информация, возможно, поможет вам:

Пакеты, имеющие неудовлетворённые зависимости:
gcc-4.7 : Зависит: gcc-4.7-base (= 4.7.2-5) но 4.7.2-5astra.se1 будет установлен
Зависит: cpp-4.7 (= 4.7.2-5) но 4.7.2-5astra.se1 будет установлен
Зависит: libitm1 (>= 4.7.2-5) но он не будет установлен
E: Невозможно исправить ошибки, у вас отложены (held) битые пакеты.
 

Fd1501h

Moderator
Сообщения
447
#14
root@astra:/home/user# apt-get install gcc
Чтение списков пакетов… Готово
Построение дерева зависимостей
Чтение информации о состоянии… Готово
Некоторые пакеты невозможно установить. Возможно, вы просите невозможного,
или же используете нестабильную версию дистрибутива, где запрошенные вами
пакеты ещё не созданы или были удалены из Incoming.
Следующая информация, возможно, поможет вам:

Пакеты, имеющие неудовлетворённые зависимости:
gcc : Зависит: gcc-4.7 (>= 4.7.2-1~) но он не будет установлен
E: Невозможно исправить ошибки, у вас отложены (held) битые пакеты.
root@astra:/home/user# apt-get install gcc-4.7
Чтение списков пакетов… Готово
Построение дерева зависимостей
Чтение информации о состоянии… Готово
Некоторые пакеты невозможно установить. Возможно, вы просите невозможного,
или же используете нестабильную версию дистрибутива, где запрошенные вами
пакеты ещё не созданы или были удалены из Incoming.
Следующая информация, возможно, поможет вам:

Пакеты, имеющие неудовлетворённые зависимости:
gcc-4.7 : Зависит: gcc-4.7-base (= 4.7.2-5) но 4.7.2-5astra.se1 будет установлен
Зависит: cpp-4.7 (= 4.7.2-5) но 4.7.2-5astra.se1 будет установлен
Зависит: libitm1 (>= 4.7.2-5) но он не будет установлен
E: Невозможно исправить ошибки, у вас отложены (held) битые пакеты.
sudo apt-get update
пакажите
 

ozziue

New member
Сообщения
10
#15
root@astra:~# sudo apt-get update
Игн file: orel InRelease
Получено:1 file: orel Release.gpg [490 B]
Получено:2 file: orel Release [5 011 B]
Игн file: orel/contrib Translation-ru_RU
Игн file: orel/contrib Translation-ru
Игн file: orel/contrib Translation-en
Игн file: orel/main Translation-ru_RU
Игн file: orel/main Translation-ru
Игн file: orel/main Translation-en
Игн file: orel/non-free Translation-ru_RU
Игн file: orel/non-free Translation-ru
Игн file: orel/non-free Translation-en
Чтение списков пакетов… Готово