Автоматическое монтирование пользовательских папок

JoKeR174

New member
Сообщения
34
#1
Добрый день.

Товарищи, подскажите как возможно настроить автоматическое монтирование сетевых пользовательских(у каждого своя) папок?
Если делать вручную, то срабатывает нормально:
sudo mount \\ip\mail\$user \mnt\mail
Если прописывать в fstab, то не монтирует и ругается на переменную $user, т.к. видать не может определить ее.
 

peb

New member
Сообщения
58
#2
Скорее всего, переменная $user при загрузке еще не инициализирована. Вы через автозапуск делали?
 

Вложения

  • 208.2 КБ Просмотры: 54

JoKeR174

New member
Сообщения
34
#3
Скорее всего, переменная $user при загрузке еще не инициализирована. Вы через автозапуск делали?
В fstab проверял уже в загруженной системе, т.е. инициализировал монтирование через sudo mount -a
По логам видно, что команда на монтирование подается с переменной $user, не заменяя ее логином
 

JoKeR174

New member
Сообщения
34
#4
Понял что с fstab так у нас не получился сработать, решил перейти на pam_mount
В итоге после настройки он монтирует вроде все как надо, но если настраивать на юзерские настройки через luserconf name= то диски не монтируются, постоянно пишет в логах:
Код:
rdconf1.c:756): path to luserconf set to /home/ZAKAZ/test/.srv/.pam_mount.conf.xml
(pam_mount.c:365): pam_mount 2.16: entering auth stage
pam_unix(fly-dm:session): session opened for user test by (uid=0)
(rdconf1.c:756): path to luserconf set to /home/ZAKAZ/test/.srv/.pam_mount.conf.xml
(pam_mount.c:568): pam_mount 2.16: entering session stage
(pam_mount.c:616): going to readconfig /home/ZAKAZ/test/.srv/.pam_mount.conf.xml
(rdconf1.c:405): Tried to set command from user config: not permitted
(rdconf1.c:405): Tried to set <mntoptions allow=...> from user config: not permitted
(rdconf1.c:405): Tried to set <mntoptions allow=...> from user config: not permitted
(rdconf2.c:127): checking sanity of luserconf volume record (obmen)
(rdconf2.c:70): option "allow_root" required
Luser volume for /home/ZAKAZ/test/Obmen is missing options that are required by global <mntoptions>
command: 'pmvarrun' '-u' 'test' '-o' '1'
(pam_mount.c:441): pmvarrun says login count is 1
pam_mount.c:660): done opening session (ret=0)