Смоленск 1.6 Ald+почтовый сервер

MasterShkip

New member
Сообщения
19
#1
Доброго дня уважаемые. Столкнулся с такой проблемой, настроилDNS, ald и почтовый сервер согласно руководству администратора. Принципиалы smtp и imap созданы в домене, указаны ключи и принадлежность к mac и mail. На клиентах Thunderbird настройки сервера распознаёт, аутентификация через Kerberos, почта отправляется но до другого пользователя не доходит. Может ли быть такое что эксперименты провожу на Резервном сервере а не на основном?Ещё бинд в логах пишет что не может создать сессионный ключ, возможна ли в этом проблема?
 
Последнее редактирование:

oko

New member
Сообщения
965
#2
Логи bind, exim и dovecot увидеть бы для диагностики. Только просьба, вначале их обнулите, рестартаните сервисы и потом выкладывайте до момента ошибки включительно...
 

MasterShkip

New member
Сообщения
19
#3
Спасибо что откликнулись. Логи только завтра смогу показать. А возможно ли что из за того что в файле hostname у меня указано короткое имя, по типу "ald" а не "ald.domain.net", а принципалы созданы типа "imap/ald.domain.net" и поэтому не работает почта? Сам себе я отправляю письмо и принимаю, а вот кому то другому нет. Можете подсказать как правильно логи собрать? Я не особо силён в линукск, обычно в syslog смотрю ошибки
 
Последнее редактирование:

oko

New member
Сообщения
965
#4
Нет, в /etc/hostname должно быть короткое имя, а fqdn-имя (короткое+домен) формируется иным способом...
Логи же ищите в /var/log для exim, dovecot и bind - либо раздельные каталоги, либо раздельные файлы логов с характерными названиями. Зависит от того, как настраивали логирование...
Почитайте еще мои эксперименты с почтовым сервером (тут, правда, без ALD и на минималках, но суть та же). Впрочем, дальше приводил пример и для ALD. Плюс, как минимум, про логирование расписывал...
 

MasterShkip

New member
Сообщения
19
#5
Вот логи, сегодня снова пробовал отправить во внешний мир, меня не получают. Может ли быть такое что на оконечнике не настроен домен ALD и поэтому не получают мои сообщения?
 

Вложения

oko

New member
Сообщения
965
#6
Наличие или отсутствие ALD в данном случае не влияет. Лишь бы был почтовый сервер на оконечнике...
Бегло по логу у вас косяк только в dovecot, который не может создать каталог "отправлено" (Sent) для нужного клиента. Не может, вероятно, потому что криво настроен в части битов parsec...
В остальном вроде как все в порядке - exim, который и отвечает за отправку (не прием) функционирует корректно. Разумеется, если под "внешним миром" вы имеете в виду домен astra10.lan...
 

MasterShkip

New member
Сообщения
19
#7
Спасибо за ответ, с dovecot только chown -R dovecot var/run/dovecot и chmod 755 /var/run/dovecot делал
 

oko

New member
Сообщения
965
#8
Не, chmod/chown - это общесистемное, а биты parsec уже завязаны на механизмы защиты ALSE. Мне откровенно не нравится, что "Operation not permitted" - чего-то не хватает dovecot для запуска astrase-fix-maildir, который эти биты и выставляет...
Впрочем, все это к вашей ситуации имеет малое отношение. За отправку отвечает exim4, а ошибка dovecot максимум не давала бы копировать отправленное сообщение в каталог "Отправленные", отображаемый в Thunderbird или ином email-клиенте...
Вы настройку логирования exim4 делали как по моей ссылке расписано? Такое ощущение, что чего-то в логах не хватает...
 

MasterShkip

New member
Сообщения
19
#9
Да, именно по Вашей инструкции делал логирование. До того как это сделал, в папке /var/log/exim4 были уже логи, после перезапуска exim появились под новыми именами, которые прикреплял ранее. Послезавтра только снова доберусь до сервера, посмотрю старые логи, может там что то не досмотрел. Без Ald всё работает, отправляется, принимается, но захотелось сделать по правильному и вот уже как неделю бьюсь.