pycharm-community-2021.3.2 AstraLinux CE (Orel-current)

Сообщения
3
#1
Здравствуйте!
Пробую использовать Orel-current с IDE pycharm-community. IDE запустилась, но сообщает что в системе установлен git версии 2.11, а минимально поддерживаемая версия 2.17.
Как я могу самостоятельно собрать свежий git не из исходников? Есть какая-то документация как это можно сделать?
 

Montfer

New member
Сообщения
2 116
#4
Нет, а как это сделать?
Дайте пожалуйста ссылку на инструкцию.
примерно, как описано тут https://wiki.astralinux.ru/pages/viewpage.action?pageId=3276859
только подключаете buster, обновляете список пакетов и пробуете установить git (результат не гарантирую). только не нужно делать upgrade или dist-upgrade с подключенными репами дебиана - это точно сломает систему
 
Сообщения
3
#5
примерно, как описано тут https://wiki.astralinux.ru/pages/viewpage.action?pageId=3276859
только подключаете buster, обновляете список пакетов и пробуете установить git (результат не гарантирую). только не нужно делать upgrade или dist-upgrade с подключенными репами дебиана - это точно сломает систему
Спасибо помогло, git теперь версии 2.20.1.
Но есть нюанс, при установке `sudo apt-get install -t buster git` были заменены/установлены не только git, но и разные системные библиотеки, включая libc.
После перезагрузки ничего не отвалилось вроде, но всё таки это не совсем чистое решение, хотелось бы избежать замены штатных системных библиотек.

Код:
$ sudo apt-get install -t buster git
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Следующие пакеты устанавливались автоматически и больше не требуются:
  lib32gcc1 lib32ncurses5 lib32stdc++6 lib32tinfo5 libc6-i386 rsync
Для их удаления используйте «sudo apt autoremove».
Будут установлены следующие дополнительные пакеты:
  git-man libc-bin libc-dev-bin libc-l10n libc6 libc6-dev libc6-i386 libcom-err2 libcomerr2 libcurl3-gnutls libgnutls30 libgssapi-krb5-2 libhogweed4
  libk5crypto3 libkrb5-3 libkrb5support0 libnettle6 libp11-kit0 libpcre2-8-0 libtasn1-6 libunistring2 locales p11-kit-modules
Предлагаемые пакеты:
  git-daemon-run | git-daemon-sysvinit git-doc git-el git-email git-gui gitk gitweb git-cvs git-mediawiki git-svn glibc-doc manpages-dev gnutls-bin
  krb5-doc krb5-user
Рекомендуемые пакеты:
  manpages manpages-dev krb5-locales
Пакеты, которые будут УДАЛЕНЫ:
  ia32-libs
НОВЫЕ пакеты, которые будут установлены:
  libcom-err2 libunistring2
Пакеты, которые будут обновлены:
  git git-man libc-bin libc-dev-bin libc-l10n libc6 libc6-dev libc6-i386 libcomerr2 libcurl3-gnutls libgnutls30 libgssapi-krb5-2 libhogweed4
  libk5crypto3 libkrb5-3 libkrb5support0 libnettle6 libp11-kit0 libpcre2-8-0 libtasn1-6 locales p11-kit-modules
обновлено 22, установлено 2 новых пакетов, для удаления отмечено 1 пакетов, и 1280 пакетов не обновлено.
Необходимо скачать 25,5 MБ архивов.
После данной операции, объём занятого дискового пространства уменьшится на 269 MB.
 
Последнее редактирование:

Montfer

New member
Сообщения
2 116
#6
Спасибо помогло, git теперь версии 2.20.1.
Но есть нюанс, при установке `sudo apt-get install -t buster git` были заменены/установлены не только git, но и разные системные библиотеки, включая libc.
После перезагрузки ничего не отвалилось вроде, но всё таки это не совсем чистое решение, хотелось бы избежать замены штатных системных библиотек.

Код:
$ sudo apt-get install -t buster git
Чтение списков пакетов… Готово
Построение дерева зависимостей      
Чтение информации о состоянии… Готово
Следующие пакеты устанавливались автоматически и больше не требуются:
  lib32gcc1 lib32ncurses5 lib32stdc++6 lib32tinfo5 libc6-i386 rsync
Для их удаления используйте «sudo apt autoremove».
Будут установлены следующие дополнительные пакеты:
  git-man libc-bin libc-dev-bin libc-l10n libc6 libc6-dev libc6-i386 libcom-err2 libcomerr2 libcurl3-gnutls libgnutls30 libgssapi-krb5-2 libhogweed4
  libk5crypto3 libkrb5-3 libkrb5support0 libnettle6 libp11-kit0 libpcre2-8-0 libtasn1-6 libunistring2 locales p11-kit-modules
Предлагаемые пакеты:
  git-daemon-run | git-daemon-sysvinit git-doc git-el git-email git-gui gitk gitweb git-cvs git-mediawiki git-svn glibc-doc manpages-dev gnutls-bin
  krb5-doc krb5-user
Рекомендуемые пакеты:
  manpages manpages-dev krb5-locales
Пакеты, которые будут УДАЛЕНЫ:
  ia32-libs
НОВЫЕ пакеты, которые будут установлены:
  libcom-err2 libunistring2
Пакеты, которые будут обновлены:
  git git-man libc-bin libc-dev-bin libc-l10n libc6 libc6-dev libc6-i386 libcomerr2 libcurl3-gnutls libgnutls30 libgssapi-krb5-2 libhogweed4
  libk5crypto3 libkrb5-3 libkrb5support0 libnettle6 libp11-kit0 libpcre2-8-0 libtasn1-6 locales p11-kit-modules
обновлено 22, установлено 2 новых пакетов, для удаления отмечено 1 пакетов, и 1280 пакетов не обновлено.
Необходимо скачать 25,5 MБ архивов.
После данной операции, объём занятого дискового пространства уменьшится на 269 MB.
ну, это временная мера, пока не выпустят бесплатную версию на новой пакетной базе