Смоленск 1.5 Grub не загружает Windowds 10

ozziue

New member
Сообщения
10
#1
Здравствуйте. Ставил 10-ку на половину диска, и Астру на вторую половину. Проблема в том, что загрузчик Grub видит загрузчик винды Windows Boot Loader, но если его запустить, то он просит какой-то логин и пароль. Вводил и логин/пароль от астры, и от винды, неважно, через секунду просто снова открывается загрузчик Grub. Но. Если при загрузке системы открыть boot menu, то оттуда я могу спокойно запустить Винду и астру. Грешу, что где-то проблемы с конфигом grub'а, или что-то ещё
 

Fd1501h

Moderator
Сообщения
468
#2
Здравствуйте. Ставил 10-ку на половину диска, и Астру на вторую половину. Проблема в том, что загрузчик Grub видит загрузчик винды Windows Boot Loader, но если его запустить, то он просит какой-то логин и пароль. Вводил и логин/пароль от астры, и от винды, неважно, через секунду просто снова открывается загрузчик Grub. Но. Если при загрузке системы открыть boot menu, то оттуда я могу спокойно запустить Винду и астру. Грешу, что где-то проблемы с конфигом grub'а, или что-то ещё
При установки SE вы сами задаёте пароль для Grub. Вот его и нужно ввести.
 

ozziue

New member
Сообщения
10
#3
Ввожу пароль Grub, та же история, секунду он думает и снова открывает окно меню Grub
 

Fd1501h

Moderator
Сообщения
468
#4
1.) для проверки уберите пароль на grub
2.) У вас windows 10 и Астра на uefi установлены?
 

ozziue

New member
Сообщения
10
#6
Лично мне помогло это
Отключение запроса пароля для других ОС в загрузчике
Добавить опцию --class os --unrestricted в строку menuentry требуемой ОС в конфиге загрузчика /boot/grub/grub.cfg

https://wiki.astralinux.ru/pages/viewpage.action?pageId=15073284
Спасибо огромное, помогло решить проблему