Установка Python 2.7

Ustudorin

New member
Сообщения
4
#1
Доброго времени суток, господа!

Есть некоторый софт, который требует питон версии 2.7.

1641970536104.png


Как понят питона этой версии в репах нет вообще(
1641970665664.png


Подскажите как поставить питон версии 2.7. И возможно ли это вообще?
 

azm9s

New member
Сообщения
270
#2
Есть некоторый софт, который требует питон версии 2.7.
а в чем проблема завести его на 3 версии? различий там не так много, а библиотек на 3ю версию в астре больше чем на 2.7.

функцию print переделать из print blablabla в print(blablalbla)???
 

azm9s

New member
Сообщения
270
#3
ну или если граф среда Tk применяется..
то:
import tkinter а не import Tkinter
 

Ustudorin

New member
Сообщения
4
#5
а какой апдейт? дайте вывод команды
python --version
дык там и нету 2.7 совсем


Bash:
support@astra:~$ lsb_release -a
No LSB modules are available.
Distributor ID: AstraLinux
Description:    Astra Linux  1.6 (Smolensk)
Release:        1.6
Codename:       smolensk

support@astra:~$ python3
python3     python3.5   python3.5m  python3m   

support@astra:~$ python
-bash: python: команда не найдена

support@astra:~$ python3 --version
Python 3.5.3

support@astra:~$
а в чем проблема завести его на 3 версии?
Это проблема. Код закрыт

Ок. Думаю, ну может из сорцов собрать
Bash:
wget https://www.python.org/ftp/python/2.7.13/Python-2.7.13.tar.xz &&
tar -xvf Python-2.7.13.tar.xz &&
cd Python-2.7.13 &&
./configure && sudo make && sudo make install &&
Но ему надо gcc !
Bash:
checking for gcc... no
checking for cc... no
checking for cl.exe... no
configure: error: in `/home/support/Python-2.7.13':
configure: error: no acceptable C compiler found in $PATH
See `config.log' for more details
В какую сторону копать?
 

Montfer

New member
Сообщения
1 888
#6
интересно вы даете инфу:
просил написать про апдейт, а не про систему, и просил дать вывод команды python --version, а не python и python3
 

Ustudorin

New member
Сообщения
4
#9
дать вывод команды python --version,
так нету ее там. Есть только python3
1642061050166.png


Про апдейт не совсем понял. В общем судя по докам https://wiki.astralinux.ru/pages/viewpage.action?pageId=36078431

1642061280966.png


Если файла /etc/astra_update_version (для ОСAstra Linux Special Edition РУСБ.10015-01 (очередное обновление 1.5) - /etc/astra-update-version) нет - значит оперативное обновление не было установлено.
Значит нет апдейтов

Bash:
root@astra:/home/support# uname -a
Linux astra 4.15.3-1-generic #astra17 SMP Mon Feb 25 18:18:04 UTC 2019 x86_64 GNU/Linux
есть у меня десяток скриптов питоновских.... закрыть их как то можно?
Ну это в байт коде просто - в .pyc

из пакетов ALSE 1.5 установите.
Можно поподробней пожалуйста
 

azm9s

New member
Сообщения
270
#10
dpkg -i /home/user/python2.7_as*blablabla.deb

и так со всеми либами к 2.7 которые идут не в составе основного установочного пакета.
 

azm9s

New member
Сообщения
270
#11
пакет установочный взять с установочного диска pool/main/p/python*
 

azm9s

New member
Сообщения
270
#12
но!!
только сейчас проверил на alse 1.6 с обновами 1.6...
python2.7 есть. и работает.
 

Montfer

New member
Сообщения
1 888
#14
так нету ее там. Есть только python3
Посмотреть вложение 1967

Про апдейт не совсем понял. В общем судя по докам https://wiki.astralinux.ru/pages/viewpage.action?pageId=36078431

Посмотреть вложение 1968


Значит нет апдейтов

Bash:
root@astra:/home/support# uname -a
Linux astra 4.15.3-1-generic #astra17 SMP Mon Feb 25 18:18:04 UTC 2019 x86_64 GNU/Linux

Ну это в байт коде просто - в .pyc


Можно поподробней пожалуйста
омг, какой же трудный человек. говорю же покажите версию
 

oko

New member
Сообщения
1 052
#19
to Montfer
Справедливости ради, топикстартер вам лог привел, где видно, что "python --version" (и с любыми иными ключами) отрабатывать не будет по причине отсутствия/замены в его системе на python3. Что явно выше 2.7 версии, нужной топикстартеру...

to Ustudorin
На диске разработчика проверьте наличие python2.7 - в main-релизе (который DVD-диск основной поставки) его может и не быть. И, если найдете, то для начала определитесь с текущим релизом/апдейтом (+1 к тов. azm9s на тему update_version). А далее читайте wiki по установке обновлений main-репозитория и dev-репозитория. Чтобы не поломать зависимости...
 

Montfer

New member
Сообщения
1 888
#20
to Montfer
Справедливости ради, топикстартер вам лог привел, где видно, что "python --version" (и с любыми иными ключами) отрабатывать не будет по причине отсутствия/замены в его системе на python3. Что явно выше 2.7 версии, нужной топикстартеру...

to Ustudorin
На диске разработчика проверьте наличие python2.7 - в main-релизе (который DVD-диск основной поставки) его может и не быть. И, если найдете, то для начала определитесь с текущим релизом/апдейтом (+1 к тов. azm9s на тему update_version). А далее читайте wiki по установке обновлений main-репозитория и dev-репозитория. Чтобы не поломать зависимости...
питон 2.7 по дефолту идет в смоленске. если его никто не выкорчевал