wine и wine32 в 1.7

zloi_bobi

New member
Сообщения
1
#1
Устанавливаю wine и winetricks, все ставиться отлично, работает.
Код:
apt-get install wine winetricks
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Будут установлены следующие дополнительные пакеты:
 cabextract fonts-wine libcapi20-3 libmspack0 libosmesa6 libvkd3d1 libwine wine64
Предлагаемые пакеты:
 ttf-mscorefonts-installer q4wine winbind playonlinux wine-binfmt dosbox exe-thumbnailer | kio-extras wine64-preloader tor
Рекомендуемые пакеты:
 wine32
Следующие НОВЫЕ пакеты будут установлены:
 cabextract fonts-wine libcapi20-3 libmspack0 libosmesa6 libvkd3d1 libwine wine wine64 winetricks
Обновлено 0 пакетов, установлено 10 новых пакетов, для удаления отмечено 0 пакетов, и 35 пакетов не обновлено.
Необходимо скачать 0 B/27,8 MB архивов.
После данной операции объём занятого дискового пространства возрастёт на 242 MB.
Пакет wine32 он сам рекомендует, но не устанавливает.
Но когда пытаюсь использовать 32 битные приложения, то wine жалуется на отсутствие пакетов wine32.
Пытаюсь установить его,но не может из-за неудовлетворенных зависимостей.

Код:
apt-get install wine
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Некоторые пакеты не могут быть установлены. Возможно, то, что вы просите,
неосуществимо, или же вы используете нестабильную версию дистрибутива, где
запрошенные вами пакеты ещё не созданы или были удалены из Incoming.
Следующая информация, возможно, вам поможет:

Следующие пакеты имеют неудовлетворённые зависимости:
wine : Зависит: wine64 (>= 4.0-2) но он не будет установлен или
                       wine32 (>= 4.0-2)
Возможно у кого-то получилось решить эту проблему и установить обе версии wine, поделитесь опытом
 

sfx09

New member
Сообщения
16
#2
аналогичная проблема в "воронеже".
по мануалу устанавливается wine 4й версии, но при этом не дает запускать x86-приложения. намекает на wine32:

Код:
lol@astralol:/etc/apt$ wine --version
it looks like wine32 is missing, you should install it.
as root, please execute "apt-get install wine32
а собственно запуск 32-разрядного приложения выдает такую ошибку:

Код:
wine: Ошибка в формате EXE для Z:\home\lol\Desktop\--\foobar2000.exe
при этом само 32-разрядное приложение можно пробовать запускать любое - ошибки на всех.

я бы и рад установить wine32, только где же его официально брать? в репозиториях не нашел.

может кто-то сможет подсказать, как быть? с wine 7.13 все в порядке, но нужно проверить запуск приложения и под wine 4.