Невозможно обновить пакеты - неудовлетворённые зависимости

juser121

New member
Сообщения
2
#1
Добрый день.

Пытаюсь провести обновление пакетов в Astra Linux (Orel 2.12.13). Проблема в том, что команда обновления показывает неудовлетворённые зависимости:
Bash:
sudo apt update && sudo apt upgrade
Игн:1 http://mirror.yandex.ru/debian stretch InRelease
Сущ:2 http://mirror.yandex.ru/debian stretch Release
Сущ:4 https://deb.nodesource.com/node_12.x stretch InRelease
Сущ:5 https://mirror.yandex.ru/astra/stable/orel/repository orel InRelease
Сущ:6 https://packages.sury.org/php stretch InRelease
Сущ:7 https://dl.astralinux.ru/astra/stable/2.12_x86-64/repository orel InRelease
Чтение списков пакетов… Готово
Построение дерева зависимостей
Чтение информации о состоянии… Готово
Может быть обновлён 791 пакет. Запустите «apt list --upgradable» для показа.
Чтение списков пакетов… Готово
Построение дерева зависимостей
Чтение информации о состоянии… Готово
Расчёт обновлений… Готово
Некоторые пакеты невозможно установить. Возможно, вы просите невозможного,
или же используете нестабильную версию дистрибутива, где запрошенные вами
пакеты ещё не созданы или были удалены из Incoming.
Следующая информация, возможно, поможет вам:
Пакеты, имеющие неудовлетворённые зависимости:
libprocesscore7 : Ломает: libtaskmanager6 (< 4:5.12) но 4:5.8.6-2.1+deb9u1 будет установлен
E: Сломанные пакеты
В sources.list подключены следующие репозитории:
Bash:
cat /etc/apt/sources.list
deb https://dl.astralinux.ru/astra/stable/2.12_x86-64/repository orel main contrib non-free
deb https://mirror.yandex.ru/astra/stable/orel/repository/ orel main contrib non-free
Как это можно починить? Хочу всё-таки обновить пакеты.
 
Последнее редактирование:

Montfer

New member
Сообщения
1 578
#2
обновление астры через apt dist-upgrade. и да, на время апгрейда рекомендую отключить репы дебиана