web-приложение, работающее с USB-устройствами (весы, сканер штрих кода и т.п.)

test357

New member
Сообщения
4
#1
Добрый день!
Подскажите, кто нибудь пробовал реализовать на Astra Linux работу web-приложения с периферийным оборудованием?
Нагуглил WebUSB WebHID , но Firefox вроде как их не поддерживает. Хром - с какой то версии, но тут https://wiki.astralinux.ru/pages/viewpage.action?pageId=10387622
написано
Эта инструкция по установке Google Chrome на ОС Astra Linux Special Edition РУСБ.10015-01 (очередное обновление 1.5).
Установка на Astra Linux текущей версии может привести к негативным последствиям.

Это значит Хром официально не поддерживается?
Кто что знает на эту тему - поделитесь информацией, пожалуйста
 

Дед

New member
Сообщения
137
#2
Добрый день!
Подскажите, кто нибудь пробовал реализовать на Astra Linux работу web-приложения с периферийным оборудованием?
Нагуглил WebUSB WebHID , но Firefox вроде как их не поддерживает. Хром - с какой то версии, но тут https://wiki.astralinux.ru/pages/viewpage.action?pageId=10387622
написано
Эта инструкция по установке Google Chrome на ОС Astra Linux Special Edition РУСБ.10015-01 (очередное обновление 1.5).
Установка на Astra Linux текущей версии может привести к негативным последствиям.

Это значит Хром официально не поддерживается?
Кто что знает на эту тему - поделитесь информацией, пожалуйста
Привет.
Что здесь не понятно, хочешь, чтоб гугл за тобой следил, ставь. Потом зайди к себе в оккупант гугла и увидишь много интересного про себя, где был, когда был и т.д. Не зря ведь в хромиуме отрубили всю слежку и он поддерживается, а ты хочешь добровольно раскрыть всю информацию о себе и о своей ОС.
 

test357

New member
Сообщения
4
#3
Спасибо за ответ. Есть варианты работы с usb периферией то?
 

Montfer

New member
Сообщения
1 581
#5
Добрый день!
Подскажите, кто нибудь пробовал реализовать на Astra Linux работу web-приложения с периферийным оборудованием?
Нагуглил WebUSB WebHID , но Firefox вроде как их не поддерживает. Хром - с какой то версии, но тут https://wiki.astralinux.ru/pages/viewpage.action?pageId=10387622
написано
Эта инструкция по установке Google Chrome на ОС Astra Linux Special Edition РУСБ.10015-01 (очередное обновление 1.5).
Установка на Astra Linux текущей версии может привести к негативным последствиям.

Это значит Хром официально не поддерживается?
Кто что знает на эту тему - поделитесь информацией, пожалуйста
у вас смоленск 1.5?
 
Сообщения
452
#6
Привет.
Что здесь не понятно, хочешь, чтоб гугл за тобой следил, ставь. Потом зайди к себе в оккупант гугла и увидишь много интересного про себя, где был, когда был и т.д. Не зря ведь в хромиуме отрубили всю слежку и он поддерживается, а ты хочешь добровольно раскрыть всю информацию о себе и о своей ОС.
Согласен что лучше Хромиум. Но в Хромиуме есть переводчик страниц гугловский - я так понимаю. Кроме того любое гугловское дополнение, например vpn, может попросить запрос к данным. Ну из двух зол меньшее это Хромиум. И все таки переводчик страниц... но может я чего то не знаю?
 

Дед

New member
Сообщения
137
#7
Согласен что лучше Хромиум. Но в Хромиуме есть переводчик страниц гугловский - я так понимаю. Кроме того любое гугловское дополнение, например vpn, может попросить запрос к данным. Ну из двух зол меньшее это Хромиум. И все таки переводчик страниц... но может я чего то не знаю?
Но сам подумай, эти браузеры обрабатывал сам разработчик для своей ОС, есть ещё дополнения к безопасности киоски. контейнеры, изолированный просмотр и т.д.
 

Montfer

New member
Сообщения
1 581
#9
Ммм. А в чем разница для моего вопроса? Мы пока не привязаны к какой либо версии. Но это должна быть именно Астра
в том, что вы смотрите инструкцию для смоленска 1.5, выпущенного году эдак в 2016, пакетная база - дебиан 8, если не изменяет память. отсюда и предупреждение, что современные хромы не будут на нем работать

и вообще, после выхода 1.7 версия 1.5 снята с поддержки
 
Последнее редактирование:

test357

New member
Сообщения
4
#10
в том, что вы смотрите инструкцию для смоленска 1.5, выпущенного году эдак в 2016, пакетная база - дебиан 8, если не изменяет память. отсюда и предупреждение, что современные хромы не будут на нем работать

и вообще, после выхода 1.7 версия 1.5 снята с поддержки
Спасибо большое! Не обратил внимания на этот нюанс