Проблема с подключением репозитория Debian

Сообщения
14
#1
Добрый день!
Не получается подключить репозиторий Debian 9. Нужна последняя версия Гимпа.

Действовал по инструкции находящейся в Справочном центре Astra Linux.
Подключение репозиториев с пакетами в ОС Astra Linux и установка пакетов

пакет debian-archive-keyring установить не удается.

После команды:
wget https://dl.astralinux.ru/astra/test...ol/main/d/debian-archive-keyring/debian-archi
ve-keyring_2021.1.1_all.deb
пишет:
--2021-11-16 20:50:32-- https://dl.astralinux.ru/astra/test...ain/d/debian-archive-keyring/debian-archive-k
eyring_2021.1.1_all.deb
Распознаётся dl.astralinux.ru (dl.astralinux.ru)… 141.105.66.226
Подключение к dl.astralinux.ru (dl.astralinux.ru)|141.105.66.226|:443... соединение установлено.
HTTP-запрос отправлен. Ожидание ответа… 404 Not Found
2021-11-16 20:50:32 ОШИБКА 404: Not Found.

После команды:
sudo apt install ./debian-archive-keyring_2021.1.1_all.deb
пишет:
sudo: unable to resolve host localhost.localdomain
Чтение списков пакетов… Готово
E: В командной строке указан не поддерживаемый файл

После команды:
sudo apt-key adv --recv-keys --keyserver keys.gnupg.net EF0F382A1A7B6500
пишет:
sudo: unable to resolve host localhost.localdomain
Executing: /tmp/apt-key-gpghome.C3c80CXSVf/gpg.1.sh --recv-keys --keyserver keys.gnupg.net EF0F382A1A7B6500
gpg: сбой при получении с сервера ключей: No name

Последняя рекомендация - Временно изменить настройки DNS.
Но как это делать - не знаю. Прошу, подскажите, как действовать?
 

Montfer

New member
Сообщения
1 242
#2
Добрый день!
Не получается подключить репозиторий Debian 9. Нужна последняя версия Гимпа.

Действовал по инструкции находящейся в Справочном центре Astra Linux.
Подключение репозиториев с пакетами в ОС Astra Linux и установка пакетов

пакет debian-archive-keyring установить не удается.

После команды:
wget https://dl.astralinux.ru/astra/test...ol/main/d/debian-archive-keyring/debian-archi
ve-keyring_2021.1.1_all.deb
пишет:
--2021-11-16 20:50:32-- https://dl.astralinux.ru/astra/test...ain/d/debian-archive-keyring/debian-archive-k
eyring_2021.1.1_all.deb
Распознаётся dl.astralinux.ru (dl.astralinux.ru)… 141.105.66.226
Подключение к dl.astralinux.ru (dl.astralinux.ru)|141.105.66.226|:443... соединение установлено.
HTTP-запрос отправлен. Ожидание ответа… 404 Not Found
2021-11-16 20:50:32 ОШИБКА 404: Not Found.

После команды:
sudo apt install ./debian-archive-keyring_2021.1.1_all.deb
пишет:
sudo: unable to resolve host localhost.localdomain
Чтение списков пакетов… Готово
E: В командной строке указан не поддерживаемый файл

После команды:
sudo apt-key adv --recv-keys --keyserver keys.gnupg.net EF0F382A1A7B6500
пишет:
sudo: unable to resolve host localhost.localdomain
Executing: /tmp/apt-key-gpghome.C3c80CXSVf/gpg.1.sh --recv-keys --keyserver keys.gnupg.net EF0F382A1A7B6500
gpg: сбой при получении с сервера ключей: No name

Последняя рекомендация - Временно изменить настройки DNS.
Но как это делать - не знаю. Прошу, подскажите, как действовать?
в сетевом соединении на вкладке ipv4 укажите dns гугла 8.8.8.8 или яндекса 77.88.8.8 (как вам удобно), потом перезапустите подключение
 

oko

New member
Сообщения
769
#3
*в сторону*
Для начала стоит почитать выхлоп первой команды, подумать над выражением "404 Not Found" и не вводить остальные, пока эта проблема (отсутствие источника по причине явно некорректно скопированного адреса) не будет решена...
А лучше почитать про пакет debian-keyring и про понятие ключей репозитория (для общего развития, ага). Или хотя бы в той же инструкции найти пример подключения репозитория Debian 9 без keyring, но через trusted=yes...
 
Сообщения
190
#4
А откуда вообще взято окончание строки 2021.1.1_all.deb ? И относиться ли это к debian 9? Дайте ссылку на страничку где Вы взяли эту команду
wget https://dl.astralinux.ru/astra/test...ol/main/d/debian-archive-keyring/debian-archi
ve-keyring_2021.1.1_all.deb
Она ведь явно не отсюда. (В справочной ведь окончание _2017.5_all.deb) Все таки сейчас уже debian 10 и 11. Вы дали ссылку на Справочный Центр но не дали ссылку на страничку где Вы нашли этот адрес:
wget https://dl.astralinux.ru/astra/test...ol/main/d/debian-archive-keyring/debian-archi
ve-keyring_2021.1.1_all.deb

Вот если пройтись по ссылке этой команды то "404 Not Found" нету

wget https://dl.astralinux.ru/astra/test...keyring/debian-archive-keyring_2017.5_all.deb
 
Последнее редактирование:
Сообщения
14
#6
А откуда вообще взято окончание строки 2021.1.1_all.deb ? И относиться ли это к debian 9? Дайте ссылку на страничку где Вы взяли эту команду
wget https://dl.astralinux.ru/astra/test...ol/main/d/debian-archive-keyring/debian-archi
ve-keyring_2021.1.1_all.deb
Она ведь явно не отсюда. (В справочной ведь окончание _2017.5_all.deb) Все таки сейчас уже debian 10 и 11. Вы дали ссылку на Справочный Центр но не дали ссылку на страничку где Вы нашли этот адрес:
wget https://dl.astralinux.ru/astra/test...ol/main/d/debian-archive-keyring/debian-archi
ve-keyring_2021.1.1_all.deb

Вот если пройтись по ссылке этой команды то "404 Not Found" нету

wget https://dl.astralinux.ru/astra/test...keyring/debian-archive-keyring_2017.5_all.deb
Вот это из инструкции:

Screenshot_20211117_092830.png

Номер списка узнал на этой странице:
https://packages.debian.org/sid/debian-archive-keyring
Screenshot_20211117_093738.png
 
Сообщения
14
#7
Так он же в Синаптике есть, чего мудрить-то? Я, помнится, оттуда и установил.
Спаси Бог, за отклик! Увидел, обрадовался, нашел в Синаптике debian-archive-keyring, стал устанавливать, и вот что в итоге:
Screenshot_20211117_094249.png

W: Download is performed unsandboxed as root as file '/root/.synaptic/tmp//tmp_sh' couldn't be accessed by user '_apt'. - pkgAcquire::Run (13: Отказано в доступе)

Вот перевод (яндекс-переводчик):

W: Загрузка выполняется в незашифрованном виде как корневой файл, так как файл "/root/.synaptic/tmp//tmp_sh" не может быть доступен пользователю "_apt". - pkg Получить::Выполнить (13: Отказано в доступе)

Не знаю, что с этим делать.
Но, несмотря на это теперь в Синаптике дело обстоит так:
Screenshot_20211117_094908.png

Означает ли это, что debian-archive-keyring все таки установился?
 
Последнее редактирование:
Сообщения
14
#8
Перезагрузил компьютер, попробовал обновить Синаптик. Вот такой результат:

После обновления Синаптик_101002.png

Может быт, лучше провести всю процедуру заново?
Удалить Дебиановский репозиторий и потом снова подключить?
Если так, то как поступать с debian-archive-keyring? Тоже удалить и потом заново установить?

Гимп 2.10 так в Синаптике и не появился.
 

countmein

New member
Сообщения
15
#9
Сообщения
190
#10
Перезагрузил компьютер, попробовал обновить Синаптик. Вот такой результат:

Посмотреть вложение 1833
Может быт, лучше провести всю процедуру заново?
Удалить Дебиановский репозиторий и потом снова подключить?
Если так, то как поступать с debian-archive-keyring? Тоже удалить и потом заново установить?

Гимп 2.10 так в Синаптике и не появился.
Похожая проблема у меня была здесь. Как то она разрешилась. Нужно пожалуй посмотреть дату и время в системном трее и если они отличаются от текущй то исправить их. Мне например часто приходиться это делать вручную, потому что не знаю как синхронизировать их постоянно. Кроме того ссылка команды wget у Вас выдает ошибку как будто она битая. Впрочем, как уже было сказанно, лучше устанавливать в таком случае из Синаптика.
 
Последнее редактирование:

countmein

New member
Сообщения
15
#12
В общем, как никогда ясно, что первая программа, которую нужно установить в системе -- это Timeshift. И тут же сделать снимок системы. :) А потом уже мудрить с репозиториями и прочей фигнёй. А то зайдёшь не пойми куда и не знаешь, как выйти.
 
Сообщения
190
#13
В общем, как никогда ясно, что первая программа, которую нужно установить в системе -- это Timeshift. И тут же сделать снимок системы. :) А потом уже мудрить с репозиториями и прочей фигнёй. А то зайдёшь не пойми куда и не знаешь, как выйти.
Вам удавалось поставить ее на Астру Орла? Если не трудно то опишите процесс установки. Я вчера покопался но так еще и не понял. Я правда начинающий, поэтому очень быстро путаюсь когда приходиться что то такое делать. К тому же в интернете тоже многое пишут на слэнге и поди разбери.
 

countmein

New member
Сообщения
15
#14
Вам удавалось поставить ее на Астру Орла? Если не трудно то опишите процесс установки.
Так я же в другой теме вам ответил: скачайте не последнюю, а предпоследнюю версию, в виде deb-файла. https://github.com/teejee2008/timeshift/releases/download/v20.11.1/timeshift_20.11.1_amd64.deb. На виртуалке я из него и установил, проблем не помню. По-моему, просто открыл в менеджере файлов, все зависимости нашлись. На дисковой Астре я её собрал из исходника, чисто из интереса к процессу, но это ведь необязательно. А последнюю версию я собрать не смог, ошибки какие-то лезли. Похоже, нужен компилятор более новой версии.
 

oko

New member
Сообщения
769
#15
to Юрий В. Лангинен
Primo, в репозитории Debian 9 лежит далеко не последний GIMP...
Secundo, если Debian-репозиторий нужен на один раз, то проще добавить его через правку /etc/apt/sources.list с опцией [trusted=yes]. Что делает репозиторий "доверенным" и отключает обязательную проверку ключей подписи репозитория (для чего, собственно, нужен debian-keyring)...
 
Сообщения
14
#16
Подскажите пожалуйста, мне пришло на ум, а уменьшится ли вероятность ошибок при манипуляциях с тем или иным репозиторием, если перед тем как устанавливать новый репозиторий, пользователь снимет флажок "Разрешен" в приложении "Проверка обновлений-Настройки" и, в дальнейшем, будет работать с этим репозиторием лишь тогда, когда флаг "Разрешен" снят со всех остальных репозиториев?

А перед тем как воспользоваться любым другим репозиторием, пользователь будет снимать этот флаг со всех остальных и оставлять лишь на том, которым в данный момент планирует воспользоваться. Или это не принципиально? Я новичек, поэтому спрашиваю.

Просто в той же инструкции по установке репозиториев в Astra Linux написано, что не рекомендуется одновременно устанавливать даже два родных астровских репозитория: тестинг и экспериментал.

Флаги в Проверке обновлений .png

В данный момент подключено целых 4 репозитория.
 
Сообщения
190
#17
Так я же в другой теме вам ответил: скачайте не последнюю, а предпоследнюю версию, в виде deb-файла. https://github.com/teejee2008/timeshift/releases/download/v20.11.1/timeshift_20.11.1_amd64.deb. На виртуалке я из него и установил, проблем не помню. По-моему, просто открыл в менеджере файлов, все зависимости нашлись. На дисковой Астре я её собрал из исходника, чисто из интереса к процессу, но это ведь необязательно. А последнюю версию я собрать не смог, ошибки какие-то лезли. Похоже, нужен компилятор более новой версии.
Я скачал то что Вы говорили еще вчера но я не знаю как устанавливать. Где установочный файл? В общем как в файловом менеджере ее установить?
 

Montfer

New member
Сообщения
1 242
#18
Подскажите пожалуйста, мне пришло на ум, а уменьшится ли вероятность ошибок при манипуляциях с тем или иным репозиторием, если перед тем как устанавливать новый репозиторий, пользователь снимет флажок "Разрешен" в приложении "Проверка обновлений-Настройки" и, в дальнейшем, будет работать с этим репозиторием лишь тогда, когда флаг "Разрешен" снят со всех остальных репозиториев?

А перед тем как воспользоваться любым другим репозиторием, пользователь будет снимать этот флаг со всех остальных и оставлять лишь на том, которым в данный момент планирует воспользоваться. Или это не принципиально? Я новичек, поэтому спрашиваю.

Просто в той же инструкции по установке репозиториев в Astra Linux написано, что не рекомендуется одновременно устанавливать даже два родных астровских репозитория: тестинг и экспериментал.

Посмотреть вложение 1843
В данный момент подключено целых 4 репозитория.
приоритет репозиториев настроен в орле, поэтому можно не убирать галки. ну, а новичку лезть в тестинг и эскпериментал не нужно. и вообще экспериментал давно не обновлялся, а тестинг последнее время обновляется одновременно со стейбл, поэтому смысла в них 0
 

oko

New member
Сообщения
769
#19
*в сторону, устало*
Каждый применяемый репозиторий содержит некий перечень пакетов, представляющих собой (условно) готовые к употреблению программы или части поддержки более "комплексных" программ. В разных репозиториях могут встречаться одни и те же пакеты разной версии. И при равных прочих выполнение команд apt upgrade или apt install имя_пакета (то же самое выполняет Synaptic или иная визуальная оболочка пакетного менеджера apt) по умолчанию приведет к попытке установки наиболее "свежей" версии пакета. Что, в большинстве своем, может окончиться плачевно: от банального останова процесса установки/обновления в связи с неразрешимыми зависимостями (большинство пакетов зависят от других), до глобальных сбоев всей ОС в целом. Так что играть в эту увлекательную игру следует только тогда, когда понимаешь, что делаешь...
В рамках одного и того же дистрибутива (той же ALCE) репозитории типа stable содержат в себе перечень пакетов, опробированных авторами дистрибутива - стабильных и не создающих проблем в ОС при их инсталляции/использовании (ну почти, ага). Остальные репозитории (как видно из их названия) содержат "нестабильные", но, как правило, более "свежие" версии тех же пакетов. И использование exprerimental/testing/unstable репозиториев предназначено исключительно для энтузиастов, которые понимают, что и зачем они делают...
В рамках разных дистрибутивов дело осложняется неполной бинарной и конфигурационной совместимостью как самих дистрибутивов, так и перечней пакетов, хранящихся в их репозиториях. Поэтому смешивание репозиториев Debian 9 (и для текущей версии ALCE только 9) с ALCE также повышает вероятность сбоя ОС в целом или каких-либо программных средств в ее составе. Поэтому, при подключении таких репозиториев, опять-таки нужно понимать (и далее по тексту)...
И, главное, если уже был подключен какой-то сторонний репозиторий и с его помощью были обновлены какие-либо компоненты ОС или используемого ПО, то отключать при дальнейших обновлениях этот репозиторий крайне опасно. Потому что весьма вероятно, что проявятся проблемы с зависимостями пакетов из отключенного репозитория, ошибки взаимосвязи и т.д., и т.п. Если, конечно, полностью не понимаешь и не осознаешь, что делаешь...
 
Сообщения
190
#20
*в сторону, устало*
Каждый применяемый репозиторий содержит некий перечень пакетов, представляющих собой (условно) готовые к употреблению программы или части поддержки более "комплексных" программ. В разных репозиториях могут встречаться одни и те же пакеты разной версии. И при равных прочих выполнение команд apt upgrade или apt install имя_пакета (то же самое выполняет Synaptic или иная визуальная оболочка пакетного менеджера apt) по умолчанию приведет к попытке установки наиболее "свежей" версии пакета. Что, в большинстве своем, может окончиться плачевно: от банального останова процесса установки/обновления в связи с неразрешимыми зависимостями (большинство пакетов зависят от других), до глобальных сбоев всей ОС в целом. Так что играть в эту увлекательную игру следует только тогда, когда понимаешь, что делаешь...
В рамках одного и того же дистрибутива (той же ALCE) репозитории типа stable содержат в себе перечень пакетов, опробированных авторами дистрибутива - стабильных и не создающих проблем в ОС при их инсталляции/использовании (ну почти, ага). Остальные репозитории (как видно из их названия) содержат "нестабильные", но, как правило, более "свежие" версии тех же пакетов. И использование exprerimental/testing/unstable репозиториев предназначено исключительно для энтузиастов, которые понимают, что и зачем они делают...
В рамках разных дистрибутивов дело осложняется неполной бинарной и конфигурационной совместимостью как самих дистрибутивов, так и перечней пакетов, хранящихся в их репозиториях. Поэтому смешивание репозиториев Debian 9 (и для текущей версии ALCE только 9) с ALCE также повышает вероятность сбоя ОС в целом или каких-либо программных средств в ее составе. Поэтому, при подключении таких репозиториев, опять-таки нужно понимать (и далее по тексту)...
И, главное, если уже был подключен какой-то сторонний репозиторий и с его помощью были обновлены какие-либо компоненты ОС или используемого ПО, то отключать при дальнейших обновлениях этот репозиторий крайне опасно. Потому что весьма вероятно, что проявятся проблемы с зависимостями пакетов из отключенного репозитория, ошибки взаимосвязи и т.д., и т.п. Если, конечно, полностью не понимаешь и не осознаешь, что делаешь...
Да, установку и работу программ, особенно из сторонних репозиториев, лучше сначала пробовать на виртуальной машине. Я так и делаю с тех пор как у меня начались первые проблемы. Вы правы.
 
Последнее редактирование: