Обновления 8-9 помечают нужные пакеты как "неиспользуемые"

djastroid

New member
Сообщения
11
#1
Добрый день!
После установки 8го или 9го обновления и выполнения команды "apt install -f" большое число пакетов, таких как bridge-utils и полный комплект qemu-system помечается как ненужные и отмечаются для удаления, соотвествено autoremove их успешно удаляет. НО перед установкой обновлений в системе функционирует сетевой мост и ПК Брест его использующий..
Можно ли как-то избавиться от неверной оценки нужно сти пакетов? Обновление 6 их не трогало.
 

Montfer

New member
Сообщения
1 575
#2
Добрый день!
После установки 8го или 9го обновления и выполнения команды "apt install -f" большое число пакетов, таких как bridge-utils и полный комплект qemu-system помечается как ненужные и отмечаются для удаления, соотвествено autoremove их успешно удаляет. НО перед установкой обновлений в системе функционирует сетевой мост и ПК Брест его использующий..
Можно ли как-то избавиться от неверной оценки нужно сти пакетов? Обновление 6 их не трогало.
пишите в тех.поддержку
 

djastroid

New member
Сообщения
11
#3
10е обновление - всё то же самое. Сразу же предлагаются к удалению НУЖНЫЕ пакеты. Тех поддержка, подробно выяснив реквизиты организации, молчит.
updates.png
 

Montfer

New member
Сообщения
1 575
#4
10е обновление - всё то же самое. Сразу же предлагаются к удалению НУЖНЫЕ пакеты. Тех поддержка, подробно выяснив реквизиты организации, молчит.
Посмотреть вложение 1982
че то слышал, что определенная версия бреста к определенному обновлению ос
 

djastroid

New member
Сообщения
11
#5
Да, про версию бреста верно, но описанная ситуация происходит и без него, так как qemu присутствует в составе самой ОС.
 

oko

New member
Сообщения
946
#6
to djastroid
Primo, вот тут расписано про совместимость версий Бреста с новыми апдейтами ALSE1.6. Модуль экстрасенсорики подсказывает, что ваша версия Брест "старее", чем совместимая по умолчанию с апдейтами 7-10 для ALSE1.6. Так-то было бы неплохо указать версию используемого у вас Бреста...
Secundo, он же подсказывает, что установку Бреста (qemu, libvirt и проч.) вы производили через FTP-/HTTP- репозиторий диска Бреста, но при установке апдейтов 8 и выше этот репозиторий не использовали. Так-то было бы неплохо указать параметры /apt/sources.list и /apt/sources.list.d/ - перечня используемых репозиториев...
Tertio, начиная с апдейта 8, в ALSE1.6 в массовом масштабе устраняются уязвимости qemu, libvirt и проч., входящего в том числе в состав Бреста. Что требует обновления указанных пакетов. И было бы неплохо опять-таки поглядеть, маркирует ли apt эти пакеты при использовании апдейта 8 и выше как обновляемые. Если не маркирует, то либо сбилась схема apt, либо де факто эти пакеты у вас не используются (и Брест, соответственно, не работает), либо иные фактические ошибки, допущенные при попытке применить апдейты...
Quatro, почитайте про apt-mark - это позволяет вручную пометить пакеты для разных нужд, в том числе для игнорирования со стороны autoremove в дальнейшем...
 

djastroid

New member
Сообщения
11
#7
Спасибо за ответ!

С совместимостью Бреста всё не так просто.. Для чего изменяется цифра самих версий при обновлениях, ведь по сути, при использовании на изделиях, по документации это выходит как другая программа? У нас строго прописана версия 2.5. Как я начинаю понимать, что суть проблемы именно в уязвимостях qemu, libvirt, о которых вы упомянули, поэтому они у помечаются для удаления, так как не могут обновиться изза отсутствия этих пакетов в оперативном обновлении 10 самой Астры. Но ведь изначально они являются базовой частью ОС. Но стали частью Бреста, обновить который можно было бы "оперативным обновлением Бреста", которого почему-то нет, а обновить сменой версии на сертифицированном изделии с 2.5 на 2.6+ не является возможным.

Отмечу, что таблица совместимости Бреста с обновлениями ОС не всегда критична на практике, ведь можно использовать сценарий локальной виртуализации (только qemu, libvirt, virt-manager), упомянутый на странице 10 руководства РДЦП.10001-03 95 01, эти компоненты не зависят от обновлений ОС. Таблица совместимости, по-моему, касается лишь облачных сервисов. Ибо qemu прекрасно работает и на голой Астре, Брест, в этом случае, нужен лишь для лицензии и графической оболочки.

Все наши установки производятся из трех локальных репозиториев, которые являются копиями дисков Бреста, Астры и апдейтов, сложенных в папку /repo на самой машине сразу после установки ОС.

Про apt-mark почитаю, но помечание пакетов на удаление происходит еще до установки Бреста на чистой Астре, сетевой адаптер которой настроен как br0, соответственно автоудаление пакета bridge-utils ломает сеть..
 

oko

New member
Сообщения
946
#8
to djastroid
Primo, новые неуязвимые версии libvirt, qemu и, подозреваю, bridge-utils (качать iso на 8, 9 и 10 апдейты и читать Release, честно говоря, вломм), как раз и идут в составе 8, 9 и 10 обновлений ALSE1.6...
Secundo, используемая вами apt install -f - это метод борьбы с зависимостями при обнаружении сбоев в пакетной базе менеджера apt. И, поскольку у вас после ее выполнения летят qemu, libvirt, bridge-utils и т.п., то модуль экстрасенсорики подсказывает минимум два момента:
  1. Компоненты Бреста зависят от старых версий qemu, libvirt, bridge-utils и т.п., а апдейты лепят новые => apt пытается этого избежать и сносит их нахрен...
  2. Поскольку ваша версия Бреста официально несовместима с 8 и далее апдейтами (7 апдейт был битым и снятым с поддержки - его не рассматриваем), постольку вы эту несовместимость наглядно подтвердили не следует эти апдейты в принципе накатывать на систему со старым Брестом...
А вообще, уже давно правильным методом установки обновлений является выполнение утилиты astra-update (см. wiki по каждому апдейту - там же информация, как ее установить). Попробуйте - не исключено, что этот странный бинарь astra-update проводит обновление через вызовы apt как-то иначе, и вам это поможет...
 

djastroid

New member
Сообщения
11
#9
Вы не заметили моё последнее предложение о том, что помечание пакетов на удаление происходит еще до установки Бреста на чистой Астре. По сути Бреста с его зависимостями вообще нет, его репозиторий также пока не добавлен в список. При этом пакеты qemu обновлены с диска апдейтов, они идут в составе дисков обновлений.

Обновления устанавливаю только через astra-update -A -r, который теперь не надо скачивать отдельно, его поведение ничем не отличается.

И, таки, еще одно размышление по Бресту - таблица его совместимости с обновлениями ОС не важна по отношению к сценарию локальной виртуализации, так как пакеты qemu, libvirt являются часть ОС, поставляются с ней и на дисках её обновлений. ПК Брест их не содержит. В локальном сценарии не используется, чувствительный к обновам, пакет brest-cloud (где собственно можно увидеть логотип данного ПК), а используется лишь общепринятая графическая оболочка virt-manager, которая управляет системными qemu и libvirt.

PS. qemu и libvirt это лишь малая часть предлагаемых к удалению после обновления пакетов (см скриншот выше). После применения autoremove, к которому раньше было доверие, система может сломаться еще в нескольких местах.. Гадай потом почему встают службы..
 
Последнее редактирование:

oko

New member
Сообщения
946
#10
to djastroid
Под рукой нет сервера, где можно развернуть KVM под ALSE1.6 в чистом виде (единый интерфейс br0, qemu+libvirt). Но в прошлом году успешно такую вещь проделывал в том числе с апдейтами (кажись, как раз 8 и 9). И никаких проблем с зависимостями не наблюдалось. Впрочем, на серверы и графику-то никогда не ставлю (хотя в вашей ситуации это вряд ли влияет)...
 

Nixar

New member
Сообщения
1
#11
10е обновление - всё то же самое. Сразу же предлагаются к удалению НУЖНЫЕ пакеты. Тех поддержка, подробно выяснив реквизиты организации, молчит.
Посмотреть вложение 1982
Добрый день!
Поправьте меня если ошибаюсь, но на скрине видно сообщение о том, что были ранее установлены пакеты, а не о том что они будут удалены. Про удаление там только несколько библиотек от почтовика.