Есть простой способ восстановить загрузчик?

townbov

New member
Сообщения
26
#1
Каждый раз после сбоя питания слетает загрузчик астры, и остается только виндосный. Обновил загрузчик на Live-usb, он увидел астру на жестком и загрузил ее. А что дальше? Везде ошибки восстановления или установки grub. Почему?
1625652585196.png

в графической утилите то же ошибка:
1625652728764.png

Все что есть в интернете к астре не подходит(((
Дайте плз совет как восстановить этот гребаный загрузчик в астре. А еще лучше - заменить MBR на Grub
 

oko

New member
Сообщения
769
#3
to townbov
Вообще странное поведение - сбои питания, слет загрузчика... Загрузчик либо есть, либо его нет. Хотя grub мог не сам записаться в нужную область, а дать лишь ссылку на себя, а размещаться на другом разделе. Тут бы знать, как вы его первично инсталлировали (тем более с uefi-flash)...
С NVMe под Linux не работал, возможно там имеются свои баги (тем более в Астре, которая не очень за временем поспевает), но... Разве не тупо sudo grub-install /dev/nvme0n1, читай на само устройство, а не в конкретный раздел?
Что касается apt ugrade... Вы там случайно через dpkg не ставили и потом сносили spice? Похоже, что база apt зафиксировала изменения, а пакета-то уже и нет. Трайните его инсталл по-новой, а затем уже upgrade. Так-то может статься, что проблема вовсе не в системе как таковой...
 

Vosiley

New member
Сообщения
53
#4
Не-не-не.
Т.к. это UEFI, да еще с Windows, то размечен диск однозначно в GPT.
Загрузчик GRUB ставится таким образом в директорию EFI. Т.е. /dev/nvme0n1p2 монтируем в /mnt , далее
Код:
grub-install --efi-directory=/mnt
 

townbov

New member
Сообщения
26
#6
либо же, если в самой системе раздел EFI уже смонтирован в /boot/efi, то
Код:
grub-install --efi-directory=/boot/efi
Ага EFI именно там). gpt.png
Но при выполнении выдает ошибку. Пробовал перемонтировать в /mnt но это конечно же ничего не меняет)
install2_grub.png
инсталятор ищет папку i386-pc в /usr/lib но она в /boot/efi. Ок) копирую ее туда куда он хочет)
после этого он не может найти kernel.img и его действительно там нет! Ок)) я копирую из платформы x86_64-efi и конечно же его он не устаивает)
install3_grub.png
ошибка в каком то заголовке ELF
я здаюсь)
 

townbov

New member
Сообщения
26
#7
to townbov
Вообще странное поведение - сбои питания, слет загрузчика... Загрузчик либо есть, либо его нет. Хотя grub мог не сам записаться в нужную область, а дать лишь ссылку на себя, а размещаться на другом разделе. Тут бы знать, как вы его первично инсталлировали (тем более с uefi-flash)...
С NVMe под Linux не работал, возможно там имеются свои баги (тем более в Астре, которая не очень за временем поспевает), но... Разве не тупо sudo grub-install /dev/nvme0n1, читай на само устройство, а не в конкретный раздел?
Что касается apt ugrade... Вы там случайно через dpkg не ставили и потом сносили spice? Похоже, что база apt зафиксировала изменения, а пакета-то уже и нет. Трайните его инсталл по-новой, а затем уже upgrade. Так-то может статься, что проблема вовсе не в системе как таковой...
Загрузчик так и остается после збоя. Но биос видит только запись майкрософт.
вот записи в папке efi которые биос видел до збоя: efi.png они все остались
появилась только какая то сомнительная копия в папке Boot: boot.png
переименовать пробовал- но все равно грузится только винда((
Знаю точно, что после переустановки Астры, биос ее снова увидит))))
Переустановка как решение - это треш)
 

townbov

New member
Сообщения
26
#8
to Vosiley
64.png
странно, но платформа x86_64-efi тоже не становится
 

Vosiley

New member
Сообщения
53
#9
Нужно убедиться, установлен ли в системе пакет grub-efi.
Если это UEFI установка, то устройство никакое указывать не надо.

в общем случае, я делаю так:

Код:
# grub-mkconfig -o /boot/grub/grub.cfg
# grub-install --efi-directory=/mnt