Смоленск 1.6 Ошибка при установке пакетов

workkvd

New member
Сообщения
2
#1
Здравствуйте, после выполнения команды sudo apt upgrade не устанавливаются любые другие пакеты. Подскажите, пожалуйста, как решить данную проблему?

Код:
sudo apt install libreoffice-sdbc-hsqldb
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Возможно, для исправления этих ошибок вы захотите воспользоваться «apt-get -f install».
Пакеты, имеющие неудовлетворённые зависимости:
 attr : Зависит: libattr1 (= 1:2.4.48-4) но 1:2.4.47-2 будет установлен
 libreoffice-sdbc-hsqldb : Зависит: libreoffice-core (= 1:6.1.5-3+deb10u6) но 1:6.0.5-1astra1 будет установлен
                           Зависит: libreoffice-java-common (>= 1:6.1.5~) но он не будет установлен
                           Зависит: default-jre но он не будет установлен или
                                           sun-java6-jre но он не может быть установлен или
                                           java6-runtime или
                                           jre но он не может быть установлен
                           Зависит: libhsqldb1.8.0-java но он не будет установлен
E: Неудовлетворённые зависимости. Попытайтесь выполнить «apt --fix-broken install», не указывая имени пакета, (или найдите другое решение).

Код:
sudo apt-get -f install
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Исправление зависимостей… Готово
Следующий пакет устанавливался автоматически и больше не требуется:
  gcc-8-base
Для его удаления используйте «sudo apt autoremove».
Будут установлены следующие дополнительные пакеты:
  libattr1
Пакеты, которые будут обновлены:
  libattr1
обновлено 1, установлено 0 новых пакетов, для удаления отмечено 0 пакетов, и 1201 пакетов не обновлено.
не установлено до конца или удалено 1 пакетов.
Необходимо скачать 0 B/21,3 kB архивов.
После данной операции, объём занятого дискового пространства возрастёт на 14,3 kB.
Хотите продолжить? [Д/н] y
(Чтение базы данных … на данный момент установлено 130820 файлов и каталогов.)
Подготовка к распаковке …/libattr1_1%3a2.4.48-4_amd64.deb …
Распаковывается libattr1:amd64 (1:2.4.48-4) на замену (1:2.4.47-2) …
dpkg: ошибка при обработке архива /var/cache/apt/archives/libattr1_1%3a2.4.48-4_amd64.deb (--unpack):
 попытка перезаписать «/etc/xattr.conf», который уже имеется в пакете parsec-base 2.5.255
При обработке следующих пакетов произошли ошибки:
 /var/cache/apt/archives/libattr1_1%3a2.4.48-4_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Код:
sudo apt --fix-broken install
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Исправление зависимостей… Готово
Следующий пакет устанавливался автоматически и больше не требуется:
  gcc-8-base
Для его удаления используйте «sudo apt autoremove».
Будут установлены следующие дополнительные пакеты:
  libattr1
Пакеты, которые будут обновлены:
  libattr1
обновлено 1, установлено 0 новых пакетов, для удаления отмечено 0 пакетов, и 1201 пакетов не обновлено.
не установлено до конца или удалено 1 пакетов.
Необходимо скачать 0 B/21,3 kB архивов.
После данной операции, объём занятого дискового пространства возрастёт на 14,3 kB.
Хотите продолжить? [Д/н] y
(Чтение базы данных … на данный момент установлено 130820 файлов и каталогов.)
Подготовка к распаковке …/libattr1_1%3a2.4.48-4_amd64.deb …
Распаковывается libattr1:amd64 (1:2.4.48-4) на замену (1:2.4.47-2) …
dpkg: ошибка при обработке архива /var/cache/apt/archives/libattr1_1%3a2.4.48-4_amd64.deb (--unpack):
 попытка перезаписать «/etc/xattr.conf», который уже имеется в пакете parsec-base 2.5.255
При обработке следующих пакетов произошли ошибки:
 /var/cache/apt/archives/libattr1_1%3a2.4.48-4_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
 

Montfer

New member
Сообщения
1 108
#3
а, еще забыл: если вы ставили обновление безопасности, то правильно вот так:
sudo -s
apt dist-upgrade
 

workkvd

New member
Сообщения
2
#4
Код:
sudo apt dist-upgrade
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Возможно, для исправления этих ошибок вы захотите воспользоваться «apt-get -f install».
Пакеты, имеющие неудовлетворённые зависимости:
 attr : Зависит: libattr1 (= 1:2.4.48-4) но 1:2.4.47-2 уже установлен
E: Неудовлетворённые зависимости. Попытайтесь выполнить «apt --fix-broken install», не указывая имени пакета, (или найдите другое решение).

а, еще забыл: если вы ставили обновление безопасности, то правильно вот так:
sudo -s
apt dist-upgrade
Код:
apt dist-upgrade
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Возможно, для исправления этих ошибок вы захотите воспользоваться «apt-get -f install».
Пакеты, имеющие неудовлетворённые зависимости:
 attr : Зависит: libattr1 (= 1:2.4.48-4) но 1:2.4.47-2 уже установлен
E: Неудовлетворённые зависимости. Попытайтесь выполнить «apt --fix-broken install», не указывая имени пакета, (или найдите другое решение).