Нужны пакеты opencv

Карл

New member
Сообщения
47
#1
Где можно скачать пакеты opencv_videoio и opencv_imgcodecs ?
Нужны для собственной программы.
Под ubuntu 20.04 всё работает ок, нужно собрать под астру.
 

Карл

New member
Сообщения
47
#5
так ок, спасибо, но ругается на ключи:
W: GPG error: http://ftp.ru.debian.org/debian stretch Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 7638D0442B90D010 NO_PUBKEY 04EE
7237B7D453EC NO_PUBKEY EF0F382A1A7B6500
E: The repository 'http://ftp.ru.debian.org/debian stretch Release' is not signed.

как их правильно добавить себе ?
 

Карл

New member
Сообщения
47
#7
но нет там нужных файлов (
видимо в астре и той версии debian старая opencv (
 

Montfer

New member
Сообщения
1 168
#8
а оно разве не в подобных библиотеках? libopencv-videoio-dev_3.2.0+dfsg-6_amd64.deb
 

Карл

New member
Сообщения
47
#9

Montfer

New member
Сообщения
1 168
#10
прошу прощения, проверил, эти библиотеки для debian 10. В принципе, можно попробовать поставить, но нет гарантии, что заработает (и вообще, именно эти библиотеки вам нужны или нет)
 

Карл

New member
Сообщения
47
#11
на данный момент нужна версия 4.х т.к. исходный код собирался с ней под ubuntu
можно ли его адаптировать на 2.4 из астры - не знаю
пока собрал из исходников 4.5, но при линковке своего примера ругается на конфликт с имеющейся 2.4
 

Montfer

New member
Сообщения
1 168
#12
ну, если у вас астра в виртуалке, сделайте снимок состояния и удалите старый пакет, а потом установите новый. если это сломает ос, то откатитесь на предыдущее состояние
 

Карл

New member
Сообщения
47
#13
на реальной машине
при удалении opencv предлагает удалить fly-* - не стал делать )
удалось собрать минимальный пример с самосборной openvc4.5, пока этого хватит, далее еще не написал )