Пора озаботиться сборкой новейших версий ядра.

dened

New member
Сообщения
38
#1
В процессе импортозамещения возникла ситуация, когда заказчик без согласования с нами закупил 140 моноблоков Lenovo с новейшими процессорами i3 10100 (Comet Lake), графическая часть не поддерживается ядрами 4ой версии. Максимум что можно задействовать - это fbdev с разрешением 800х600.
Русбитех должен задуматься о подобных случаях, иначе будут претензии со стороны заказчиков: "Что же вы, дорогие, тулите нам какое-то старьё!".
 

Montfer

New member
Сообщения
981
#2
на диске разработчика для смоленска и в репозитории орла есть ядро 5.3 (если правильно помню). Есть ли в них поддержка вашего оборудования - хз
 

dened

New member
Сообщения
38
#3
на диске разработчика для смоленска и в репозитории орла есть ядро 5.3 (если правильно помню). Есть ли в них поддержка вашего оборудования - хз
Усугубляется тем, что в гос. структурах обязуют использовать СЗИ типа DallasLock или SecretNet, а их разработчики либо подменяют ядро своим (не свежим), либо предоставляют модули для текущего ядра дистрибутива, в случае с SecretNet только для 4.15.1.
 

Montfer

New member
Сообщения
981
#4
Усугубляется тем, что в гос. структурах обязуют использовать СЗИ типа DallasLock или SecretNet, а их разработчики либо подменяют ядро своим (не свежим), либо предоставляют модули для текущего ядра дистрибутива, в случае с SecretNet только для 4.15.1.
тогда да, печально. Значит, надо подгонять не только РБТ, но и разработчиков СЗИ/СКЗИ
 

oko

New member
Сообщения
570
#5
to dened
Извиняюсь, а навесные СЗИ заставляют совместно с ALSE юзать? Если так, то тот, кто заставляет, может отлично попасть на статью за растрату бюджетных средств, ага...
Единственное исключение - это подключение Astra Linux + клиентское СЗИ к уже развернутому ЦУ СЗИ. За такие извращения, конечно, юридических последствий нет, но... руки бы отрубить под корень...
 

dened

New member
Сообщения
38
#6
Смог заставить работать видео карту через фрэймбуфер в разрешении 1920х1080, сейчас другая задача - заставить работать звук, поддержки которого в 4.15.1 тоже нет :)
 

dened

New member
Сообщения
38
#7
Для работы звука пришлось руками править исходники ядра. На данный момент не работает только wifi адаптер intel 9650, поддержка которого началась только с 5.2. Тему можно закрывать, клиенты будут работать с тем что есть.