Нелинейный видео-редактор

myk2000

New member
Сообщения
1
#1
Добрый день! Нет ли стороннего нелинейного редактора видео, который можно было бы использовать в AstraLinux 1.5?
Устанавливал ли кто-нибудь flowblade, Openshot, Kdenlive или что-нибудь попроще?
 

Baradur88

New member
Сообщения
3
#2
Ставил Openshot и kdenlive из репозиториев Debian 7 Wheezy. Работает прекрасно
 

Baradur88

New member
Сообщения
3
#4
интересно, подробнее: как ставить kdenlive из репозитория Debian 7 Wheeezy?
Рабочая станция была без Интернета, поэтому:
1. Скачал все три DVD образа(.iso) Debian 7 c офф. сайта, записал на диски.
2. Поочередно для каждого диска выполнить команду sudo apt-cdrom add
3. sudo nano /etc/apt/sources.list закоментить строчки с дисками Astra (#), чтобы остались только 3 DVD Debian
4. sudo apt-get update
5. sudo apt-get install kdenlive
Поставит со всеми зависимостями. К сожалению, там очень старая версия этой монтажки, но за неимением лучшего.. Ждем выхода 1.6, чтобы сверху уже ставить пакеты из Debian 9.
p.s места не аттестованы, поэтому ставим сторонние библиотеки из репозиториев Deb`a
p.s.s можно и не записывать .iso на диски, а добавить их в sources.list, подобные процедуры в инете очень подробно описаны
 

vetlan

New member
Сообщения
12
#5
Пока нет программ в репо можно их с AppImage их запускать:

Kdenlive https://files.kde.org/kdenlive/release/
В папке с файлом в консоле нужно сделать файл исполняемым
chmod +x kdenlive-18.08.1-x86_64.AppImage
запуск
./kdenlive-18.08.1-x86_64.AppImage
Openshot https://www.openshot.org/download/
Тоже самое
chmod +x OpenShot-v2.4.3-x86_64.AppImage
Запуск
./OpenShot-v2.4.3-x86_64.AppImage
 
Сообщения
23
#6
Рабочая станция была без Интернета, поэтому:
1. Скачал все три DVD образа(.iso) Debian 7 c офф. сайта, записал на диски.
2. Поочередно для каждого диска выполнить команду sudo apt-cdrom add
3. sudo nano /etc/apt/sources.list закоментить строчки с дисками Astra (#), чтобы остались только 3 DVD Debian
4. sudo apt-get update
5. sudo apt-get install kdenlive
Поставит со всеми зависимостями. К сожалению, там очень старая версия этой монтажки, но за неимением лучшего.. Ждем выхода 1.6, чтобы сверху уже ставить пакеты из Debian 9.
p.s места не аттестованы, поэтому ставим сторонние библиотеки из репозиториев Deb`a
p.s.s можно и не записывать .iso на диски, а добавить их в sources.list, подобные процедуры в инете очень подробно описаны
спасибо за информацию, подходит ли репозиторий Debian 7 к AstraLinux было интересно узнать.

По видео-редакторам из своего опыта могу сказать, что OpenShot, протестированный мной в виде AppImage, удивил своей относительностью - например, не понравилось, что временные интервалы переходов надо курсором мыши устанавливать!!! Возможно, я не выяснил все возможности интерфейса, но если цифровой параметр не установить вводом с клавиатуры, это какое-то гуманитарное приложение. Поле дорожки широкое, а область всех дорожек маленькая по высоте. Анимированые титры тормозят при обработке и представлены в немногочисленных вариантах, что может быстро надоесть при многочисленных монтажах.

По скриншотам интерфейса Kdenlive выглядит солиднее. Компоновка рабочих элементов более удобна, остаётся проверить программу в работе.
 
Сообщения
23
#8
blender - это хорошо, видео уроки, которые я видел вдохновили изучить серьёзнее эту программу, хотя бы в режиме видео-редактора. Ваши ссылки могут оказаться полезными.
Но в работе с blender у меня возникли сложности, он стал подвисать при выходе из программы после работы по размещению видео-фрагментов на дорожках и я решил тормознуть процесс исследований до выяснения происхождения сбоев.

А, так, читал, что blender многие хвалят.
 
Сообщения
1
#9
Пока нет программ в репо можно их с AppImage их запускать:

Kdenlive https://files.kde.org/kdenlive/release/
В папке с файлом в консоле нужно сделать файл исполняемым
chmod +x kdenlive-18.08.1-x86_64.AppImage
запуск
./kdenlive-18.08.1-x86_64.AppImage
Openshot https://www.openshot.org/download/
Тоже самое
chmod +x OpenShot-v2.4.3-x86_64.AppImage
Запуск
./OpenShot-v2.4.3-x86_64.AppImage
Пытаюсь запустить и получаю сообщение
zenity, kdialog, Xdialog missing. Skipping ./bin//openshot-qt.wrapper.
/tmp/.mount_U6diMB/usr/bin/launch: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.17' not found (required by /tmp/.mount_U6diMB/usr/bin/libpython3.4m.so.1.0)
Что надо сделать, чтобы запустить?