Сборка проекта QT5 с помощью qmake для AstraLinux Ленинград

Silyname

New member
Сообщения
1
#1
При попытке выполнить команду qmake на файл .pro была получена ошибка:

Screenshot_20200803_170319_cr.png


При попытке установить g++ ОС сказала, что всё хорошо, при условии, что вместо g++ будет использоваться multuarch-support

Screenshot_20200803_170319_cr1.png


Дополнительно, по советов обычных линуксоидов была прописана команда install build-essential, с чем Астра Ленинград не справилась, говоря, что не хватает g++ или gcc и что присутствуют битые пакеты

При попытке восстановления пакетов командой --fix-broken install результата не дал

Screenshot_20200803_170319_cr2.png


Не получается сбилдить под Ленинград пустой проект для QT5Widgets при условии уже установленных пакетов для QT5-default
 

gosha

New member
Сообщения
24
#2
При установке g++ с помощью aptitude, такой проблемы нет.

Код:
$ sudo aptitude