Не устанавливается обновление БЮЛЛЕТЕНЬ № 20200327SE16 - Update 5

clop1000

New member
Сообщения
30
#1
Возникла проблема с установкой обновлений!
на Astra linux 1.6 (на чистую установку) Пробовал устанавливать - БЮЛЛЕТЕНЬ № 20200327SE16 - Update 5

Все делал согласно инструкции - в том числе отмену запрета на установление бита исполнения.

В ходе установки возникают проблемы с зависимостями:
cusp-daemon (>= 2.2.1-8astra.se29) но 2.2.1.-8astra.se14 уже установлен
apt -f install - не может починить это

Если apt -f install не делать вообще, то система вообще не грузится после загрузки.
 

oko

New member
Сообщения
477
#2
to clop1000
Неправильно что-то делаете. Прекрасно применяется апдейт 5 при наличии демона CUPS...
Можно обновиться и не по инструкции проще:
  • создайте каталоги /mnt/repo/main (iso-диск установки), /mnt/repo/upd (актуальный iso-апдейт);
  • монтируйте в эти каталоги свои iso-диски через sudo mount /mnt/main-disk.iso /mnt/repo/main (и аналогично для актуального апдейта);
  • внесите изменения в /etc/apt/source.list: deb file:///mnt/repo/main/ smolensk contrib non-free main (и аналогично для актуального апдейта);
  • выполните apt update && apt upgrade.
Если используются диск разработчика и актуальный апдейт для него - добавляете аналогичным способом...
iso-диск с установочного дистрибутива и диска разработчика снимайте любым доступным методом...
 

extasy

New member
Сообщения
3
#3
Возникла проблема с установкой обновлений!
на Astra linux 1.6 (на чистую установку) Пробовал устанавливать - БЮЛЛЕТЕНЬ № 20200327SE16 - Update 5

Все делал согласно инструкции - в том числе отмену запрета на установление бита исполнения.

В ходе установки возникают проблемы с зависимостями:
cusp-daemon (>= 2.2.1-8astra.se29) но 2.2.1.-8astra.se14 уже установлен
apt -f install - не может починить это

Если apt -f install не делать вообще, то система вообще не грузится после загрузки.
Если делать вручную как они пишут на wiki, то тоже всегда одни проблемы. Попробуйте инструмент astra-update для автоматической установки обновлений (https://wiki.astralinux.ru/pages/viewpage.action?pageId=71833307). Примерный порядок действий:
1) скидываете исошник установочного диска в /mnt/
2) скидываете исошник диска с апдейтом в /mnt/
3) ставите пакет astra-update
4) пускаете команду astra-update -A <исошник установочного диска> <исошник с апдейтом>

По этому способу ставил и Update5, и недавновышедший Update6. Все норм.

После этого могут быть только небольшие проблемы с дровами для некоторых видеокарт nVidia (те что поддерживают RTX), но это отдельная история и тоже решаемая.
 
Сообщения
1
#4
Здравствуйте!
У меня также возникла проблема при установке обновления Update-5. Но тут, скорее всего, моя вина, думаю где то не отключил защиту.
Произошло вот что. Запустил обновление, пошла установка пакетов, потом установщик запросил оригинальный диск Астры, и вот тут я уже не смог его смонтировать. Перезагрузил ПК и теперь не могу войти ни одним пользователем: логин пароль проходит, потом запрашиваются мандатные атрибуты и какие бы я не выбрал, вылетает ошибка. Помогите пожалуйста решить проблему.
ошибка ppfsm.tcl.jpg ошибка при монтировании в процессе обновления.jpg