Новая версия Astra Linux Common Edition 2.12.29

Насколько обновления смогли решить ваши текущие задачи?

  • Изменения актуальны для моих задач

  • Я ждал других изменений (сообщу в комментарии)


Результаты видны после голосования.

YNA

New member
Сообщения
313
Ну да, наверное про неё. Так где её найти? В стандартных репозиториях только Wine 4.*
Ещё предлагали установить Wine так:
sudo apt install --install-recommends winehq-devel
и вроде ставится самая свежая версия, но это для Убунту/Минт, да сейчас для них это и не нужно, у них и так самые свежие версии.. На Астру так вроде не поставишь.
Нам нужно установить Компас на Астру, а для этого как раз нужна Wine не ниже 6-й версии.
 

countmein

New member
Сообщения
226
А какие там тогда репозитории? Кстати, я не смог установить wine-staging, Synaptic отказывается, красненьким показывает отметку.
 

YNA

New member
Сообщения
313
Сверху (над информацией о системе), показаны репозитории 2.12.45 по умолчанию.
Снизу, тот репозиторий, который нужно добавить, что бы установить Wine 6.23
 

Вложения

countmein

New member
Сообщения
226
Добавил их, но толку нет.
Код:
Пакеты, имеющие неудовлетворённые зависимости:
 wine-staging : Зависит: wine-staging-i386 (= 6.23~buster-1+astra1)
E: Невозможно исправить ошибки, у вас отложены (held) битые пакеты.
А у вас есть этот пакет wine-staging-i386?
 

Montfer

New member
Сообщения
2 069
Добавил их, но толку нет.
Код:
Пакеты, имеющие неудовлетворённые зависимости:
wine-staging : Зависит: wine-staging-i386 (= 6.23~buster-1+astra1)
E: Невозможно исправить ошибки, у вас отложены (held) битые пакеты.
А у вас есть этот пакет wine-staging-i386?
такой пакет в каталоге ia32-lib, скорее всего, надо его установить (в смысле ia32-lib)
 

countmein

New member
Сообщения
226
Такого нет, есть ia32-libs. Его установка предлагает вот что:
Код:
Пакеты, которые будут УДАЛЕНЫ:
  binutils binutils-common binutils-x86-64-linux-gnu build-essential
  chkrootkit debhelper dh-autoreconf dh-strip-nondeterminism dkms dpkg-dev g++
  g++-6 g++-6-multilib g++-multilib gcc gcc-6 gcc-6-multilib gcc-8
  gcc-8-multilib gcc-multilib libbinutils libtool nvidia-dkms-460
  nvidia-driver-440 nvidia-driver-450 nvidia-driver-460 playonlinux
  yandex-browser-stable
Нахрена мне удалять видеодрайвер и Яндекс-браузер? А gcc зачем удалять? Что за бред?
 

Montfer

New member
Сообщения
2 069
Такого нет, есть ia32-libs. Его установка предлагает вот что:
Код:
Пакеты, которые будут УДАЛЕНЫ:
  binutils binutils-common binutils-x86-64-linux-gnu build-essential
  chkrootkit debhelper dh-autoreconf dh-strip-nondeterminism dkms dpkg-dev g++
  g++-6 g++-6-multilib g++-multilib gcc gcc-6 gcc-6-multilib gcc-8
  gcc-8-multilib gcc-multilib libbinutils libtool nvidia-dkms-460
  nvidia-driver-440 nvidia-driver-450 nvidia-driver-460 playonlinux
  yandex-browser-stable
Нахрена мне удалять видеодрайвер и Яндекс-браузер? А gcc зачем удалять? Что за бред?
сделай в консоли apt update и apt dist-upgrade

и еще вопрос libc6 случаем не обновлен до 2.28?
 

countmein

New member
Сообщения
226
Это бесполезно, все пакеты последних версий. А libc6 да, обновлена. Более ранние образы, где она старая, к сожалению, погибли при перетасовке осей на дисках.
 

Montfer

New member
Сообщения
2 069
Это бесполезно, все пакеты последних версий. А libc6 да, обновлена. Более ранние образы, где она старая, к сожалению, погибли при перетасовке осей на дисках.
м/б дело в libc6. я как то собирал openxray без проблем на штатной версии libc6 2.28 (это в астре 1.7.1 было дело), а когда закорячил туда libc6 2.31 ради эксперимента, зависимости для openxray перестали устанавливаться, ругаясь на зависимости.
может быть тут такая же ситуация
 

YNA

New member
Сообщения
313
А может дело в том, что у меня не было установлено ни каких Вайнов и по этому ни чего не конфликтует, а просто ставится версия 6.23, ни кого не трогая и ни чего не удаляя.
 

Вложения

countmein

New member
Сообщения
226
Скорее всего придётся просто установить новую версию Астры с нуля.
 

countmein

New member
Сообщения
226
Установил с нуля. Композитор таки не работает. Compton установить нельзя, т.к. он требует удаления fly-all-main, а у picom установлена только документация. Собрать его из исходников тоже нельзя, т.к. в Астре более новый пакет, чем требует одна из его зависимостей. Тупик, в общем. Разрывы в окнах при прокрутке уже задолбали.
 

Montfer

New member
Сообщения
2 069
Установил с нуля. Композитор таки не работает. Compton установить нельзя, т.к. он требует удаления fly-all-main, а у picom установлена только документация. Собрать его из исходников тоже нельзя, т.к. в Астре более новый пакет, чем требует одна из его зависимостей. Тупик, в общем. Разрывы в окнах при прокрутке уже задолбали.
если через терминал запустить picom? (при запуске compton будет то же самое, но с комментарием про устаревшее название)
 

countmein

New member
Сообщения
226
если через терминал запустить picom?
Команда не найдена. В пакете только документация.
Код:
$ dpkg -L picom
/.
/usr
/usr/share
/usr/share/doc
/usr/share/doc/picom
/usr/share/doc/picom/README.md.gz
/usr/share/doc/picom/changelog.Debian.gz
/usr/share/doc/picom/copyright
/usr/share/doc/picom/examples
/usr/share/doc/picom/examples/picom.sample.conf.gz
А собрать нельзя вот из-за этого:
Код:
Пакеты, имеющие неудовлетворённые зависимости:
libpixman-1-dev : Зависит: libpixman-1-0 (= 0.34.0-1) но 0.40.0-1astra1 будет установлен
 

Montfer

New member
Сообщения
2 069
Команда не найдена. В пакете только документация.
Код:
$ dpkg -L picom
/.
/usr
/usr/share
/usr/share/doc
/usr/share/doc/picom
/usr/share/doc/picom/README.md.gz
/usr/share/doc/picom/changelog.Debian.gz
/usr/share/doc/picom/copyright
/usr/share/doc/picom/examples
/usr/share/doc/picom/examples/picom.sample.conf.gz
А собрать нельзя вот из-за этого:
Код:
Пакеты, имеющие неудовлетворённые зависимости:
libpixman-1-dev : Зависит: libpixman-1-0 (= 0.34.0-1) но 0.40.0-1astra1 будет установлен
оказывается, picom у меня вообще не установлен, установлен compton из репы астры (но при обновлении еще был подключен репозиторий дебиана 9)
[06:31:54] alex@mypc:~$ dpkg -L compton
/.
/usr
/usr/bin
/usr/bin/picom
/usr/bin/picom-trans
/usr/share
/usr/share/doc
/usr/share/doc/compton
/usr/share/doc/compton/README.md.gz
/usr/share/doc/compton/changelog.Debian.gz
/usr/share/doc/compton/copyright
/usr/bin/compton
/usr/bin/compton-trans
 

countmein

New member
Сообщения
226
Разрывы, собственно, я наблюдал в Яндекс-браузере и Хромиуме. Оказалось, что они лечатся изменением размера окна, всё равно каким. Странные дела.