Континент АП не запускается

PavelM

New member
Сообщения
5
#1
Установил cts-3.7.6-70.ks1.astra1.6_amd64.deb на Astra Linux 1.6 (Смоленск) установка прошла без ошибок, вышло сообщение , что надо перезагрузить систему. После перезагрузки не запускается Континент АП, ни при загрузке, ни по ярлыку. Никаких сообщений не выдает. Что может быть и где смотреть?
 

Вложения

oko

New member
Сообщения
472
#3
to PavelM
Специально же придуман раздел документации на Континент-АП, в котором сказано, в каком порядке и что устанавливать кроме указанного вами deb-пакета...
Вы явно не установили зависимости, в частности, libopensc...
 

PavelM

New member
Сообщения
5
#4
to PavelM
Специально же придуман раздел документации на Континент-АП, в котором сказано, в каком порядке и что устанавливать кроме указанного вами deb-пакета...
Вы явно не установили зависимости, в частности, libopensc...
где можно скачать его?
по документации ставил *.deb пакеты из папки 'third party' но несколько пакетов оттуда не стали ставится, установлены более новые версии Continent_AP_2.jpg
 

oko

New member
Сообщения
472
#5
to PavelM
Там же на диске с Континент-АП должно быть все. Выбирайте пакеты под нужную версию Astra Linux. Помнится, ставил без каких-либо проблем, прочитав ReleaseNotice и Руководство администратора в части установки...
 

PavelM

New member
Сообщения
5
#6
Выше написал, что устанавливал по документации, но установщик заругался на несколько пакетов в частности opensc_0.16.0-3_amd64.deb и opensc-pkcs11_0.16.0-3amd64.deb, что уже установлены более новые версии (скриншот выше), которые видимо установились, когда настраивал доступ к ssl.budgetplan.minfin.ru и zakupki.gov.ru
 

Kovlanik

New member
Сообщения
40
#7
Выше написал, что устанавливал по документации, но установщик заругался на несколько пакетов в частности opensc_0.16.0-3_amd64.deb и opensc-pkcs11_0.16.0-3amd64.deb, что уже установлены более новые версии (скриншот выше), которые видимо установились, когда настраивал доступ к ssl.budgetplan.minfin.ru и zakupki.gov.ru
Более новые версии устанавливаются вместе с пакетом обновлений №3 для Астры Смоленск 1.6. Две нужные библиотеки повышаются до версии 6, вместо 4-й, и отсюда возникают проблемы. Поспешила Астра. Решается просто. Из пакета opensc-pkcs11_0.16.0-3_amd64.deb выдёргиваются две зависимости (можно воткнуть на горячую из MC) libopensc.so.4 и libopensc.so.4.0.0 кинуть по следующему пути \usr\lib\x86_64-linux-gnu\. И всё должно заработать. У нас в крайнем случае именно так и произошло. А вот те библиотеки и пакеты, которые система по вашей просьбе понизила, лучше вернуть на место. Ну не знаю, попробуйте apt dist-upgrade, что-ли
 

PavelM

New member
Сообщения
5
#8
Получилось! Правда еще про целостность начал писать, после пересчета контрольных сумм все заработало