Смоленск 1.6 и LVDS дисплей

KSV

New member
Сообщения
7
#1
Добрый день. Столкнулся с проблемой, может подскажет кто-нибудь куда "копать" ?
Есть "изделие" в форм-факторе ноутбука. В качестве материнской платы используется GA-H110TN . Камень: intel core i5-6600Т
Дисплей подключен по LVDS.
Установка проходит в обычном режиме, ничего особенного. Проблема появляется после окна GRUB
Система явно стартует ,но на дисплее ничего нет. Чернота. Если подключить второй дисплей по HDMI, то там есть изображение и всё работает. Но вот встроенного дисплея вообще никак в системе не видно.
Может подтолкнёт кто-нибудь в нужную сторону?
 

oko

New member
Сообщения
318
#2
to KSV
Вначале подключить HDMI монитор и посмотреть выхлоп команды xrandr примерно как тут...
Затем, если xrandr видит LVDS-матрицу ноутбука, либо внести соответствующие правки в Xorg.conf, либо стартовать тот же xrandr с указанием включенного LVDS и отключенного HDMI при старте системы. Оба варианта легко гуглятся...
 

KSV

New member
Сообщения
7
#3
to KSV
Вначале подключить HDMI монитор и посмотреть выхлоп команды xrandr примерно как тут...
Затем, если xrandr видит LVDS-матрицу ноутбука, либо внести соответствующие правки в Xorg.conf, либо стартовать тот же xrandr с указанием включенного LVDS и отключенного HDMI при старте системы. Оба варианта легко гуглятся...
пробовал. xrandr не видит следов LVDS.
Попробовал поправить /etc/X11/fly-dm/fly-dmrc , чтобы флай запускалась от рута. Нет, результат тот же.
Ноутбук и дисплей рабочий, до запуска иксов на установленной машине (в процессе установки) изображение есть.
Windows на нём работает нормально.
 

oko

New member
Сообщения
318
#4
to KSV
Давайте определимся, изображение "пропадает" в графическом режиме (при старте Fly) или сразу после выбора опции загрузки в GRUB? Т.е. ход загрузки с сообщениями типа [OK] отображается или нет?
Заодно покажите вывод команды sudo lspci и sudo xrandr...
 

KSV

New member
Сообщения
7
#5
to KSV
Давайте определимся, изображение "пропадает" в графическом режиме (при старте Fly) или сразу после выбора опции загрузки в GRUB? Т.е. ход загрузки с сообщениями типа [OK] отображается или нет?
Заодно покажите вывод команды sudo lspci и sudo xrandr...
Пардон, отвлекли по другой задаче. Так вот:
Сейчас к изделию по HDMI подцеплен второй монитор, на него изображение выводится.
До момента выбора вариантов загрузки ОС в GRUB изображение есть на обоих мониторах. После того, как выбор в GRUB сделан- на обоих мониторах есть лог загрузки, после чего "встроенный" монитор погасает ,а на втором появляется экран ввода логина и пароля fly
Пробовал в GRUB задать параметр nomodeset , странно, но система не загрузилась. После лога загрузки вместо иксов увидел просто мигающий курсор слева-сверху. Но на двух мониторах.
вывод lspci и xrandr прикладываю.
1.png

2.png


3.png
 

oko

New member
Сообщения
318
#6
to KSV
Не видит у вас xrandr матрицы ноубука с интерфейсом LVDS (вряд ли в вашем Изделии что-то допотопное используется). В том и проблема...
Не особый знаток xorg.conf, поэтому могу только посоветовать копнуть в эту сторону - "xorg lvds hdmi dual monitor"...