Установка клиентской версии 1С:Предприятие 8.3 на Astra Linux Orel 2.12.22

Сообщения
30
#1
По теме установки среды 1С в Справочном центре Astra Linux есть подробная инструкция Установка и настройка 1С на ОС СН Смоленск 1.6/ОС ОН Орёл 2.12.
Дополнительно можно изучить инструкцию 1С:ИТС Установка Платформы "1С:Предприятие" в ОС Linux.

В случае, если нужно установить только клиентскую версию для разработки или индивидуального пользования могут возникнуть проблемы зависимостей пакетов. В основном проблемы зависимостей возникают из-за неправильного порядка действий при установке.

Итак, как же установить клиентскую версию 1С:Предприятие 8.3 на Astra Linux?

Все действия по установке могут быть разделены на несколько этапов:
- скачивание дистрибутивов;
- предварительная установка требуемых пакетов;
- установка основных пакетов 1С:Предприятие 8.3;
- установка дополнений (например, драйверы USB-лицензий HASP).

* До установки 1С нужно установить СУБД согласно отдельной инструкции. В данном случае устанавливается PostgreSQL.

1. Скачивание дистрибутивов
Дистрибутивы .deb скачиваются из базы релизов 1С (https://releases.1c.ru/) после регистрации пользователя согласно списку доступных продуктов по соответствующей лицензии.
Допустим нужно установить клиент 1С:Предприятие 8.3 версии 8_3_16 на 64-бит. Скачивать нужно клиентские и серверные пакеты, например:
- клиент: client_8_3_16_1063.deb64.tar.gz
- сервер: deb64_8_3_16_1063.tar.gz

В поставку входят пакеты:
Клиент
- client (клиентские приложения (толстый клиент и тонкий клиент) "1С:Предприятия");
- thin-client (тонкий клиент "1С:Предприятия", в котором не поддерживается работа с файловым вариантом информационной базы).
Сервер
- common (общие компоненты "1С:Предприятия");
- server (компоненты сервера "1С:Предприятия");
- ws (адаптер для публикации Web-сервисов "1С:Предприятия" на веб-сервере на основе Apache HTTP Server 2.0, 2.2 или 2.4).

В поставке есть пакеты с суффиксами -nls, которые содержат языковые ресурсы, кроме русского и английского языков.

Зачем нужны серверные пакеты? - при установке клиента потребуются пакеты из серверной версии для устранения ошибок зависимостей.

После распаковки архивов в папку для установки нужно будет поместить следующие deb-пакеты:
- 1c-enterprise83-common_8.3.16-1063_amd64.deb
- 1c-enterprise83-common-nls_8.3.16-1063_amd64.deb
- 1c-enterprise83-server_8.3.16-1063_amd64.deb
- 1c-enterprise83-server-nls_8.3.16-1063_amd64.deb
- 1c-enterprise83-client_8.3.16-1063_amd64.deb
- 1c-enterprise83-client-nls_8.3.16-1063_amd64.deb

2. Установка требуемых пакетов
Некоторые пакеты должны быть установлены до начала установки основных пакетов 1С:Предприятие 8.3. Нужно проверить наличие или установить через терминал или установщик следующие пакеты:
- libwebkitgtk-3.0-0
- ttf-mscorefonts-installer
- libfontconfig1
- libgsf-1-114
- libglib2.0-0
- libodbc1
- libmagickwand-6.q16-3

При отсутствии этих пакетов на момент установки клиента 1С:Предприятие 8.3 могут возникнут ошибки зависимостей.

3. Установка клиента 1С:Предприятие 8.3
С помощью терминала или установщика deb-пакетов устанавливается клиент 1С. Рекомендуется устанавливать в следующей очерёдности:
1) 1c-enterprise83-common;
2) 1c-enterprise83-common-nls;
3) 1c-enterprise83-server;
4) 1c-enterprise83-server-nls;
5) 1c-enterprise83-client;
6) 1c-enterprise83-client-nls.

Можно отключить автозапуск службы сервера 1С, которая для работы клиента не нужна - это отключение сэкономит ресурсы системы.

Для отключения службы сервера 1С нужно выполнить в терминале sudo systemctl disable srv1cv83

4. Установка драйверов USB-лицензий HASP
При неоходимости использования usb-ключей из базы релизов 1С скачиваются драйверы и модуль HASP. Они устанавливаются без каких либо затруднений.

Далее можно пользоваться продуктом 1С:Предприятие 8.3 согласно поставленным задачам.
 
Последнее редактирование:

ViGr

New member
Сообщения
5
#2
Не работает. Не запускается стартовый экран 1С.
 

EngelS

New member
Сообщения
6
#4
Присоединюсь к проблеме.
1С в окружении fly не работает. Окна от 1С не рисуются. Текущий последний "Орёл"
 
Сообщения
1
#5
Работает, ей нужен libwebkitgtk3, который сам не устанавливается, ругается на неудовлетворенную зависимость.
Пока разбирался со СБИСом - (сбис-плагин + крипто-про), после вернулся к 1с - Клиент установился без вопросов, попросил с десяток доп.пакетов и установился.
 
Сообщения
24
#6
slava-sukhanov, я устанавливал учебную 1С. libwebkitgtk3 запросил, установил. Пока не заменишь ~/.1C/1cestartt/ibases.v8i ни чего не работает. Но даже после этого, ужасно тормозит.
 

sashacd

New member
Сообщения
2
#7
Чтобы окна 1С нормально отрисовывались я отключил сглаживание в шрифтах менее 14 размера. А без этого серые буквы на сером фоне.
 
Сообщения
4
#8
Добрый день.
Насколько критично отсутствие пакетов:
- ttf-mscorefonts-installer
- libgsf-1-114
В списке репозитория их нет. Если их отсутствие критично, подскажите где их взять.
 

Viktor

New member
Сообщения
1
#9
То же проблема с тормозами на тонком клиенте . В web -клиенте их нет. Платформа 8.3.15.1830. Сервер Windows 2008. БД файловая и sql. Ищу проблемы в мандатной модели управления доступом или в графическом окружений fly. У Вас есть подвижки в этом вопросе?

Решение; запускать платформу только под чистым тонким клиентом
 
Последнее редактирование:

LenIVEc

New member
Сообщения
14
#10
. Установка драйверов USB-лицензий HASP
При неоходимости использования usb-ключей из базы релизов 1С скачиваются драйверы и модуль HASP. Они устанавливаются без каких либо затруднений
В релизай кроме как под винду не нашёл, может уточните - где именно? С 1С:ИТС идёт прямая ссылка на сторонний ресурс для HASP
http://ftp.etersoft.ru/pub/Etersoft/HASP/last/ , но АстраЛинукс там нету, надо наверное ставить что-то из папки для Дебиана, а вот для какой версии? Как узнать, на сонове чего вышла сборка Смоленск 1.6?


Чтобы окна 1С нормально отрисовывались я отключил сглаживание в шрифтах менее 14 размера. А без этого серые буквы на сером фоне.
а где именно отключали, не подскажите?
 

LenIVEc

New member
Сообщения
14
#12
2. Установка требуемых пакетов
Некоторые пакеты должны быть установлены до начала установки основных пакетов 1С:Предприятие 8.3. Нужно проверить наличие или установить через терминал или установщик следующие пакеты:
- libwebkitgtk-3.0-0
- ttf-mscorefonts-installer
- libfontconfig1
- libgsf-1-114
- libglib2.0-0
- libodbc1
- libmagickwand-6.q16-3

При отсутствии этих пакетов на момент установки клиента 1С:Предприятие 8.3 могут возникнут ошибки зависимостей.
этот пункт автором проверялся? ругается на зависимости, не может найти пакеты в репозитории.. как их ставить-то?

Код:
 sudo apt-get install libwebkitgtk-3.0-0
Чтение списков пакетов… Готово
Построение дерева зависимостей
Чтение информации о состоянии… Готово
Возможно, для исправления этих ошибок вы захотите воспользоваться «apt-get -f install».
Пакеты, имеющие неудовлетворённые зависимости:
 libwebkitgtk-3.0-0 : Зависит: libjavascriptcoregtk-3.0-0 (= 2.4.11-3) но он не будет установлен
                      Рекомендует: geoclue-2.0 но он не может быть установлен
E: Неудовлетворённые зависимости. Попытайтесь выполнить «apt --fix-broken install», не указывая имени пакета, (или найдите другое решение).
.. почему libjavascriptcoregtk-3.0-0 (= 2.4.11-3) не будет установлен? почему рекомендуют geoclue-2.0 но он не может быть установлен?? очень всё информативно....
 
Сообщения
15
#13
Кто использует 1С клиент версий 8.3.16 и выше с ключом на локальном компьютере, напишите - нет ли у вас такой проблемы, как 100% загрузка одного ядра процессора во время работы 1С?
Какой ключ вы используете - аппаратный или программный?
 

Kgoblin

New member
Сообщения
5
#15
Кто использует 1С клиент версий 8.3.16 и выше с ключом на локальном компьютере, напишите - нет ли у вас такой проблемы, как 100% загрузка одного ядра процессора во время работы 1С?
Какой ключ вы используете - аппаратный или программный?
Сталкивался. В интернетах нашел решение, что надо отключить vhci_hcd.
Для этого в /etc/modprobe.d/blacklist.conf добавляем строку blacklist vhci_hcd
 

Kgoblin

New member
Сообщения
5
#16
Может кто сталкивался. Ошибка «Файл базы данных поврежден».
Орел 2.12.42, 1С 8.3.17.1851 файловый вариант. БГУ 2.0.78.16
База лежит на этом же компе на отдельном разделе на CCD. Папка расшарена через Самбу для других пользователей.
Пользователи по самбе работают без проблем. У локального после нескольких действий в базе она слетает с сообщением "Файл базы данных поврежден", при этом по самбе пользователи продолжают спокойно работать, а локального не пускает выдавая все туже ошибку.
После проверки файла, пускает локального пользователя, но не на долго.
Очень хочется, что бы локальный пользователь имел возможность работать.
Куда копать?
 

LenIVEc

New member
Сообщения
14
#17
И снова всех приветствую. Есть ли опыт установки 1с клиентской части в закрытой ЛВС? Интернет под запретом. Попытался вручную выкачать все пакеты, перечисленные в п.2 :
2. Установка требуемых пакетов
Некоторые пакеты должны быть установлены до начала установки основных пакетов 1С:Предприятие 8.3. Нужно проверить наличие или установить через терминал или установщик следующие пакеты:
- libwebkitgtk-3.0-0
- ttf-mscorefonts-installer
- libfontconfig1
- libgsf-1-114
- libglib2.0-0
- libodbc1
- libmagickwand-6.q16-3
так же примонтировал диск разработчика и внёс его в sources.list, закоментировав ссылку на репозиторий в интернете. В результате эти пакеты не ставятся, ссылаются на зависимости к другим пакетам, которые или не установлены, или имеют версию ниже той - что уже установлены.
 

Montfer

New member
Сообщения
1 243
#18
И снова всех приветствую. Есть ли опыт установки 1с клиентской части в закрытой ЛВС? Интернет под запретом. Попытался вручную выкачать все пакеты, перечисленные в п.2 :
2. Установка требуемых пакетов
Некоторые пакеты должны быть установлены до начала установки основных пакетов 1С:Предприятие 8.3. Нужно проверить наличие или установить через терминал или установщик следующие пакеты:
- libwebkitgtk-3.0-0
- ttf-mscorefonts-installer
- libfontconfig1
- libgsf-1-114
- libglib2.0-0
- libodbc1
- libmagickwand-6.q16-3
так же примонтировал диск разработчика и внёс его в sources.list, закоментировав ссылку на репозиторий в интернете. В результате эти пакеты не ставятся, ссылаются на зависимости к другим пакетам, которые или не установлены, или имеют версию ниже той - что уже установлены.
никак, только качать и ставить через dpkg. последовательность уставки непредсказуема