Как установить php версии >= 7.1?

exequit

New member
Сообщения
2
#1
Натолкнулся на следующую проблему:
Еще месяц назад спокойно устанавливал 1С-Битрикс на Астру CE, используя версию 7.0, однако Битрикс изменил минимальные технические требования к PHP. Теперь требуется версия не меньше 7.1. Пробовал устанавливать из стороннего репозитория версию 7.3, но что-то астра ругается на битые пакеты (действовал по инструкции https://linuxhostsupport.com/blog/how-to-install-php-7-2-on-debian-9/ ). Возможно, что-то делаю не так. Буду рад любой помощи.
 

Montfer

New member
Сообщения
885
#2
Под рукой только на виртуалке Смоленск 1.6. Сделал как в инструкции по ссылке. Только пришлось php.list руками создавать:
deb https://packages.sury.org/php/ stretch main
Да, после установки php7.2 ругалось на ошибки, но помогло sudo apt-get -f install
VirtualBox_alse16_02_12_2019_21_44_28.png
 
Последнее редактирование:

exequit

New member
Сообщения
2
#3
Спасибо большое за ответ, Montfer! В итоге моя проблема с установкой версии php 7.3 решилась следующим образом:

1. Добавляем PPA репозиторий для PHP:
sudo apt install apt-transport-https lsb-release ca-certificates libcurl3
sudo wget -O /etc/apt/trusted.gpg.d/php.gpg https://packages.sury.org/php/apt.gpg
echo "deb https://packages.sury.org/php/ stretch main" |sudo tee /etc/apt/sources.list.d/php.list

2. Выполняем update:
sudo apt update
Пишет "...Все пакеты имеют последние версии."

3. Открываем файл /etc/apt/sources.list на редактирование для отключения репозитория Астры:
sudo nano /etc/apt/sources.list
и комментируем строку :
#deb https://download.astralinux.ru/astra/stable/orel/repository/ orel main contrib non-free

4. Выполняем update:
sudo apt update
Пишет "...Может быть обновлено 11 пакетов. Запустите «apt list --upgradable» для их показа."
Обновляем все (или устанавливаем необходимые пакеты):
sudo apt upgrade

5. Устанавливаем PHP и все необходимые пакеты:
sudo apt install -y php7.3-common php7.3-readline php7.3-fpm php7.3-cli php7.3-gd php7.3-mysql php7.3-curl php7.3-mbstring php7.3-opcache php7.3-json php7.3-xml php7.3-zip

6. Открываем файл /etc/apt/sources.list на редактирование и подключаем репозиторий Астры
 

Вложения

  • 107.9 КБ Просмотры: 212

mactersait

New member
Сообщения
7
#4
Сделал по этой инструкции и все зависло. Ни терминал не отвечает и перезагрузка не помогает. Что делать не понятно
 
Сообщения
25
#5
тут описано 2 типа установки и оба палевные. надо чтобы разработчики разрешили зависимости и написали про это в википедии.
 

Olej

New member
Сообщения
1 211
#6
тут описано 2 типа установки и оба палевные. надо чтобы разработчики разрешили зависимости и написали про это в википедии.
Способ описанный exequit, с подключением репозиториев Debian (являющегося базовым для Astra Linux) а). является совершенно легальным, б). и описан и в википедии от разработчиков, в). и является вообще стандартным и типовым для Linux.

Именно так и только так нужно делать дополнительные установки в Astra Linux CE/Орёл - это всё вытекает из документации на пакетную систему DEB и менеджеры apt*.
 
Сообщения
25
#8
а). является совершенно легальным, б). и описан и в википедии от разработчиков, в). и является вообще стандартным и типовым для Linux.
отвечаю по пунктам
а) 0% правды. не согласен. конфликтов не должно быть
б) 50%правды. описано но не для этого репозитория (deb https://packages.sury.org/php/ stretch main )
в) 0% правды. стандартно подключаются новые, старые не отключаются.

добавление любого стороннего репозитория грозит потерей защиты. потому все сторонние программы должны проходить экспертизу исходников.

вот сама статья про Подключение репозиториев с пакетами в ОС Astra Linux и установка пакетов.
 
Последнее редактирование:

mactersait

New member
Сообщения
7
#11
Так по этой инструкции, добавил несколько дополнительных команд, после которых перестает ругаться на зависимости
 

mrEnst

New member
Сообщения
110
#12
Натолкнулся на следующую проблему:
Еще месяц назад спокойно устанавливал 1С-Битрикс на Астру CE, используя версию 7.0, однако Битрикс изменил минимальные технические требования к PHP. Теперь требуется версия не меньше 7.1. Пробовал устанавливать из стороннего репозитория версию 7.3, но что-то астра ругается на битые пакеты (действовал по инструкции https://linuxhostsupport.com/blog/how-to-install-php-7-2-on-debian-9/ ). Возможно, что-то делаю не так. Буду рад любой помощи.
ставьте из исходников хоть ночные билды
 

Montfer

New member
Сообщения
885
#13
еще один вариант установки php7.3 - подключить репозиторий дебиан 10 (buster) и поставить через aptitude (он ругаться, конечно же, будет, но сам разрешит все зависимости). После перезагрузки астра нормально стартанула. Если что то и сломалось, пока что не проявило себя.
 
Сообщения
25
#14
я поставил с помощью подключения репозитория echo "deb https://packages.sury.org/php/ stretch main" |sudo tee /etc/apt/sources.list.d/php.list и aptitude. надо просто грамотно ответить на вопросы:
$ sudo aptitude install php7.3-cli
Следующие НОВЫЕ пакеты будут установлены:
libargon2-1{a} libsodium23{a} php-common{a} php7.3-cli{b} php7.3-common{a} php7.3-json{a} php7.3-opcache{a} php7.3-readline{a}
0 пакетов обновлено, 8 установлено новых, 0 пакетов отмечено для удаления, и 0 пакетов не обновлено.
Необходимо получить 2 343 kБ архивов. После распаковки 12,6 MБ будет занято.
Следующие пакеты имеют неудовлетворённые зависимости:
php7.3-cli : Зависит: libpcre2-8-0 (>= 10.32) но установлен 10.22-3
Следующие действия разрешат зависимости:

Оставить для следующих пакетов их текущие версии:
1) php7.3-cli [Не установлен]

Принять данное решение? [Y/n/q/?] n
Следующие действия разрешат зависимости:

Обновить следующие пакеты:
1) libpcre2-8-0 [10.22-3 (now, stable) -> 10.34-7+0~20191219.5+debian9~1.gbp555bb9 (<NULL>)]

Принять данное решение? [Y/n/q/?] Y
Следующие НОВЫЕ пакеты будут установлены:
libargon2-1{a} libsodium23{a} php-common{a} php7.3-cli php7.3-common{a} php7.3-json{a} php7.3-opcache{a} php7.3-readline{a}
Следующие пакеты будут обновлены:
libpcre2-8-0
1 пакетов обновлено, 8 установлено новых, 0 пакетов отмечено для удаления, и 0 пакетов не обновлено.
Необходимо получить 2 571 kБ архивов. После распаковки 12,7 MБ будет занято.
Хотите продолжить? [Y/n/?] Y
...
пробуем
$ php -v
PHP 7.3.14-5+0~20200202.52+debian9~1.gbpa71879 (cli) (built: Feb 2 2020 07:56:57) ( NTS )
Copyright (c) 1997-2018 The PHP Group
Zend Engine v3.3.14, Copyright (c) 1998-2018 Zend Technologies
with Zend OPcache v7.3.14-5+0~20200202.52+debian9~1.gbpa71879, Copyright (c) 1999-2018, by Zend Technologies
 

Raynor

New member
Сообщения
1
#15
Успешно накатил по мануалу в первом сообщении с комментами от exequit PHP 7.1 (выше не поддерживается фреймворком) в дополнение к системному PHP 7.0. Никаких проблем с установкой не возникло, тьфу*3. Спасибо за обсуждение, помогло :)