совместимость репозиториев.

lincooln

New member
Сообщения
4
#1
В описании ОС ОН Орёл указанно возможность использовать репозитории debian. И даже в wiki расписана процедура как это сделать.
В инструкции речь шла про Debian 9.
Сейчас вышла версия 10.
Правильно я понимаю что для Орла 2.12.13 подходят репы только от 9ки?
Как узнать когда Орёл перейдёт на 10тую ветку debian?
 

Olej

New member
Сообщения
1 214
#2
Правильно я понимаю что для Орла 2.12.13 подходят репы только от 9ки?
Правильно понимаете. :LOL:
Последовательные выпуски Debian (9, 10, ...) - это разные системы.

Как узнать когда Орёл перейдёт на 10тую ветку debian?
Debian 9 - совершенно современная система, релиз Debian 10 получил статус stable только 2-3 месяца назад, а до этого был tested ("сомнительный"), и переход между ветками релизов Debian происходит не часто, раз в 3-4 года 9?).
Так что спешить особо оснований нет.
 
Последнее редактирование:

lincooln

New member
Сообщения
4
#3
Правильно понимаете. :LOL:
Последовательные выпуски Debian (9, 10, ...) - это разные системы.
Понятно, спасибо!
Так что спешить особо оснований нет.
Я и не спешу. Просто хотелось бы понимания.

Другой вопрос по теме совместимости.
Правильно ли я понял, если мне нужна программа которая отсутствует в основных репах (например conky, баловство, но всё же)
То я подключаю репы Debian, устанавливаю программу и репы Debian отключаю. Дабы при обновлении случайно не обновить программы установленные из родных реп.
И если это так, то может стоило озаботится кнопочкой "горячего" подключения/отключения сторонних репозиториев, хотя и понимаю что данный функционал легко решается на коленке с помощью bash скрипта, но всёже.
 

YNA

New member
Сообщения
121
#4
Да их в общем то не сложно переключать, просто поставить или снять птичку с нужного репозитория. Если достаёт постоянный ввод пароля, то его можно отключить через санкции PolicyKit (выделено на рисунке), тогда вообще будет легко подключать/отключать.
 

Вложения

lincooln

New member
Сообщения
4
#5
Ага, спасибо YNA. Но у меня почему то нет PolicyKit
Может что то до установить нужно?
Во время установки выбирал: Базовые средства, Рабочий стол Fly, Офисные средства, и средства для работы с мультимедиа.
 

Olej

New member
Сообщения
1 214
#7
То я подключаю репы Debian, устанавливаю программу и репы Debian отключаю. Дабы при обновлении случайно не обновить программы установленные из родных реп.
Думаю, что можете и не отключать.
Потому что Astra Linux CE - это ничего более чем Debian 9 дополненный графическими обёртками ("свистелками и перделками") для управления и настройки, похожими "на винду" :D (в отличие от Astra Linux SE, где отличия действительно существенные).
Обновления базовых средств никак не затронет "установленные из родных реп" - потому что нечего там ... затрагивать. Только обновление версий произойдёт, что во благо.
А все эти графические свистелки с перделками обновления никак не затронут, потому что в сторонних репозиториях подобного нет.

P.S. Кроме репозиториев Debian 9 можно подключить и репозитории Ubuntu 16.04 и Mint 18.2, если оттуда что-то захочется взять.
 

Montfer

New member
Сообщения
807
#9
не бойтесь, приоритет репозиториев выстроен так, что вы не обновите важные компоненты из репозитория дебиан...
Хотя год-полтора назад можно было при неосторожном apt upgrade получить нечто неработающее, но внешне похожее на дебиан 9
 

CrashBldash

New member
Сообщения
251
#10
Хз почему у вас это нечно не работало. У меня самый натуральный дебиан получался. Орел на пакетной базе 10го деба ожидается к концу 2020 года. Но в анстейбле будет доступен раньше.