kvm

hhaggenn

New member
Сообщения
37
#1
При создании виртуальной машины выдает вот такую ошибку:

Не удалось завершить установку: «internal error: process exited while connecting to monitor: Could not access KVM kernel module: Permission denied
failed to initialize KVM: Permission denied»

Traceback (most recent call last):
File "/usr/share/virt-manager/virtManager/asyncjob.py", line 88, in cb_wrapper
callback(asyncjob, *args, **kwargs)
File "/usr/share/virt-manager/virtManager/create.py", line 2288, in _do_async_install
guest.start_install(meter=meter)
File "/usr/share/virt-manager/virtinst/guest.py", line 461, in start_install
doboot, transient)
File "/usr/share/virt-manager/virtinst/guest.py", line 396, in _create_guest
self.domain = self.conn.createXML(install_xml or final_xml, 0)
File "/usr/lib/python2.7/dist-packages/libvirt.py", line 3523, in createXML
if ret is None:raise libvirtError('virDomainCreateXML() failed', conn=self)
libvirtError: internal error: process exited while connecting to monitor: Could not access KVM kernel module: Permission denied
failed to initialize KVM: Permission denied
 

cogniter

Moderator
Team Astra Linux
Сообщения
527
#2
в каких группах состоит пользователь, который создает виртуальную машину?
 

hhaggenn

New member
Сообщения
37
#3
В общем для пользователя libvirt-qemu необходимо было добавить группу. Сейчас это выглядти так группы libvirt-qem, libvirt, user, kvm. Какой-то из них не было. Уже не помню.
Пользователю user добавлял группы согласно руководству,
 
Сообщения
452
#4
В общем для пользователя libvirt-qemu необходимо было добавить группу. Сейчас это выглядти так группы libvirt-qem, libvirt, user, kvm. Какой-то из них не было. Уже не помню.
Пользователю user добавлял группы согласно руководству,
Что то я не понял: Как это для пользователя "libvirt-qemu необходимо было добавить группу"? В смысле пользователя libvirt-qemu добавить в группу или что? Кстати группы user нет. Есть группа users. Так же нет группы libvirt-qem. Есть группа libvirt-qemu.
 
Сообщения
452
#5
Просто возникла та же проблема и не знаю как ее решить. В группы kvm libvirt libvirt-qemu пользователь добавлен.
 

Дед

New member
Сообщения
137
#6
Просто возникла та же проблема и не знаю как ее решить. В группы kvm libvirt libvirt-qemu пользователь добавлен.
"Разувай глаза и включай мозги" Читай мануал внимательно и вникай на вики: https://wiki.astralinux.ru/pages/viewpage.action?pageId=3277425. И всё получится. Для интереса поставил. хотя у меня на ноуте на отдельном диске стоит.
 

Вложения

Сообщения
452
#7
"Разувай глаза и включай мозги" Читай мануал внимательно и вникай на вики: https://wiki.astralinux.ru/pages/viewpage.action?pageId=3277425. И всё получится. Для интереса поставил. хотя у меня на ноуте на отдельном диске стоит.
А конкретнее пожалуйста. Что сделали?
 
Последнее редактирование:
Сообщения
452
#8
"Разувай глаза и включай мозги" Читай мануал внимательно и вникай на вики: https://wiki.astralinux.ru/pages/viewpage.action?pageId=3277425. И всё получится. Для интереса поставил. хотя у меня на ноуте на отдельном диске стоит.
Забыл добавить: На виртуальной (гостевой) системе все устанавливается нормально а вот на реальной Астре проблема которую я указал выше.
 
Сообщения
452
#11
А вот это не понял, подробней.
Вначале я делаю все на виртуальной, разумеется. Я пользуюсь VirtualBox. Так вот на Орле которая установлена на VirtualBox я запускал KVM и там мне удавалось начать установку гостевой на KVM а вот на реальном Орле такая вот проблема.
 

Дед

New member
Сообщения
137
#12
Вначале я делаю все на виртуальной, разумеется. Я пользуюсь VirtualBox. Так вот на Орле которая установлена на VirtualBox я запускал KVM и там мне удавалось начать установку гостевой на KVM а вот на реальном Орле такая вот проблема.
А почему VirtualBox, а не родной QEMU/KVM? я ставил на родном и нормально, VirtualBox чужой.
 
Сообщения
452
#13
А почему VirtualBox, а не родной QEMU/KVM? я ставил на родном и нормально, VirtualBox чужой.
Вот я и хочу на QEMU/KVM перейти но столкнулся с проблемами. Кое что удалось решить (мне помогли) но вот текущую озвученную проблему я пока не решил. Если бы кто подсказал я бы сидел уже на QEMU/KVM. Вы очевидно устанавливали все через терминал а меня интересуют решения в графике. Я тут уже неоднократно спрашивал про QEMU/KVM но никто толком мне не помог, хотя были и добрые, отзывчивые люди - низкий им поклон. А начинал то вообще с винды и прочих приложений. На чужом уже успел посидеть. Но вот с недавних пор начал изучение всего и вся. Но путь этот нелегкий для начинающих. Пришлось через многое продираться, в том числе и через то с чем сталкивается любой начинающий когда начинает задавать на форуме разные вопросы.
Проблема в KVM.png
 
Последнее редактирование:
Сообщения
452
#14
А почему VirtualBox, а не родной QEMU/KVM? я ставил на родном и нормально, VirtualBox чужой.
Пока у меня как у начинающего еще глаза разбегаются от того что написанно здесь. Хочется все это научиться делать через графику. Терминалом уж как нибудь позже займусь.
 
Сообщения
452
#15
А почему VirtualBox, а не родной QEMU/KVM? я ставил на родном и нормально, VirtualBox чужой.
Попробовал сделать по инструкции и не получилось. Подскажите как Вы это делали?
Сам я сделал вот что:

sudo usermod -a -G kvm,libvirt,libvirt-qemu <имя_пользователя>

(в группу libvirt-admin разумеется не добавлял)


sudo mkdir -p /vrt/pool1
sudo chmod 750 /vrt/pool1
sudo chown <имя_пользователя> /vrt/pool1


virsh -c qemu:///system pool-define-as pool1 --type dir --target /vrt/pool1
virsh -c qemu:///system pool-build pool1
virsh -c qemu:///system pool-start pool1
virsh -c qemu:///system pool-autostart pool1
virsh -c qemu:///system pool-list --all


Команда:

virsh -c qemu:///system domdisplay vm1

выдает ошибку


error: failed to get domain 'vm1'
error: Domain not found: no domain with matching name 'vm1'

Впрочем там вообще для Special Edition.
 
Последнее редактирование:
Сообщения
452
#17
Единственно что удалось мне узнать что если менять вот эти параметры то ошибка будет другой.
Проблема в KVM1.png
 
Сообщения
452
#18
Так же хочу напомнить что в гостевых системах на VirtualBox таких проблем нет. Там KVM работает на Орле. А на реальных двух компьютерах нет.