Установка Крипто Про и Rutoken S

Igor

New member
Сообщения
13
#1
Подскажите где взять пакет pcsc-tools для установки на Орел Рутокена с подписью.
 

Igor

New member
Сообщения
13
#3
Крипто Про 4.0.9944 утановил, Рутокен S установил. Не тестовой странице Крипто про Сертификаты подгружаются.
Но появилась ударгая проблема. не могу зайти на сайт госуслуг по Рутокену. Пишет что не утановлен плагин.
Хотя система автоматически указывает что нужно установить для 32 разрадный плагин, а не 64.
Плагин установлен.
Проблема наблюдается с браузерами Спутник, Яндекс,Mozilla
 

Igor

New member
Сообщения
13
#5
Да Вы Батенька, Волшебник!

Внес изменения в конфиг
{ name = "CryptoPro CSP"; alias = "cryptoprocsp"; type = "pkcs11"; lib_linux = "/opt/cprocsp/lib/amd64/libcppkcs11.so"; }, и на Мозиле заработало. Минус 1 проблема совместимости.
 

Fd1501h

Moderator
Сообщения
447
#8

ludmila

New member
Сообщения
12
#9
Орёл уже давное на debian 9 (stretch).
По этому ссыка должна быть https://packages.debian.org/stretch/pcsc-tools
По вашей ссылке пакет для старого Debian, могут быть проблемы с зависемостями на старые пакеты.
Подскажите, если установлен КриптоПро 4 и Рутокен S настроен, сертификаты установлены и на тестовой странице КриптоПро они отображаются, но при входе в Госуслуги выходит: У вас нет действующих сертификатов. Версия мозиллы 59, плагин госуслуг 3.0.0.0. в браузере он включен и про неустановленный плагин сообщений не выходит, госуслуги добавлены в исключения блокировать высплывающие окна. Изменения в /etc/ifc.cfg внесены. В чем может быть проблема?
 

ludmila

New member
Сообщения
12
#11
Здравствуйте ludmila.
Попробуйте новую версию плагина Госуслуг 3.0.3.0 под архитектуру Вашего ПК IFCPlugin-i386.deb или IFCPlugin-x86_64.deb
Добрый день! Изначально 3.0.3.0 (x64) эта версия плагина была установлена при настройке, с ней браузер мозилла 59 выдавал сообщение о том, что плагин не установлен. Мозилла 41.0.2 в дополнениях видит обе версии госуслуг 3.0.0.0 и 3.0.3.0, но так же выдает что он не установлен. Со старым плагином 2.0.6.0 версия 41 мозилла также пишет нет действующих сертификатов.
 
Последнее редактирование:

Blaze

New member
Сообщения
44
#12
Значит очередной раз "разработчики" госуслуг сломали авторизацию. Она на Windows-то работает с горем пополам =)
Попробуйте авторизоваться в госуслугах с помощью браузера спутник https://browser.sputnik.ru/ для Astra Linux (данные введите произвольные)
Затем в браузере Спутник установите >>> Расширение для плагина Госуслуг <<< (кликабельная ссылка - открыть в браузере Спутник). Закройте Спутник и после этого попробуйте зайти в личный кабинет Госуслуг.
 

ludmila

New member
Сообщения
12
#13
Значит очередной раз "разработчики" госуслуг сломали авторизацию. Она на Windows-то работает с горем пополам =)
Попробуйте авторизоваться в госуслугах с помощью браузера спутник https://browser.sputnik.ru/ для Astra Linux (данные введите произвольные)
Затем в браузере Спутник установите >>> Расширение для плагина Госуслуг <<< (кликабельная ссылка - открыть в браузере Спутник). Закройте Спутник и после этого попробуйте зайти в личный кабинет Госуслуг.
В Спутнике не заработало. Интересно получается, что в alt линукс при точно таких же версиях крипто про и плагина госуслуг и настройках ifc.cfg ( только там мозилла 52) всё заработало с 1го раза. В Astra не работает (проверено на разных машинах, криптопро переустанавливался).
 

Fd1501h

Moderator
Сообщения
447
#14
В Спутнике не заработало. Интересно получается, что в alt линукс при точно таких же версиях крипто про и плагина госуслуг и настройках ifc.cfg ( только там мозилла 52) всё заработало с 1го раза. В Astra не работает (проверено на разных машинах, криптопро переустанавливался).
В Firefox 52 используется старый формат дополнений. В firefox > 60 перешли на новый формат, из-за этого старые плагины не работают (разработчики их должны переписать под новый движок ff).
В астре установите firefox-esr (это версия длительной поддержки,там старые дополнения ещё работают)
 

Fd1501h

Moderator
Сообщения
447
#15
Так же при работе в firefox ESR (до 60) нужно использовать версию плагина IFC 2.
Для firefox > 60 версия IFC 3 и выше, но с ним пока проблемы
 

ludmila

New member
Сообщения
12
#16
Так же при работе в firefox ESR (до 60) нужно использовать версию плагина IFC 2.
Для firefox > 60 версия IFC 3 и выше, но с ним пока проблемы
Спасибо! Нет ли иформации по поводу работы эцп VipNet CSP 4.2 + IFC госуслуг? Удалось ли настроить?
 

Fd1501h

Moderator
Сообщения
447
#17
Спасибо! Нет ли иформации по поводу работы эцп VipNet CSP 4.2 + IFC госуслуг? Удалось ли настроить?
К сожалению "отошёл от этой темы" нет технической возможности протестировать. В чате телеграмм данных тем так же не было.
 

Blaze

New member
Сообщения
44
#19
DavidovichDV, на портал zakupki.gov.ru, а точнее в личный кабинет, разве можно зайти под Astra Linux?
 
Сообщения
9
#20
DavidovichDV, на портал zakupki.gov.ru, а точнее в личный кабинет, разве можно зайти под Astra Linux?
да и не только закупки, даже самый вредный сайт налоговой работает, как закончу с инструкцией, скину скриншоты подтверждения что все работает
 
Последнее редактирование: