AuthType not set!

LEB

New member
Сообщения
3
#1
Добрый день.

Пытаюсь настроить apache на astra 1.5, но не выходит, выпадает ошибка Internal Server Error и в логах(var/log/apache2/error.log ) сообщение:
[crit] [client 192.168.0.39] configuration error: couldn't perform authentication. AuthType not set!: /.
Гугление меня привело к такой же проблеме - https://ru.stackoverflow.com/questions/444412/Настройка-apache2-на-astra-linux
Так понимаю из ответа по ссылке, астра не позволяет сделать доступ к сайту без авторизации.

Может с таким кто-то уже сталкивался и нашел обходное решение?
 
Сообщения
52
#2
Добрый вечер!
Вам надо обратиться к руководству администратора (https://wiki.astralinux.ru/download...rsion=1&modificationDate=1528109650709&api=v2), стр. 195 - вкратце надо настроить тип авторизации:

<VirtualHost *:80>
ServerAdmin webmaster@localhost
ServerName server.domain.name
DocumentRoot /path/to/root/dir/
<Directory /path/to/root/dir/>
Options Indexes FollowSymLinks MultiViews195
AllowOverride None
</Directory>
ErrorLog /var/log/apache2/error.log
LogLevel warn
CustomLog /var/log/apache2/access.log combined
</VirtualHost>
 

LEB

New member
Сообщения
3
#3
Добрый день, Аркадий.

А если нужно без авторизации?
 

LEB

New member
Сообщения
3
#5
Печаль. Ладно, проблему решил тем, что заменил /usr/lib/apache2/mpm-prefork/apache2 на другой, где данной защиты не было.