Linux-версия FAR

Mischutka

New member
Сообщения
314
#63
Увы:
Bash:
far2l: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.28' not found (required by far2l)
far2l: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.27' not found (required by far2l)
 

lisco2002

New member
Сообщения
50
#66
Ясно. Да в Астре 2.12 старее libc. А этот пакет far2l собирался для Астры 1.7, она новее, основана на Дебиан 10. В названии пакета 1.7 указано.
Для 2.12 попробую тоже собрать.

Upd: Закинул в Облако.
 
Последнее редактирование:

Mischutka

New member
Сообщения
314
#67
Ясно. Да в Астре 2.12 старее libc. А этот пакет far2l собирался для Астры 1.7, она новее, основана на Дебиан 10. В названии пакета 1.7 указано.
Для 2.12 попробую тоже собрать.

Upd: Закинул в Облако.
Ура, заработало! © Премного вам благодарен! (y)
 

lisco2002

New member
Сообщения
50
#68
Собрал свежее в Астре 2.12. В Облаке папка
14-06-2023-AMD64-ASTRA-2.12

Две версии.
-nowx-
-DUSEWX=no also in this case dont need to install libwxgtk*-dev package
 
Последнее редактирование:

Mischutka

New member
Сообщения
314
#69
Собрал свежее в Астре 2.12. В Облаке папка
14-06-2023-AMD64-ASTRA-2.12

Две версии.
-nowx-
-DUSEWX=no also in this case dont need to install libwxgtk*-dev package
Состояние: Ошибка: не удалось удовлетворить зависимости

Не установлены

libgcc-s1
libgcc
libssl3
libnfs11
libnfs12
libnfs13
 

lisco2002

New member
Сообщения
50
#70
Имеено эта сборка производилась по инструкции с офф.сайта. Она прошла нормально. Инсталляция тоже.
Генерация пакета тоже по инструкции с офф. сайта, и в него прописались эти зависимости, которых нет в Астре 2.12.

Можно попробовать установить пакет явной распаковкой его.
 

Mischutka

New member
Сообщения
314
#71
Имеено эта сборка производилась по инструкции с офф.сайта. Она прошла нормально. Инсталляция тоже.
Генерация пакета тоже по инструкции с офф. сайта, и в него прописались эти зависимости, которых нет в Астре 2.12.

Можно попробовать установить пакет явной распаковкой его.
Сборка производилась в какой "Астре", особого или общего назначения?
 

lisco2002

New member
Сообщения
50
#72
Сборка производилась в какой "Астре", особого или общего назначения?
2.12. Написал выше.
2.12 всегда была Common Edition. Теперь они от нее отказались. Актуальная Астра 1.7.

Можете сами пробовать собирать и инсталлировать, а пакет не обязателен. В нем у них прописаны зависимости которые не удовлетворяются в 2.12. Либо отредактировать скрипт формирующий пакет и убрать эти зависимости. Это чистая формальность.
 

unxed

New member
Сообщения
1
#74